Skip to content

CVE 2022 33683

Lari Hotari edited this page Sep 23, 2022 · 2 revisions
Clone this wiki locally

Disabled Certificate Validation makes Broker, Proxy Admin Clients vulnerable to MITM attack (CVE-2022-33683)

PRODUCT AFFECTED:

This issue affects Apache Pulsar 2.10, 2.6 and earlier, 2.7, 2.8, 2.9.

PROBLEM:

Severity: high

Apache Pulsar Brokers and Proxies create an internal Pulsar Admin Client that does not verify peer TLS certificates, even when tlsAllowInsecureConnection is disabled via configuration. The Pulsar Admin Client's intra-cluster and geo-replication HTTPS connections are vulnerable to man in the middle attacks, which could leak authentication data, configuration data, and any other data sent by these clients.

An attacker can only take advantage of this vulnerability by taking control of a machine 'between' the client and the server. The attacker must then actively manipulate traffic to perform the attack.

This issue affects Apache Pulsar Broker and Proxy versions 2.7.0 to 2.7.4; 2.8.0 to 2.8.3; 2.9.0 to 2.9.2; 2.10.0; 2.6.4 and earlier.

This issue has been assigned CVE-2022-33683.

WORKAROUND:

Any users running affected versions of the Pulsar Broker or Pulsar Proxy should rotate static authentication data vulnerable to man in the middle attacks used by these applications, including tokens and passwords.

2.7 users should upgrade Pulsar Brokers and Proxies to 2.7.5, and rotate vulnerable authentication data, including tokens and passwords.

2.8 users should upgrade Pulsar Brokers and Proxies to 2.8.4, and rotate vulnerable authentication data, including tokens and passwords.

2.9 users should upgrade Pulsar Brokers and Proxies to 2.9.3, and rotate vulnerable authentication data, including tokens and passwords.

2.10 users should upgrade Pulsar Brokers and Proxies to 2.10.1, and rotate vulnerable authentication data, including tokens and passwords.

Any users running Pulsar Brokers and Proxies for 2.6 and earlier should upgrade to one of the above patched versions, and rotate vulnerable authentication data, including tokens and passwords.

In addition to upgrading, it is also necessary to enable hostname verification to prevent man in the middle attacks. Please see CVE-2022-33682 for more information.

RELATED LINKS:

CVE-2022-33683 at cve.mitre.org
https://lists.apache.org/thread/42v5rsxj36r3nhfxhmhb2x12r5jmvx3x

ACKNOWLEDGEMENTS:

This issue was discovered by Michael Marshall of DataStax.

Security Advisories