Skip to content

CVE 2021 41571

Lari Hotari edited this page Sep 23, 2022 · 3 revisions
Clone this wiki locally

CVE-2021-41571: Apache Pulsar: Pulsar Admin API allows access to data from other tenants using getMessageById API

Severity: moderate

Description:

In Apache Pulsar it is possible to access data from BookKeeper that does not belong to the topics accessible by the authenticated user.

The Admin API get-message-by-id requires the user to input a topic and a ledger id. The ledger id is a pointer to the data, and it is supposed to be a valid id for the topic. Authorisation controls are performed against the topic name and there is no proper validation that the ledger id is valid in the context of such ledger. So it may happen that the user is able to read from a ledger that contains data owned by another tenant.

This issue affects Apache Pulsar Apache Pulsar version 2.8.0 and prior versions; Apache Pulsar version 2.7.3 and prior versions; Apache Pulsar version 2.6.4 and prior versions.

This issue is being tracked as https://github.com/apache/pulsar/issues/11814

Mitigation:

If you are running Pulsar behind a proxy you can disable access to the REST API for the flawed API

/admin/v2/non-persistent/{tenant}/{namespace}/{topic}/ledger/{ledgerId}/entry/{entryId}

RELATED LINKS:

CVE-2021-41571 at cve.mitre.org
https://pulsar.apache.org/admin-rest-api/#operation/getLastMessageId
https://github.com/apache/pulsar/issues/11814
https://lists.apache.org/thread/8n3k7pvyh4cf9q2jfzb6pb32ync6xlvr

Security Advisories