Skip to content
Browse files

unicorn 4.2.0

The GPLv3 is now an option to the Unicorn license.  The existing GPLv2
and Ruby-only terms will always remain options, but the GPLv3 is
preferred.

Daemonization is correctly detected on all terminals for development
use (Brian P O'Rourke).

Unicorn::OobGC respects applications that disable GC entirely
during application dispatch (Yuichi Tateno).

Many test fixes for OpenBSD, which may help other *BSDs, too.
(Jeremy Evans).

There is now _optional_ SSL support (via the "kgio-monkey"
RubyGem).  On fast, secure LANs, SSL is only intended for
detecting data corruption that weak TCP checksums cannot detect.
Our SSL support is remains unaudited by security experts.

There are also some minor bugfixes and documentation
improvements.

Ruby 2.0.0dev also has a copy-on-write friendly GC which can save memory
when combined with "preload_app true", so if you're in the mood, start
testing Unicorn with the latest Ruby!
  • Loading branch information...
1 parent 8478a54 commit b6a154eba6d79fd1572f61290e55f4d05df86730 Eric Wong committed Jan 28, 2012
Showing with 2 additions and 2 deletions.
  1. +1 −1 GIT-VERSION-GEN
  2. +1 −1 lib/unicorn/const.rb
View
2 GIT-VERSION-GEN
@@ -1,7 +1,7 @@
#!/bin/sh
GVF=GIT-VERSION-FILE
-DEF_VER=v4.1.1.GIT
+DEF_VER=v4.2.0.GIT
LF='
'
View
2 lib/unicorn/const.rb
@@ -8,7 +8,7 @@
# improve things much compared to constants.
module Unicorn::Const
- UNICORN_VERSION = "4.1.1"
+ UNICORN_VERSION = "4.2.0"
# default TCP listen host address (0.0.0.0, all interfaces)
DEFAULT_HOST = "0.0.0.0"

0 comments on commit b6a154e

Please sign in to comment.
Something went wrong with that request. Please try again.