Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Downgrade `strip-ansi` package #2692

Merged
merged 1 commit into from Jun 29, 2017

Conversation

Projects
None yet
3 participants
@pdhoopr
Copy link
Contributor

commented Jun 29, 2017

This should fix #2691.

strip-ansi v4.0.0 (used by react-dev-utils) updates ansi-regex to v3.0.0, which exports an arrow function instead of a regular function. Internet Explorer 11 doesn't support arrow functions, so in development the app throws a syntax error and won't load. Downgrading to the previous version of strip-ansi (v3.0.1) also downgrades ansi-regex and should resolve the issue.

@facebook-github-bot

This comment has been minimized.

Copy link

commented Jun 29, 2017

Thank you for your pull request and welcome to our community. We require contributors to sign our Contributor License Agreement, and we don't seem to have you on file. In order for us to review and merge your code, please sign up at https://code.facebook.com/cla. If you are contributing on behalf of someone else (eg your employer), the individual CLA may not be sufficient and your employer may need the corporate CLA signed.

If you have received this in error or have any questions, please contact us at cla@fb.com. Thanks!

@facebook-github-bot

This comment has been minimized.

Copy link

commented Jun 29, 2017

Thank you for signing our Contributor License Agreement. We can now accept your code for this (and any) Facebook open source project. Thanks!

@gaearon

This comment has been minimized.

Copy link
Member

commented Jun 29, 2017

Can you verify it worked?

@gaearon gaearon added this to the 1.0.10 milestone Jun 29, 2017

@gaearon gaearon merged commit 5e11b48 into facebook:master Jun 29, 2017

0 of 2 checks passed

continuous-integration/appveyor/pr Waiting for AppVeyor build to complete
Details
continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
@pdhoopr

This comment has been minimized.

Copy link
Contributor Author

commented Jun 29, 2017

Sure! I just followed the instructions to start the app from the "Setting Up a Local Copy" section of CONTRIBUTING.md, and the app loads as expected. Sorry for the slightly delayed verification!

screen shot 2017-06-29 at 1 06 19 pm

@gaearon gaearon referenced this pull request Jun 29, 2017

Merged

Changelog for 1.0.10 #2694

zangrafx added a commit to absolvent/create-react-app that referenced this pull request Jun 30, 2017

Merge remote-tracking branch 'upstream/master'
* upstream/master:
  Publish
  Changelog for 1.0.10 (facebook#2694)
  Update CHANGELOG.md
  Upgrade flow (facebook#2693)
  Added `gluestick` to the alternatives section (facebook#2402)
  Downgrade `strip-ansi` package to 3.0.1 (facebook#2692)
  Fix typo (facebook#2683)
  Fix typo in README link (facebook#2684)
  Publish
  Changelog for 1.0.9 (facebook#2682)
  Fix external CSS imports (facebook#2680)

# Conflicts:
#	packages/react-dev-utils/package.json
#	packages/react-scripts/package.json

romaindso added a commit to romaindso/create-react-app that referenced this pull request Jul 10, 2017

wmonk referenced this pull request in wmonk/create-react-app-typescript Aug 7, 2017

timneutkens added a commit to zeit/next.js that referenced this pull request Aug 28, 2017

morgs32 added a commit to BrickworkSoftware/create-react-app that referenced this pull request Sep 1, 2017

@afc163 afc163 referenced this pull request Nov 23, 2017

Closed

0.2.2 throw error in IE11 #210

ipaintcode added a commit to ipaintcode/razzle that referenced this pull request Mar 21, 2018

Patching for IE11
Mirroring the patch for react-dev-utils that causes dev utils to break in IE11. strip-ansi package arrow function is causing this issue. See react-dev-utils patch PR that was accepted to fix this issue: facebook/create-react-app#2692

@ipaintcode ipaintcode referenced this pull request Mar 21, 2018

Merged

Patching for IE11 #547

jaredpalmer added a commit to jaredpalmer/razzle that referenced this pull request Mar 23, 2018

Patching for IE11 (#547)
Mirroring the patch for react-dev-utils that causes dev utils to break in IE11. strip-ansi package arrow function is causing this issue. See react-dev-utils patch PR that was accepted to fix this issue: facebook/create-react-app#2692

@KagamiChan KagamiChan referenced this pull request Aug 14, 2018

Merged

Bump dependencies #3785

tannerkozlowski pushed a commit to tannerkozlowski/react-razzle that referenced this pull request Dec 18, 2018

Patching for IE11 (#547)
Mirroring the patch for react-dev-utils that causes dev utils to break in IE11. strip-ansi package arrow function is causing this issue. See react-dev-utils patch PR that was accepted to fix this issue: facebook/create-react-app#2692

@lock lock bot locked and limited conversation to collaborators Jan 21, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.