Skip to content

@gaearon gaearon released this Jan 15, 2018 · 951 commits to master since this release

1.1.0 (January 15, 2018)

🚀 New Feature

  • react-scripts

    • #3387 Add support for variable expansion in .env files. (@moos)
  • react-error-overlay

    • #3474 Allow the error overlay to be unregistered. (@Timer)
  • create-react-app

🐛 Bug Fix

  • babel-preset-react-app, react-scripts

    • #3788 Fix object destructuring inside an array on Node 6. (@gaearon)
  • react-dev-utils

  • create-react-app

  • react-scripts

    • #3537 Add mjs and jsx filename extensions to file-loader exclude pattern. (@iansu)
    • #3511 Unmount the component in the default generated test. (@gaearon)

💅 Enhancement

  • react-scripts

  • create-react-app

  • react-dev-utils

  • react-dev-utils, react-error-overlay

  • react-dev-utils, react-scripts

    • #3721 Support setting none in REACT_EDITOR environment variable. (@raerpo)
  • eslint-config-react-app

📝 Documentation

🏠 Internal

Committers: 47

Migrating from 1.0.17 to 1.1.0

Inside any created project that has not been ejected, run:

npm install --save --save-exact react-scripts@1.1.0

or

yarn add --exact react-scripts@1.1.0
Assets 2
You can’t perform that action at this time.