Permalink
Find file
f6a4cc7 Sep 26, 2014
25 lines (18 sloc) 680 Bytes
You must first install a recent version of
- OCaml (at least 4.00.1), and camlp4 (not part of OCaml since 4.02)
see http://caml.inria.fr/download.en.html
- GTK (at least gtk 2.10) and Cairo
if you want codemap and codegraph, the fancy graphics code visualizers
- SWI-prolog
if you want the interactive code query tool
- Java (for bddbddb)
if you want the datalog pointer analysis
If you want most of the good things just type:
$ ./configure
$ make depend
$ make
$ make opt
This should generate a few binaries at the toplevel directory such
as pfff or codemap.
If you just want to compile the parsing frontends, then type:
$ ./configure -novisual