updates thor to be compatible with Rails #4

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
2 participants
@xentek

xentek commented Oct 11, 2012

  • uses nearly the same version dependency declaration that rails/railties does, which should mean that we can count on this being compatible for some time
  • specs still pass
updates thor to be compatible with Rails
  - uses nearly the same version dependency declaration that
    rails/railties does, which should mean that we can count on this
    being compatible for some time
  - specs still pass
@rykov

This comment has been minimized.

Show comment Hide comment
@rykov

rykov Oct 19, 2012

Contributor

Any reason to restrict to 0.15 and higher if 0.14 still works?

Contributor

rykov commented Oct 19, 2012

Any reason to restrict to 0.15 and higher if 0.14 still works?

@xentek

This comment has been minimized.

Show comment Hide comment
@xentek

xentek Oct 19, 2012

So currently stable 3.2 version of thor allowed by rails/railties is >= 0.14.6, < 2.0 (see: https://github.com/rails/rails/blob/3-2-stable/railties/railties.gemspec )

HEAD rails/railties has it at >= 15.4, < 2.0 (see: https://github.com/rails/rails/blob/master/railties/railties.gemspec )

My thinking was that by setting gemfury's dependency to >= 0.15, < 2.0 would allow it to keep satisfy both versions (since 0.15.4 would be selected if they were testing rails 4 stuff and running on rails master, and anything over 0.14 is compatible with the current 3.2 branch).

Given that thor is currently at 0.16, this seemed like the most pragmatic approach to ensure a wide range of compatibility with rails, currently and for the forseeable future.

xentek commented Oct 19, 2012

So currently stable 3.2 version of thor allowed by rails/railties is >= 0.14.6, < 2.0 (see: https://github.com/rails/rails/blob/3-2-stable/railties/railties.gemspec )

HEAD rails/railties has it at >= 15.4, < 2.0 (see: https://github.com/rails/rails/blob/master/railties/railties.gemspec )

My thinking was that by setting gemfury's dependency to >= 0.15, < 2.0 would allow it to keep satisfy both versions (since 0.15.4 would be selected if they were testing rails 4 stuff and running on rails master, and anything over 0.14 is compatible with the current 3.2 branch).

Given that thor is currently at 0.16, this seemed like the most pragmatic approach to ensure a wide range of compatibility with rails, currently and for the forseeable future.

@rykov

This comment has been minimized.

Show comment Hide comment
@rykov

rykov Oct 20, 2012

Contributor

@xentek - we prefer to stay conservative with our dependencies to verify that everything works before incrementing them forward. I've retested our gem with 0.14.x, 0.15.x and 0.16.x versions of thor and expanded the dependency range to < 1.0. This should hold us over for the foreseeable future. It's worth going through this upgrade loop again when thor hits 1.0 to make sure nothing breaks in the meantime.

Thanks for pointing this out.

Contributor

rykov commented Oct 20, 2012

@xentek - we prefer to stay conservative with our dependencies to verify that everything works before incrementing them forward. I've retested our gem with 0.14.x, 0.15.x and 0.16.x versions of thor and expanded the dependency range to < 1.0. This should hold us over for the foreseeable future. It's worth going through this upgrade loop again when thor hits 1.0 to make sure nothing breaks in the meantime.

Thanks for pointing this out.

@rykov rykov closed this Oct 20, 2012

@xentek

This comment has been minimized.

Show comment Hide comment
@xentek

xentek Oct 20, 2012

Sure, that's fine. This solves my immediate problem, and that's what counts in the end. Thanks!

xentek commented Oct 20, 2012

Sure, that's fine. This solves my immediate problem, and that's what counts in the end. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment