Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/build: git errors with gnutls_handshake() failed: Error in the pull function. #52820

Open
bcmills opened this issue May 10, 2022 · 1 comment
Open
Labels
Builders NeedsInvestigation
Milestone

Comments

@bcmills
Copy link
Member

@bcmills bcmills commented May 10, 2022

            > go get -d insecure.go-get-issue-15410.appspot.com/pkg/p
            [stderr]
            # cd $WORK/gopath/src/insecure.go-get-issue-15410.appspot.com; git clone -- http://insecure.go-get-issue-15410.appspot.com/ $WORK/gopath/src/insecure.go-get-issue-15410.appspot.com/pkg
            Cloning into '$WORK/gopath/src/insecure.go-get-issue-15410.appspot.com/pkg'...
            fatal: unable to access 'http://insecure.go-get-issue-15410.appspot.com/': gnutls_handshake() failed: Error in the pull function.
            package insecure.go-get-issue-15410.appspot.com/pkg/p: exit status 128

greplogs -l -e 'gnutls_handshake() failed: Error in the pull function.'`
2022-05-09T20:57:58-3f43096/linux-386-longtest
2021-12-13T16:44:13-acc65b4/linux-amd64-longtest
2021-11-08T14:49:56-ab31dbc/linux-386-longtest
2021-10-26T15:20:53-1b2362b/linux-386-longtest
2021-10-23T16:18:15-12e4404/linux-386-longtest
2021-10-20T20:39:29-1dff8f0/linux-386-longtest
2021-10-20T05:28:45-b091189/linux-386-longtest
2021-10-20T05:28:45-b091189/linux-amd64-longtest
2021-10-19T18:56:08-07e5527/linux-386-longtest
2021-10-19T18:43:08-1d63052/linux-386-longtest
2021-10-19T18:18:37-9820602/linux-386-longtest
2021-10-11T22:34:49-d90f0b9/linux-386-longtest
2021-09-08T11:57:03-9295723/linux-386-longtest
2021-04-11T15:56:20-189c694/linux-amd64-longtest
2021-04-06T21:25:55-0bc4605/linux-386-longtest
2021-04-03T21:06:18-9e7bc80/linux-386-longtest
2020-10-29T16:26:43-25d28ec/linux-386-longtest

@gopherbot gopherbot added the Builders label May 10, 2022
@gopherbot gopherbot added this to the Unreleased milestone May 10, 2022
@bcmills
Copy link
Member Author

@bcmills bcmills commented May 10, 2022

I suspect that this indicates some kind of network error or internal server error, but it would be nice to get a better error message out of it.

Some cursory searching suggests:

  • Upgrade git. (linux-386-longtest currently has git version 2.30.2, whereas the current release is 2.36.1)
  • Upgrade libcurl3-gnutls (linux-386-longtest has 7.74.0, current is 7.83.0)
  • Upgrade libgnutls30(linux-386-longtest has 3.7.1-5, current is 3.7.4-2)

@bcmills bcmills removed this from the Unreleased milestone May 10, 2022
@bcmills bcmills added this to the Backlog milestone May 10, 2022
@bcmills bcmills removed this from the Backlog milestone May 10, 2022
@bcmills bcmills added this to the Unplanned milestone May 10, 2022
@heschi heschi added the NeedsInvestigation label May 10, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Builders NeedsInvestigation
Projects
None yet
Development

No branches or pull requests

3 participants