New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Strange with russian letters in editor in Windows #155

Closed
nrukin opened this Issue Jan 10, 2018 · 5 comments

Comments

Projects
None yet
2 participants
@nrukin
Copy link

nrukin commented Jan 10, 2018

Operating system

  • Windows
  • macOS
  • Linux
  • Android
  • iOS

Application

  • Desktop
  • Mobile
  • Terminal

If it is a bug if possible please provide a screenshot showing the problem

If there is an error, please copy and paste the full error message


Hello,
i've found strange behavior with russian letters in editor - real cursor position and displayed cursor position are different. Longer the string - bigger the differ

in attached gif i've writed some letters, then put cursor in the middle of the string and pressed backspace.

joplin_rus

Thanks!

@laurent22

This comment has been minimized.

Copy link
Owner

laurent22 commented Jan 10, 2018

Does it do this in this demo too? https://ace.c9.io/build/kitchen-sink.html

@nrukin

This comment has been minimized.

Copy link

nrukin commented Jan 10, 2018

yes

@laurent22

This comment has been minimized.

Copy link
Owner

laurent22 commented Jan 10, 2018

I have filed a report on the text editor component and will see if they have any solution to propose. Otherwise, I will see if it works with a different font.

ajaxorg/ace#3506

@nrukin

This comment has been minimized.

Copy link

nrukin commented Jan 11, 2018

Thanks!
i've tested it on three different computers (win10, win8), but problem occurred only at one of them

i've found some issues with ace and other apps using ace: seems to be it should use only monospace font

swagger-api/swagger-editor#703
ajaxorg/ace#1078
jpillora/docker-dnsmasq#4
https://stackoverflow.com/questions/15183031/ace-editor-cursor-behaves-incorrectly

@laurent22 laurent22 closed this in f710463 Jan 15, 2018

@laurent22

This comment has been minimized.

Copy link
Owner

laurent22 commented Jan 15, 2018

Ok that should be fixed in the release after the next one (so after 0.10.47). It was due to the editor not using monospace font.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment