Skip to content
This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Create an OpenGL 1.1 context by default, if available.

This is easier for people to set up and work with, and is more conformant to the way desktop OpenGL works.
  • Loading branch information
slouken committed Feb 7, 2011
1 parent f9dd606 commit c66258259163f809fb0510580791314ba22730c1
Showing with 3 additions and 3 deletions.
  1. +3 −3 src/video/SDL_video.c
@@ -488,12 +488,12 @@ SDL_VideoInit(const char *driver_name)
#if SDL_VIDEO_OPENGL
_this->gl_config.major_version = 2;
_this->gl_config.minor_version = 1;
#elif SDL_VIDEO_OPENGL_ES2
_this->gl_config.major_version = 2;
_this->gl_config.minor_version = 0;
#elif SDL_VIDEO_OPENGL_ES
_this->gl_config.major_version = 1;
_this->gl_config.minor_version = 1;
#elif SDL_VIDEO_OPENGL_ES2
_this->gl_config.major_version = 2;
_this->gl_config.minor_version = 0;
#endif

/* Initialize the video subsystem */

0 comments on commit c662582

Please sign in to comment.