Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

GBC - Loading quick saves on screen transitions makes games mute #1305

Closed
themalu866 opened this issue Feb 13, 2019 · 6 comments
Closed

GBC - Loading quick saves on screen transitions makes games mute #1305

themalu866 opened this issue Feb 13, 2019 · 6 comments

Comments

@themalu866
Copy link

@themalu866 themalu866 commented Feb 13, 2019

Playing on Windows, the music plays just fine and I quick save, then I die, or go to the next level, or enter a bonus/warp, it doesn't matter, at the exact moment when the screen fades and there's a brief SILENCE if I quick load on that moment the level music don't play and only returns if I die or go to different screen.

As far as I know this only happens when there is this quiet moment, it doesn't seem to happen with games where the transition is instantaneous but I not sure. And maybe that happens with GB games too.

Donkey Kong Land 2.zip

Donkey Kong Land III.zip

@endrift
Copy link
Member

@endrift endrift commented Aug 12, 2020

This is likely fixed on latest dev builds. Please retest.

@themalu866
Copy link
Author

@themalu866 themalu866 commented Aug 24, 2020

I checked on Donkey Kong Land III and still happens.

@endrift
Copy link
Member

@endrift endrift commented Aug 24, 2020

Was this with a save state you made on the newer builds? Old save states may have been created with errors in them as a result of bugs.

@endrift
Copy link
Member

@endrift endrift commented Aug 24, 2020

Never mind, I can reproduce.

@themalu866
Copy link
Author

@themalu866 themalu866 commented Aug 24, 2020

It's a new save but this time the glitch is kinda different.
If I quick load at silent moments it still gets mute, but if I close mgba, quick load really fast then the music partially plays and if I wait for the title screen to appears and then load it the music plays fine.
This is only happening with Donkey Kong Land III, Donkey Kong Land 2 is fine.
Donkey Kong Land III.zip

endrift added a commit that referenced this issue Aug 24, 2020
@endrift endrift closed this in 27b3102 Aug 24, 2020
@endrift
Copy link
Member

@endrift endrift commented Aug 24, 2020

Turns out the commit I thought I fixed this in broke something related in the process. It's properly fixed now.

RetroEdit added a commit to TASVideos/mgba that referenced this issue Sep 13, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.