Votainteligente es el portal electoral de la Fundación Ciudadano Inteligente , lo estamos rehaciendo para que puedan utilizarlo en toda latinoamérica.
Pull request Compare This branch is 2310 commits behind ciudadanointeligente:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
elections
votainteligente
.coveragerc
.gitignore
.travis.yml
LICENSE
README.md
candidator_example_data.yaml
coverage.sh
example_data.yaml
manage.py
question.yml
requirements-amazon.txt
requirements.txt
start_local_candidator.bash
start_local_popit_api.bash
start_local_writeit.bash
test.sh
upgrade.sh
upgrade_data.sh
upgrade_ubuntu.sh
writeit-example-data.yaml

README.md

votainteligente-portal-electoral

Build Status Coverage Status

Votainteligente the electoral platform that Fundación Ciudadano Inteligente uses to transparent the electoral positions of different candidates to an election.

#Installation

VotaInteligente depends on 3 parts candideit.org, popit and write-it. You might choose to use all of them or just part. In the following document it is described how to install.

Assumptions

This guide was made using an ubuntu 13.10 just installed.

Requirements

Before the installation process is started a number of requirements is needed

Installation process

  • Clone votainteligente somewhere in your system.

git clone https://github.com/ciudadanointeligente/votainteligente-portal-electoral.git

Enter the installation directory

cd votainteligente-portal-electoral

  • Create a virtual environment

mkvirtualenv votainteligente

Here you can optionally give the command the full path to the installation directory by adding -a <full_path>.

  • If you didn't use the -a option you'll have to cd into the directory.

cd votainteligente-portal-electoral

  • Install the requirements that votainteligente needs in the current virtualenvironment

pip install -r requirements.txt

It might take some time to get all installed

  • Create the database and tables.

python manage.py syncdb

Update the tables with migrations

python manage.py migrate

Bringing elections from candideit.org

Elections in VotaInteligente have a one-to-one relation with elections in candideit.org, so for your installation you'll first need to create an election in candideit.org and follow the next steps.

Specifically for this installation we are not using popit (But we'll soon be doing so).

  • Create the file votainteligente/local_settings.py with the following content.
USE_POPIT = False

CANDIDEITORG_URL = http://candideit.org/api/v2/'

CANDIDEITORG_USERNAME = 'YOUR-CANDIDEITORG-USERNAME'

CANDIDEITORG_API_KEY = 'YOUR-CANDIDEITORG-APIKEY'

  • Getting your elections from candideit.org into your installation.

You need to run the following command

python manage.py update_from_candidator

  • Running VotaInteligente

python manage.py runserver

And hit http://localhost:8000/.

Theming

Previously created themes

Creating your own custom theme

If you want to create a new theme you have to create a directory containing two different subdirectories templates and static, and copy the templates that you want to replace.

And in your project in your local_settings.py file you have to add the following

 STATICFILES_DIRS = (
     '/full/path/to/your/theme/static/',
 )
 TEMPLATE_DIRS = (
     '/full/path/to/your/theme/templates/',
 )

Localization

If you want to help us translate votainteligente please join our project in poeditor.com

Licensing

VotaInteligente is free and released as open source software covered by the terms of the GNU Public License (GPL v3)