Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

build(deps-dev): bump prettier from 3.0.3 to 3.1.0 #282

Merged
merged 1 commit into from Nov 15, 2023

Conversation

dependabot[bot]
Copy link
Contributor

@dependabot dependabot bot commented on behalf of github Nov 15, 2023

Bumps prettier from 3.0.3 to 3.1.0.

Release notes

Sourced from prettier's releases.

3.1.0

diff

馃敆 Release note

Changelog

Sourced from prettier's changelog.

3.1.0

diff

馃敆 Release Notes

Commits
  • e8ac9f8 Release 3.1.0
  • 6a1d409 chore(deps): update dependency eslint-plugin-regexp to v2 (#15521)
  • f4d93d3 chore(deps): update dependency esbuild to v0.19.5 (#15630)
  • 4fc71a5 chore(deps): update dependency flow-parser to v0.221.0 (#15637)
  • d452f45 chore(deps): update dependency eslint-plugin-jest to v27.6.0 (#15635)
  • eb84a60 chore(deps): update dependency @鈥媡ypes/estree to v1.0.5 (#15625)
  • 2af23ee chore(deps): update dependency webpack to v5.89.0 (#15640)
  • 8f27c73 chore(deps): update dependency eslint-plugin-unicorn to v49 (#15642)
  • cdc5f5a chore(deps): update dependency webpack to v5.89.0 (#15639)
  • 14607ef chore(deps): update dependency eslint-plugin-n to v16.3.1 (#15636)
  • Additional commits viewable in compare view

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot show <dependency name> ignore conditions will show all of the ignore conditions of the specified dependency
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

Bumps [prettier](https://github.com/prettier/prettier) from 3.0.3 to 3.1.0.
- [Release notes](https://github.com/prettier/prettier/releases)
- [Changelog](https://github.com/prettier/prettier/blob/main/CHANGELOG.md)
- [Commits](prettier/prettier@3.0.3...3.1.0)

---
updated-dependencies:
- dependency-name: prettier
  dependency-type: direct:development
  update-type: version-update:semver-minor
...

Signed-off-by: dependabot[bot] <support@github.com>
@dependabot dependabot bot added the dependencies Pull requests that update a dependency file label Nov 15, 2023
@actions-bot actions-bot enabled auto-merge (squash) November 15, 2023 05:52
Copy link

github-actions bot commented Nov 15, 2023

This is a multi-line test comment

Edit: Some additional info

Copy link

github-actions bot commented Nov 15, 2023

This is a multi-line test comment read from a file.
This is the second line. This is still the second line.

Copy link

github-actions bot commented Nov 15, 2023

This is a multi-line test comment

Edit: Some additional info

Copy link

github-actions bot commented Nov 15, 2023

This is a multi-line test comment read from a file.
This is the second line. This is still the second line.

@actions-bot actions-bot merged commit b2c2ea4 into main Nov 15, 2023
5 checks passed
@dependabot dependabot bot deleted the dependabot/npm_and_yarn/prettier-3.1.0 branch November 15, 2023 05:56
renovate bot added a commit to 4m-mazi/gh-test that referenced this pull request Jan 25, 2024
)

[![Mend
Renovate](https://app.renovatebot.com/images/banner.svg)](https://renovatebot.com)

This PR contains the following updates:

| Package | Type | Update | Change |
|---|---|---|---|
|
[peter-evans/create-or-update-comment](https://togithub.com/peter-evans/create-or-update-comment)
| action | major | `v3.1.0` -> `v4.0.0` |

---

### Release Notes

<details>
<summary>peter-evans/create-or-update-comment
(peter-evans/create-or-update-comment)</summary>

###
[`v4.0.0`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v4.0.0):
Create or Update Comment v4.0.0

[Compare
Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v3.1.0...v4.0.0)

鈿欙笍  Updated runtime to Node.js 20

- The action now requires a minimum version of
[v2.308.0](https://togithub.com/actions/runner/releases/tag/v2.308.0)
for the Actions runner. Update self-hosted runners to v2.308.0 or later
to ensure compatibility.

##### What's Changed

- build(deps): bump actions/setup-node from 3 to 4 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#273
- build(deps-dev): bump
[@&#8203;vercel/ncc](https://togithub.com/vercel/ncc) from 0.38.0 to
0.38.1 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#274
- build(deps-dev): bump eslint-plugin-jest from 27.4.2 to 27.4.3 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#276
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.18.5 to
18.18.6 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#277
- build(deps-dev): bump eslint from 8.51.0 to 8.52.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#275
- build(deps-dev): bump eslint-plugin-jest from 27.4.3 to 27.6.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#278
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.18.6 to
18.18.8 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#279
- build(deps-dev): bump eslint from 8.52.0 to 8.53.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#280
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.18.8 to
18.18.9 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#281
- build(deps-dev): bump prettier from 3.0.3 to 3.1.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#282
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.18.9 to
18.18.12 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#283
- build(deps-dev): bump eslint from 8.53.0 to 8.54.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#284
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.18.12 to
18.18.13 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#285
- build(deps-dev): bump eslint from 8.54.0 to 8.55.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#286
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.18.13 to
18.19.2 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#287
- build(deps): bump chuhlomin/render-template from 1.8 to 1.9 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#288
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.19.2 to
18.19.3 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#289
- build(deps-dev): bump prettier from 3.1.0 to 3.1.1 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#290
- build(deps-dev): bump eslint-plugin-prettier from 5.0.1 to 5.1.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#292
- build(deps-dev): bump eslint from 8.55.0 to 8.56.0 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#293
- build(deps): bump actions/download-artifact from 3 to 4 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#295
- build(deps-dev): bump eslint-plugin-prettier from 5.1.0 to 5.1.2 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#296
- build(deps-dev): bump eslint-plugin-jest from 27.6.0 to 27.6.1 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#297
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.19.3 to
18.19.4 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#298
- build(deps-dev): bump eslint-plugin-prettier from 5.1.2 to 5.1.3 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#299
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.19.4 to
18.19.6 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#300
- build(deps-dev): bump prettier from 3.1.1 to 3.2.3 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#301
- build(deps-dev): bump eslint-plugin-jest from 27.6.1 to 27.6.3 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#302
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.19.6 to
18.19.7 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#303
- build(deps-dev): bump
[@&#8203;types/node](https://togithub.com/types/node) from 18.19.7 to
18.19.8 by [@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#304
- build(deps-dev): bump prettier from 3.2.3 to 3.2.4 by
[@&#8203;dependabot](https://togithub.com/dependabot) in
[peter-evans/create-or-update-comment#305
- feat: update runtime to node 20 by
[@&#8203;peter-evans](https://togithub.com/peter-evans) in
[peter-evans/create-or-update-comment#306

**Full Changelog**:
peter-evans/create-or-update-comment@v3.1.0...v4.0.0

</details>

---

### Configuration

馃搮 **Schedule**: Branch creation - At any time (no schedule defined),
Automerge - At any time (no schedule defined).

馃殾 **Automerge**: Enabled.

鈾 **Rebasing**: Whenever PR is behind base branch, or you tick the
rebase/retry checkbox.

馃敃 **Ignore**: Close this PR and you won't be reminded about this update
again.

---

This PR has been generated by [Mend
Renovate](https://www.mend.io/free-developer-tools/renovate/). View
repository job log
[here](https://developer.mend.io/github/Mogyuchi/gh-test).

<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiIzNy4xMzUuMCIsInVwZGF0ZWRJblZlciI6IjM3LjEzNS4wIiwidGFyZ2V0QnJhbmNoIjoibWFpbiJ9-->

Co-authored-by: renovate[bot] <29139614+renovate[bot]@users.noreply.github.com>
Brooooooklyn pushed a commit to rolldown/rolldown that referenced this pull request Mar 9, 2024
[![Mend Renovate](https://app.renovatebot.com/images/banner.svg)](https://renovatebot.com)

This PR contains the following updates:

| Package | Type | Update | Change |
|---|---|---|---|
| [peter-evans/create-or-update-comment](https://togithub.com/peter-evans/create-or-update-comment) | action | major | `v1.4.5` -> `v4.0.0` |

---

### Release Notes

<details>
<summary>peter-evans/create-or-update-comment (peter-evans/create-or-update-comment)</summary>

### [`v4.0.0`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v4.0.0): Create or Update Comment v4.0.0

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v3.1.0...v4.0.0)

鈿欙笍  Updated runtime to Node.js 20

-   The action now requires a minimum version of [v2.308.0](https://togithub.com/actions/runner/releases/tag/v2.308.0) for the Actions runner. Update self-hosted runners to v2.308.0 or later to ensure compatibility.

#### What's Changed

-   build(deps): bump actions/setup-node from 3 to 4 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#273
-   build(deps-dev): bump [@&#8203;vercel/ncc](https://togithub.com/vercel/ncc) from 0.38.0 to 0.38.1 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#274
-   build(deps-dev): bump eslint-plugin-jest from 27.4.2 to 27.4.3 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#276
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.18.5 to 18.18.6 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#277
-   build(deps-dev): bump eslint from 8.51.0 to 8.52.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#275
-   build(deps-dev): bump eslint-plugin-jest from 27.4.3 to 27.6.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#278
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.18.6 to 18.18.8 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#279
-   build(deps-dev): bump eslint from 8.52.0 to 8.53.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#280
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.18.8 to 18.18.9 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#281
-   build(deps-dev): bump prettier from 3.0.3 to 3.1.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#282
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.18.9 to 18.18.12 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#283
-   build(deps-dev): bump eslint from 8.53.0 to 8.54.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#284
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.18.12 to 18.18.13 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#285
-   build(deps-dev): bump eslint from 8.54.0 to 8.55.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#286
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.18.13 to 18.19.2 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#287
-   build(deps): bump chuhlomin/render-template from 1.8 to 1.9 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#288
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.19.2 to 18.19.3 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#289
-   build(deps-dev): bump prettier from 3.1.0 to 3.1.1 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#290
-   build(deps-dev): bump eslint-plugin-prettier from 5.0.1 to 5.1.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#292
-   build(deps-dev): bump eslint from 8.55.0 to 8.56.0 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#293
-   build(deps): bump actions/download-artifact from 3 to 4 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#295
-   build(deps-dev): bump eslint-plugin-prettier from 5.1.0 to 5.1.2 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#296
-   build(deps-dev): bump eslint-plugin-jest from 27.6.0 to 27.6.1 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#297
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.19.3 to 18.19.4 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#298
-   build(deps-dev): bump eslint-plugin-prettier from 5.1.2 to 5.1.3 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#299
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.19.4 to 18.19.6 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#300
-   build(deps-dev): bump prettier from 3.1.1 to 3.2.3 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#301
-   build(deps-dev): bump eslint-plugin-jest from 27.6.1 to 27.6.3 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#302
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.19.6 to 18.19.7 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#303
-   build(deps-dev): bump [@&#8203;types/node](https://togithub.com/types/node) from 18.19.7 to 18.19.8 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#304
-   build(deps-dev): bump prettier from 3.2.3 to 3.2.4 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#305
-   feat: update runtime to node 20 by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#306

**Full Changelog**: peter-evans/create-or-update-comment@v3.1.0...v4.0.0

### [`v3.1.0`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v3.1.0): Create or Update Comment v3.1.0

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v3.0.2...v3.1.0)

#### What's Changed

-   Add truncate warning to body of comment by [@&#8203;ethanmdavidson](https://togithub.com/ethanmdavidson) and [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#272
-   46 dependency updates by [@&#8203;dependabot](https://togithub.com/dependabot)

**Full Changelog**: peter-evans/create-or-update-comment@v3.0.2...v3.1.0

### [`v3.0.2`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v3.0.2): Create or Update Comment v3.0.2

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v3.0.1...v3.0.2)

#### What's Changed

-   Truncate long comment bodies during comment update too by [@&#8203;Dermah](https://togithub.com/Dermah) in [peter-evans/create-or-update-comment#205
-   Update distribution by [@&#8203;actions-bot](https://togithub.com/actions-bot) in [peter-evans/create-or-update-comment#210
-   23 dependency updates by [@&#8203;dependabot](https://togithub.com/dependabot)

#### New Contributors

-   [@&#8203;Dermah](https://togithub.com/Dermah) made their first contribution in [peter-evans/create-or-update-comment#205

**Full Changelog**: peter-evans/create-or-update-comment@v3.0.1...v3.0.2

### [`v3.0.1`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v3.0.1): Create or Update Comment v3.0.1

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v3.0.0...v3.0.1)

#### What's Changed

-   fix: find-comment version by [@&#8203;ematipico](https://togithub.com/ematipico) in [peter-evans/create-or-update-comment#164
-   fix: truncate body when it exceeds the max length by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#182
-   12 dependency updates by [@&#8203;dependabot](https://togithub.com/dependabot)

#### New Contributors

-   [@&#8203;ematipico](https://togithub.com/ematipico) made their first contribution in [peter-evans/create-or-update-comment#164

**Full Changelog**: peter-evans/create-or-update-comment@v3.0.0...v3.0.1

### [`v3.0.0`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v3.0.0): Create or Update Comment v3.0.0

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v2.1.1...v3.0.0)

#### What's new

-   Now supports replacing reactions on a comment by setting input `reactions-edit-mode` to `replace`. The default behaviour has not changed and will `append` reactions.
-   Chose how the action should append the comment body with input `append-separator`. The default behaviour is to add a `newline`. Other options are `space` and `none`.
-   `body-file` is deprecated in favour of `body-path`. The behaviour is unchanged.

#### What's Changed

-   v3 by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#161
-   Update some links in the README by [@&#8203;Kurt-von-Laven](https://togithub.com/Kurt-von-Laven) in [peter-evans/create-or-update-comment#152
-   9 dependency updates by [@&#8203;dependabot](https://togithub.com/dependabot)

#### New Contributors

-   [@&#8203;Kurt-von-Laven](https://togithub.com/Kurt-von-Laven) made their first contribution in [peter-evans/create-or-update-comment#152

**Full Changelog**: peter-evans/create-or-update-comment@v2.1.1...v3.0.0

### [`v2.1.1`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v2.1.1): Create or Update Comment v2.1.1

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v2.1.0...v2.1.1)

鈿欙笍 Fixes the recent Json5 vulnerability.

#### What's Changed

-   11 dependency updates by [@&#8203;dependabot](https://togithub.com/dependabot)

**Full Changelog**: peter-evans/create-or-update-comment@v2.1.0...v2.1.1

### [`v2.1.0`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v2.1.0): Create or Update Comment v2.1.0

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v2.0.1...v2.1.0)

猸 Adds input `body-file`, the path to a file containing the comment body.

#### What's Changed

-   Replace set-output by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#130
-   Bump chuhlomin/render-template from 1.5 to 1.6 by [@&#8203;dependabot](https://togithub.com/dependabot) in [peter-evans/create-or-update-comment#132
-   Support reading body from a file by [@&#8203;umanghome](https://togithub.com/umanghome) in [peter-evans/create-or-update-comment#115
-   Add input body-file by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#133

#### New Contributors

-   [@&#8203;umanghome](https://togithub.com/umanghome) made their first contribution in [peter-evans/create-or-update-comment#115

**Full Changelog**: peter-evans/create-or-update-comment@v2.0.1...v2.1.0

### [`v2.0.1`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v2.0.1): Create or Update Comment v2.0.1

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v2.0.0...v2.0.1)

鈿欙笍 Bumps `@actions/core` to transition away from [deprecated runner commands](https://github.blog/changelog/2022-10-11-github-actions-deprecating-save-state-and-set-output-commands/).

#### What's Changed

-   Add workflow permissions by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#120
-   9 dependency updates by [@&#8203;github-actions](https://togithub.com/github-actions) and https://github.com/dependabot

**Full Changelog**: peter-evans/create-or-update-comment@v2.0.0...v2.0.1

### [`v2.0.0`](https://togithub.com/peter-evans/create-or-update-comment/releases/tag/v2.0.0): Create or Update Comment v2.0.0

[Compare Source](https://togithub.com/peter-evans/create-or-update-comment/compare/v1.4.5...v2.0.0)

#### What's new

-   Updated runtime to Node.js 16
    -   The action now requires a minimum version of v2.285.0 for the [Actions Runner](https://togithub.com/actions/runner/releases/tag/v2.285.0).
    -   If using GitHub Enterprise Server, the action requires [GHES 3.4](https://docs.github.com/en/enterprise-server@3.4/admin/release-notes) or later.

#### What's Changed

-   Use double quotes to preserve adjacent spaces correctly by [@&#8203;mfn](https://togithub.com/mfn) in [peter-evans/create-or-update-comment#95
-   Remove workflow by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#101
-   Update runtime to node 16 by [@&#8203;peter-evans](https://togithub.com/peter-evans) in [peter-evans/create-or-update-comment#105
-   7 dependency updates by [@&#8203;actions-bot](https://togithub.com/actions-bot) and [@&#8203;dependabot](https://togithub.com/dependabot)

#### New Contributors

-   [@&#8203;mfn](https://togithub.com/mfn) made their first contribution in [peter-evans/create-or-update-comment#95

**Full Changelog**: peter-evans/create-or-update-comment@v1.4.5...v2.0.0

</details>

---

### Configuration

馃搮 **Schedule**: Branch creation - At any time (no schedule defined), Automerge - At any time (no schedule defined).

馃殾 **Automerge**: Disabled by config. Please merge this manually once you are satisfied.

鈾 **Rebasing**: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

馃敃 **Ignore**: Close this PR and you won't be reminded about this update again.

---

 - [ ] <!-- rebase-check -->If you want to rebase/retry this PR, check this box

---

This PR has been generated by [Mend Renovate](https://www.mend.io/free-developer-tools/renovate/). View repository job log [here](https://developer.mend.io/github/rolldown-rs/rolldown).
<!--renovate-debug:eyJjcmVhdGVkSW5WZXIiOiIzNy4yMzAuMCIsInVwZGF0ZWRJblZlciI6IjM3LjIzMC4wIiwidGFyZ2V0QnJhbmNoIjoibWFpbiJ9-->
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
dependencies Pull requests that update a dependency file
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

1 participant