New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

py 1.5 release breaks pytest with pip dependency resolver #2926

Closed
uSpike opened this Issue Nov 14, 2017 · 8 comments

Comments

Projects
None yet
4 participants
@uSpike
Member

uSpike commented Nov 14, 2017

Hi,

Since pip doesn't have a great dependency resolver (see pypa/pip#988) it will download the latest version of the dependencies of the first package passed to it. For example,

pip install tox pytest

This will install py>=1.4.17 as depended on by tox, which will happily get the most recent py package at version 1.5. However, we cannot run pytest now since pytest depends on py<1.5

I think you can make the argument that the blame doesn't fall within pytest itself, but I think there's going to be a lot of requirements.txt out there which don't list pytest first, and may run into this issue.

@nicoddemus

This comment has been minimized.

Member

nicoddemus commented Nov 14, 2017

Hi @uSpike,

Thanks for bringing this to attention.

Hmm, the only reason why the <1.5 restriction was put into place was because 1.5 no longer supports py26 and py33. I guess that's a little harsh, perhaps the ideal would be to make the <1.5 restriction valid only for py26 and py33 I guess. This can still cause havoc on those platforms, but I'm sure the affected users will be much fewer.

Alternatively, we might remove the restriction in pytest completely and let py declare python_requires instead.

@nicoddemus

This comment has been minimized.

Member

nicoddemus commented Nov 15, 2017

I went ahead and opened #2927 removing the restriction; as soon as we decide this is the way to go we just push the package to PyPI.

@nicoddemus

This comment has been minimized.

Member

nicoddemus commented Nov 15, 2017

let py declare python_requires instead.

Oh oh, seems it is too late now; publishing a new py-1.5.1 with python_requires won't help because 1.5.0 is already out and it no longer supports py26 and py33. ☹️

@RonnyPfannschmidt

This comment has been minimized.

Member

RonnyPfannschmidt commented Nov 15, 2017

we can pull the release from pypi if necessary

@RonnyPfannschmidt

This comment has been minimized.

Member

RonnyPfannschmidt commented Nov 15, 2017

after all it breaks the world

@nicoddemus

This comment has been minimized.

Member

nicoddemus commented Nov 15, 2017

3.2.5 has been published with the restriction removed, thanks @uSpike again for the quick report.

@uSpike

This comment has been minimized.

Member

uSpike commented Nov 15, 2017

Thanks for the quick response @nicoddemus and @RonnyPfannschmidt !

Hopefully pip can get a good dependency resolver in place soon :)

@merwok

This comment has been minimized.

merwok commented Jan 26, 2018

FIW pip-compile from the https://github.com/jazzband/pip-tools project can handle this kind of situtations.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment