New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Replace f-string with "...".format(...) #146

Merged
merged 1 commit into from Jun 26, 2017

Conversation

Projects
None yet
6 participants
@vstinner
Member

vstinner commented Jun 26, 2017

Change adding Python 3.5 support.

Replace f-string with "...".format(...)
Change adding Python 3.5 support.
@vstinner

This comment has been minimized.

Member

vstinner commented Jun 26, 2017

Alternate syntax of PR #143, again, to add Python 3.5 compatibility.


fields = [x.strip() for x in filename.split(".")]
assert len(fields) >= 4, f"Can't parse 'next' filename! filename {filename!r} fields {fields}"
assert len(fields) >= 4, "Can't parse 'next' filename! filename {!r} fields {}".format(filename, fields)

This comment has been minimized.

@1st1

1st1 Jun 26, 2017

Member

This line is surely longer than 79 characters.

This comment has been minimized.

@vstinner

vstinner Jun 26, 2017

Member

The PEP 8 allows up to 120 characters. The file already contains lines longer than 120 characters (before my change) ;-)

@1st1

1st1 approved these changes Jun 26, 2017

@vstinner vstinner merged commit 155f473 into python:master Jun 26, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@vstinner vstinner deleted the vstinner:format branch Jun 26, 2017

@serhiy-storchaka

This comment has been minimized.

Member

serhiy-storchaka commented Jun 27, 2017

Thank you for doing this @Haypo!

@serhiy-storchaka

This comment has been minimized.

Member

serhiy-storchaka commented Jul 3, 2017

Brett, could you please update the version on PyPI? Current version is installable on 3.5, but doesn't work.

@brettcannon

This comment has been minimized.

Member

brettcannon commented Jul 5, 2017

@serhiy-storchaka sure, but I'm traveling ATM so I won't be able to get to it until I return home (no later than sometime next week).

@Mariatta

This comment has been minimized.

Member

Mariatta commented Jul 5, 2017

Prior to releasing to PyPI, I think this line in flit.ini should be updated so it can work with Python < 3.6.

The readme still states "blurb's only dependency is Python 3.6+.", guess that should be updated too.

@brettcannon

This comment has been minimized.

Member

brettcannon commented Jul 8, 2017

I updated the version number, tweaked the trove classifiers, fixed the README, pushed 1.0.1 to PyPI, and then bumped the version number for future development.

@serhiy-storchaka

This comment has been minimized.

Member

serhiy-storchaka commented Jul 9, 2017

Unfortunately

python3 -m pip install --user blurb

still installs version 1.0. And explicit specifying the version 1.0.1 doesn't work.

$ python3 -m pip install --user blurb==1.0.1
Collecting blurb==1.0.1
  Could not find a version that satisfies the requirement blurb==1.0.1 (from versions: 1.0)
No matching distribution found for blurb==1.0.1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment