Permalink
Browse files

Explicitly require rake so its DSL is available

  • Loading branch information...
1 parent 709e432 commit 51af1e25789728248078db6b17989b252ac2e53c @jeremy jeremy committed May 31, 2012
Showing with 1 addition and 0 deletions.
  1. +1 −0 railties/lib/rails/railtie.rb
@@ -190,6 +190,7 @@ def load_runner(app=self)
end
def load_tasks(app=self)
+ require 'rake'
extend Rake::DSL if defined? Rake::DSL
@mhuggins

mhuggins May 31, 2012

If rake is always being required, shouldn't this line be changed to just read:

extend Rake::DSL
@jeremy

jeremy May 31, 2012

Owner

Sure enough: c1a0c77

self.class.rake_tasks.each { |block| self.instance_exec(app, &block) }

0 comments on commit 51af1e2

Please sign in to comment.