Skip to content
Permalink
Browse files
feat(node-version): raised the minimum required version to v14.17 (#170)
BREAKING CHANGE: the minimum required version of node is now v14.17
  • Loading branch information
travi committed Sep 22, 2021
1 parent 8f008ce commit 5cf74e47e9a86f1b50ca0ac23abcc8d95eafc531
Showing with 43 additions and 40 deletions.
  1. +4 −3 .github/workflows/test.yml
  2. +36 −34 package-lock.json
  3. +3 −3 package.json
@@ -13,9 +13,8 @@ jobs:
strategy:
matrix:
node-version:
- 10
- 12
- 14
- '14.17'
- 16
runs-on: ubuntu-latest
steps:
- uses: actions/checkout@v2
@@ -25,6 +24,8 @@ jobs:
node-version: ${{ matrix.node-version }}
cache: npm
- run: npm ci
- name: Ensure dependencies are compatible with the version of node
run: npx ls-engines
- run: npm run test:ci
test:
runs-on: ubuntu-latest

Some generated files are not rendered by default. Learn more.

@@ -26,13 +26,13 @@
"clear-module": "4.1.1",
"codecov": "3.8.3",
"nyc": "15.1.0",
"semantic-release": "17.4.7",
"semantic-release": "18.0.0",
"sinon": "11.1.2",
"tempy": "1.0.1",
"xo": "0.28.3"
},
"engines": {
"node": ">=10.18"
"node": ">=14.17"
},
"files": [
"lib",
@@ -61,7 +61,7 @@
"all": true
},
"peerDependencies": {
"semantic-release": ">=15.8.0 <18.0.0"
"semantic-release": ">=18.0.0"
},
"prettier": {
"printWidth": 120,

0 comments on commit 5cf74e4

Please sign in to comment.