安装指南

Symeon Huang edited this page Jan 4, 2017 · 28 revisions

Windows

要求Windows XP或更高版本

  1. Releases下载最新的预编译压缩包,仅提供64位版本。
  2. 解压缩
  3. 运行ss-qt5.exe

Linux

Fedora

目前支持RHEL 7, Fedora

  1. 使用dnf添加shadowsocks的Copr源: sudo dnf copr enable librehat/shadowsocks
  2. 使用dnf更新cache并安装:
sudo dnf update
sudo dnf install shadowsocks-qt5

如果使用传统的yum包管理工具的话,需要从Copr下载相应版本的repo文件放到/etc/yum.repos.d/下,然后通过yum安装:

sudo yum update
sudo yum install shadowsocks-qt5

RHEL/CentOS请确认已经添加了EPEL源

Ubuntu

通过PPA源安装,仅支持Ubuntu 14.04或更高版本。

sudo add-apt-repository ppa:hzwhuang/ss-qt5
sudo apt-get update
sudo apt-get install shadowsocks-qt5

Debian

可以尝试安装Ubuntu PPA源的deb包,如果不行,请自行编译(dpkg-buildpackage -uc -us -b),在上级目录中将会生成shadowsocks-qt5的deb包,通过sudo dpkg -i来安装。

注意:你可能需要安装好的依赖关系:sudo apt-get install qt5-qmake qtbase5-dev libqrencode-dev libqtshadowsocks-dev libappindicator-dev libzbar-dev libbotan1.10-dev

Arch

官方Community源

Gentoo

gentoo-zh,由microcai维护

其他发行版

可以Google搜一下看有没有现成的二进制包或者安装源。我个人只维护Feodra和Ubuntu的源,如果您已经在维护其他发行版的源,请开issue提交到这个Wiki页面。

Mac OS X

目前需要自行从源码编译

从源码编译

参见Compiling