Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade sofa-bolt version to 1.5.6 #440

Closed
dbl-x opened this issue Jun 27, 2019 · 6 comments

Comments

@dbl-x
Copy link

commented Jun 27, 2019

sofa-bolt 1.4.x和1.5.x之间存在不兼容的问题,目前部分sofa-boot用户需要使用部分依赖了1.5.x的组件,需要sofa-bolt提供支持1.5.x的版本

@QilongZhang

This comment has been minimized.

Copy link
Contributor

commented Jun 28, 2019

@leizhiyuan 一起关注一下, @dbl-x 升级sofa-bolt 版本放在 sofaboot 2.x 还是 3.x, 对 rpc 版本是否有要求? -

@leizhiyuan

This comment has been minimized.

Copy link
Collaborator

commented Jun 28, 2019

有的,sofabolt 有不兼容的变更点。rpc 5.6.1中升级吧。放在3.x中。

@QilongZhang

This comment has been minimized.

Copy link
Contributor

commented Jun 28, 2019

有的,sofabolt 有不兼容的变更点。rpc 5.6.1中升级吧。放在3.x中。

ok

@dbl-x

This comment has been minimized.

Copy link
Author

commented Jul 4, 2019

@QilongZhang 这个有明确的时间吗?什么时候能发布支持bolt1.5的版本?

@QilongZhang

This comment has been minimized.

Copy link
Contributor

commented Jul 4, 2019

@QilongZhang 这个有明确的时间吗?什么时候能发布支持bolt1.5的版本?

我建议是放在 SOFABoot 3.1.6 版本管控。参考 @leizhiyuan 上面回复,RPC 需要适配 bolt 1.5 不兼容变更带点。 为了避免 SOFABoot 升级 bolt 版本,导致 RPC 使用问题,@leizhiyuan 一起关注下,确定大概的发布时间。

@straybirdzls straybirdzls added this to the 3.2.0 milestone Aug 14, 2019

@straybirdzls

This comment has been minimized.

Copy link
Member

commented Aug 14, 2019

确定相关改动放到 3.2.0 中

@caojie09 caojie09 closed this Sep 3, 2019

@caojie09 caojie09 changed the title sofa-boot支持sofa-bolt 1.5.x版本 Upgrade sofa-bolt version to 1.5.6 Sep 3, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
5 participants
You can’t perform that action at this time.