Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Abstractor is a Rails engine gem for deriving and curating discrete data points from narrative text via natural language processing (NLP).
Ruby Cucumber Java JavaScript HTML CSS CoffeeScript

README.md

Abstractor

Abstractor is a Rails engine gem for deriving discrete data points from narrative text via natural language processing. The gem includes a user interface to present the abstracted data points for confirmation/revision by a curator.

Status

Gem Version

Requirements

Abstractor works with:

  • Ruby 1.9.3, 2.0.0 and 2.1.1
  • >= Rails 4.1
  • Rails 3.2 branch now available here

Some key dependencies are:

Install

Add abstractor to your Gemfile:

gem 'abstractor'

or if using Rails 3

gem 'abstractor', :git => 'https://github.com/NUBIC/abstractor', branch: 'rails-3'

Add our foked and released version of stanford-core-nlp gem to your Gemfile. Currently we need to use our fork until the official gem releases a new version:

gem 'stanford-core-nlp-abstractor'

Also add the paper_trail gem to your Gemfile (if it is not already there):

gem 'paper_trail'

Bundle, install, and migrate. The abstractor:install generator can take a long time because it needs to download and intall the Stanford CoreNLP library into your application's lib directory:

  • bundle install
  • bundle exec rails g abstractor:install
  • bundle exec rake db:migrate
  • bundle exec rake abstractor:setup:system

Install the paper_trail gem (if it is not already installed in your application).

  • bundle exec rails g paper_trail:install
  • bundle exec rake db:migrate
Something went wrong with that request. Please try again.