Permalink
Browse files

nixpkgs: no parallel builds for mono 4.4

See #32386 -- while Mono in general should build correctly with parallel
building, it seems the 4.4 branch has broken.

Instead, allow parallel build support to be overridden by individual
versions, and default to true.

Signed-off-by: Austin Seipp <aseipp@pobox.com>
  • Loading branch information...
thoughtpolice committed Dec 7, 2017
1 parent 6f64bc5 commit 90bcfc78c3fcf1439ac7951861cfa266d1c6da1f
Showing with 10 additions and 2 deletions.
  1. +1 −0 pkgs/development/compilers/mono/4.4.nix
  2. +9 −2 pkgs/development/compilers/mono/generic.nix
@@ -4,4 +4,5 @@ callPackage ./generic.nix (rec {
inherit Foundation libobjc;
version = "4.4.2.11";
sha256 = "0cxnypw1j7s253wr5hy05k42ghgg2s9qibp10kndwnp5bv12q34h";
buildParallel = false; # see #32386 -- parallel building broken on 4.4
})
@@ -1,4 +1,11 @@
{ stdenv, fetchurl, bison, pkgconfig, glib, gettext, perl, libgdiplus, libX11, callPackage, ncurses, zlib, withLLVM ? false, cacert, Foundation, libobjc, python, version, sha256 }:
{ stdenv, fetchurl, bison, pkgconfig, glib, gettext, perl, libgdiplus, libX11
, callPackage, ncurses, zlib
, cacert, Foundation, libobjc, python
, version, sha256
, withLLVM ? false
, buildParallel ? true
}:
let
llvm = callPackage ./llvm.nix { };
@@ -40,7 +47,7 @@ stdenv.mkDerivation rec {
# The file /nix/store/xxx-mono-2.4.2.1/lib/mscorlib.dll is an invalid CIL image
dontStrip = true;
enableParallelBuilding = true;
enableParallelBuilding = buildParallel;
# We want pkg-config to take priority over the dlls in the Mono framework and the GAC
# because we control pkg-config

0 comments on commit 90bcfc7

Please sign in to comment.