Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Require .NET Framework >= 4.7.2 on Windows. #16324

merged 1 commit into from Mar 21, 2019


Copy link

commented Mar 17, 2019

This PR raises our baseline .NET requirement on Windows from 4.5 to 4.7.2, working towards #15954.

.NET 4.7.2 is the minimum that Microsoft recomments for .NET standard 2.0 [ref], and does not drop support for any of our supported Windows versions [ref].

I have a few more commits locally that improve the Windows packaging by updating NSIS to 3.0.3 to fix #11865 and add HiDPI support to the installer. This change requires a switch to the Ubuntu 16.04 Travis VMs, which breaks the Mono 4.6.2 runtime we currently depend on. This therefore needs to wait until we merge this PR, #16319, #16316, and then bump our Travis runtime to 5.10.0.

@pchote pchote added this to the Next Release milestone Mar 17, 2019


This comment has been minimized.

Copy link

left a comment

Test build Installed fine on Win10 system.
On my older Win7 system with .NET 4.6, it correct warned about outdated version and aborted install.

Copy link

left a comment

Looks good!

@reaperrr reaperrr merged commit 01f6f98 into OpenRA:bleed Mar 21, 2019

2 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
continuous-integration/travis-ci/pr The Travis CI build passed

@pchote pchote deleted the pchote:dotnet472 branch Mar 21, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
None yet
3 participants
You can’t perform that action at this time.