HAPI Client for Java.
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
core
.gitignore
LICENSE
README.md

README.md

HAPI Client

An HTTP Client implementing the HAL specification.

Requirements

Java 5 or higher

Installation

Maven dependency:

<dependency>
	<groupId>com.slimpay</groupId>
	<artifactId>hapiclient</artifactId>
	<version>1.0.2</version>
</dependency>

For Java 5 to 7 included, you also need to add:

<dependency>
	<groupId>org.glassfish</groupId>
	<artifactId>javax.json</artifactId>
	<version>1.0.4</version>
	<optional>true</optional>
</dependency>

Use

Examples and full working snippets are available in our HAPI Browser.