Skip to content
Simple RedditApi wrapper
Ruby Shell
Branch: master
Clone or download

Latest commit

Fetching latest commit…
Cannot retrieve the latest commit at this time.

Files

Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
bin
lib
spec
.gitignore
.rspec
.travis.yml
Gemfile
Guardfile
LICENSE.txt
README.md
Rakefile
reddit_api-0.3.8.gem
reddit_api.gemspec

README.md

RedditApi

Communicate with the Reddit API painlessly.

Installation

Add this line to your application's Gemfile:

gem 'reddit_api'

And then execute:

$ bundle

Or install it yourself as:

$ gem install reddit_api

Usage

  1. Get Reddit API credentials by following the guide here
  2. Load Reddit API credentials into the environment
  • Expected names can be found in RedditApi::Client
  1. Create instances of the RedditApi sub-api objects and make requests

Resources

Contributing

Bug reports and pull requests are welcome on GitHub at https://github.com/anthonyfuentes/reddit_api.

License

The gem is available as open source under the terms of the MIT License.

You can’t perform that action at this time.