Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 94 lines (69 sloc) 2.925 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93
=========================================
 CELERYSA-0001: Celery Security Advisory
=========================================
:contact: security@celeryproject.org
:author: Ask Solem
:CVE id: CVE-2011-4356
:date: 2011-11-25 04:35:00 P.M GMT

Details
=======

:package: celery
:vulnerability: privilege escalation
:problem type: local
:risk: medium
:bug-no: Celery #544
:versions-affected: 2.1, 2.2, 2.3, 2.4

Description
===========

The --uid and --gid arguments to the celeryd-multi,
celeryd_detach, celerybeat and celeryev programs shipped
with Celery versions 2.1 and later was not handled properly:
only the effective user was changed, with the real id remaining
unchanged.

In practice for affected users the vulnerability means that malicious code
loaded in the worker process would be allowed to escalate privileges.

We take this issue seriously since the Pickle serializer used by
default makes it possible to execute arbitrary code.

We recommend that users takes steps to secure their systems so that
malicious users cannot abuse the message broker to send messages,
or disable the pickle serializer used in Celery so that arbitrary code
execution is not possible.

Patches are now available for all maintained versions (see below),
and users are urged to upgrade, even if not directly
affected.

Systems affected
================

Users of Celery versions 2.1, 2.2, 2.3, 2.4 except the recently
released 2.2.8, 2.3.4 and 2.4.4, daemonizing the celery programs
as the root user, using either:
    1) the --uid or --gid arguments, or
    2) the provided generic init scripts with the environment variables
       CELERYD_USER or CELERYD_GROUP defined,
are affected.

Users using the Debian init scripts, CentOS init scripts, OS X launchctl
scripts, Supervisor, or users not starting the programs as the root user
are *not* affected.

Solution
========

Users of the 2.4 series should upgrade to 2.4.4:

    * ``pip install -U celery``, or
    * ``easy_install -U celery``, or
    * http://pypi.python.org/pypi/celery/2.4.4

Users of the 2.3 series should upgrade to 2.3.4:

    * ``pip install -U celery==2.3.4``, or
    * ``easy_install -U celery==2.3.4``, or
    * http://pypi.python.org/pypi/celery/2.3.4

Users of the 2.2 series should upgrade to 2.2.8:

    * ``pip install -U celery==2.2.8``, or
    * ``easy_install -U celery==2.2.8``, or
    * http://pypi.python.org/pypi/celery/2.2.8

The 2.1 series is no longer being maintained, so we urge users
of that series to upgrade to a more recent version.

Distribution package maintainers are urged to provide their users
with updated packages.


Please direct questions to the celery-users mailing-list:
http://groups.google.com/group/celery-users/,

or if you are planning to report a security issue we request that
you keep the information confidential by contacting
security@celeryproject.org, so that a fix can be issued as quickly as possible.

Thank you!
Something went wrong with that request. Please try again.