Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

update readme with fix from #1939 #2114

Merged
merged 10 commits into from May 12, 2017

Conversation

@kellyrmilligan
Copy link
Contributor

commented May 10, 2017

updating readme with comment from #1939 . works with latest node-sass@4.5.2

馃帀

@@ -406,7 +406,7 @@ Then in `package.json`, add the following lines to `scripts`:
```diff
"scripts": {
+ "build-css": "node-sass src/ -o src/",
+ "watch-css": "npm run build-css && node-sass src/ -o src/ --watch --recursive",
+ "watch-css": "npm run build-css && node-sass src/*.scss -o src/ --watch --recursive",

This comment has been minimized.

Copy link
@Timer

Timer May 10, 2017

Collaborator

Does this need to be src/**/*.scss?
Also, what about sass files? Aren't both extensions supported?

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan May 10, 2017

Author Contributor

馃憖

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan May 10, 2017

Author Contributor

ok, updating. I coudn't find anything at first in the readme of node-sass but looking through the code of the cli, yeah normal globbing is supported. updating. .sass files are supported, but I think for a readme this should suffice no?

This comment has been minimized.

Copy link
@Timer

Timer May 10, 2017

Collaborator

Most likely, yeah! I just want to make sure it's noted.

Thanks!

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan May 10, 2017

Author Contributor

noted 馃憤

@Timer

This comment has been minimized.

Copy link
Collaborator

commented May 10, 2017

Hey @kellyrmilligan, thanks for this PR!

Do you happen to know about that comment I mentioned above?

@Timer Timer added this to the 0.10.0 milestone May 10, 2017

kellyrmilligan added some commits May 10, 2017

@cr101

This comment has been minimized.

Copy link
Contributor

commented May 11, 2017

@kellyrmilligan Unfortunately, it doesn't work on Windows

Error: ENOENT: no such file or directory, lstat 'C:\wf\my-app\src***.scss'

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

What if you tried app\src\**\*.scss ?

Update, I did see in a doc somewhere even on windows for globbing you should use forward slashes as well.

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

i'm looking more into the code now. there are a few levels of abstraction around how the globbing works, so I may change this back to the original fix and explain in this PR why it works.

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

looks like the recommended solution from the issue won't let you watch files in subdirectories. the glob pattern in the cli gets expanded, and then node-sass doesn't treat it as a directory. on the other hand, if you use src/*/**.scss, it doesn't work as you would expect either. from what I am seeing, the way they want it to be used is src/. this results in the sass-graph lib picking up all the correct files. The cli assumes you want all extensions, and its not configurable.

After trying out a few different ways of calling the cli, on my setup at least, the looping happens when you change a file that is included in a lot of files, like say a _settings.scss file or something.

I switched over to node-sass-chokidar and this issue just went away. I think longer term the node-sass cli should let you configure the extensions or use proper globbing patterns, as ATM its kind of broken IMO.

switching to node-sass-chokidar fixed this issue fully for me, so not sure what to do with this PR unless we want to switch the recommendation for sass to that package instead.

thoughts @Timer and anyone else?

@Timer

This comment has been minimized.

Copy link
Collaborator

commented May 11, 2017

Let's just switch the docs to node-sass-chokidar primarily.

@gaearon

This comment has been minimized.

Copy link
Member

commented May 11, 2017

Would it work if you quoted the glob? node-sass "src/**/*.scss"
Then shell wouldn鈥檛 expand it. (I don鈥檛 know if it helps or not.)

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

@gaearon let me give it a shot.

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

nope, it takes that as the literal value and gives Error: ENOENT: no such file or directory, lstat 'src/**/*.scss'

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

I updated the readme again. I reverted it back to the way it was, and added a note under the step to install node-sass, about node-sass-chokidar.

@Timer

This comment has been minimized.

Copy link
Collaborator

commented May 11, 2017

We already have a note to switch to it about performance, but I think we should just recommend it first and adjust both notes to say why we use it.

I don't see a need to show docs using node-sass.

@Timer

This comment has been minimized.

Copy link
Collaborator

commented May 11, 2017

Perfect! Thanks much.

@Timer

This comment has been minimized.

Copy link
Collaborator

commented May 11, 2017

Just to confirm, new files aren't an issue anymore?

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

@Timer added note about new files back in after testing. please let me know of any other changes I just pushed an update to the notes as well.

@@ -207,7 +207,7 @@ To configure the syntax highlighting in your favorite text editor, head to the [

## Displaying Lint Output in the Editor

>Note: this feature is available with `react-scripts@0.2.0` and higher.

This comment has been minimized.

Copy link
@gaearon

gaearon May 11, 2017

Member

Whitespace is significant in markdown. Please leave those two spaces in, they are causing the line to break. They were intentional.

@Timer

This comment has been minimized.

Copy link
Collaborator

commented May 11, 2017

/cc @michaelwayman
Figured you'd like to see this.

@@ -442,27 +441,17 @@ Then we can change `start` and `build` scripts to include the CSS preprocessor c
}
```

Now running `npm start` and `npm run build` also builds Sass files. Note that `node-sass` seems to have an [issue recognizing newly created files on some systems](https://github.com/sass/node-sass/issues/1891) so you might need to restart the watcher when you create a file until it鈥檚 resolved.
Now running `npm start` and `npm run build` also builds Sass files. Note that `node-sass-chokidar` seems to have an issue recognizing newly created files on some systems so you might need to restart the watcher when you create a file until it鈥檚 resolved.

This comment has been minimized.

Copy link
@michaelwayman

michaelwayman May 11, 2017

Contributor

Note that node-sass-chokidar seems to have an issue recognizing newly created files

I would like to comment though that node-sass-chokidar does not have a problem recognizing new files.

@Timer thanks for the tag, this is amazing :)


If you want to see why node-sass has this problem, read on:

You can see here that node-sass only watches files that are there when program first runs. And possibly newly created files IFF they are imported by a file that IS being watched.

This comment has been minimized.

Copy link
@gaearon

gaearon May 11, 2017

Member

hmm, doesn't this contradict:

added note about new files back in after testing

@kellyrmilligan Can you confirm you still experience the issue with new files?

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan May 11, 2017

Author Contributor

@michaelwayman in testing it seems to not recognize a new file being added for me.

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan May 11, 2017

Author Contributor

what is a good way to verify it? I am testing on os x sierra.

This comment has been minimized.

Copy link
@michaelwayman

michaelwayman May 11, 2017

Contributor

ok, thanks @kellyrmilligan
can you open an issue on node-sass-chokidar and describe steps to reproduce, as well as your system details. (e.g. OS, node, npm, and package versions) thanks so much and I will try to have this fixed ASAP

It works as expected for me so I need to try and duplicate your setup.

This comment has been minimized.

Copy link
@michaelwayman

michaelwayman May 11, 2017

Contributor

Well, what I did to test it was:

  1. Start a clean project and install node-sass-chokidar.
  2. run node-sass-chokidar src/ -o src/ --watch --recursive
  3. Create a new scss file src/my_file.scss with simple style #yoyo {color:red;} and save.
    • note that the file HAS to be in the directory that's being watched i.e. src/
  4. Check for the existence of src/my_file.css

that was all the "testing" I did but it works fine. So yeah, please describe your steps to reproduce and system info in an issue here

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan May 11, 2017

Author Contributor

I realized I tried a _test.scss file, which is meant to be included in others. in testing a regular file you are correct and i've removed the note about that.

@michaelwayman

This comment has been minimized.

Copy link
Contributor

commented May 11, 2017

That's awesome @kellyrmilligan thanks :)

And yep, files starting with _ do not get transpiled.

I think the not recognizing new files is a known bug with node-sass.
Since you already have the "Why node-sass-chokidar?" section, if you want to add that nsc fixes it that would be super 馃憤 lol

<3 this PR BTW :)

@kellyrmilligan

This comment has been minimized.

Copy link
Contributor Author

commented May 11, 2017

@michaelwayman done!

@heshamsalman

This comment has been minimized.

Copy link

commented May 12, 2017

@michaelwayman 馃憦 馃憦 馃憦

"build-css": "node-sass src/ -o src/",
"watch-css": "npm run build-css && node-sass src/ -o src/ --watch --recursive",
"build-css": "node-sass-chokidar src/ -o src/",
"watch-css": "npm run build-css && node-sass-chokidar src/ -o src/ --watch --recursive",

This comment has been minimized.

Copy link
@Timer

Timer May 12, 2017

Collaborator

Why do we build before we start watching? Does the watcher not compile everything when started in watch mode?

This comment has been minimized.

Copy link
@michaelwayman

michaelwayman May 12, 2017

Contributor

without the build-css inside of watch-css there is no guarantee the latest stylesheets are being used when you npm run start

Does the watcher not compile everything when started in watch mode?

that is correct, the watcher does not compile everything when it first starts.

  1. If it's the first time running npm run start you won't have ANY CSS files yet
  2. If you made changes to a stylesheet while you weren't watching then npm run start those changes won't show until you modify the stylesheet again

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan May 12, 2017

Author Contributor

just to comment on this, I do like for example how the babel cli when started in watch mode does compile one time before the watch mode kicks in. something to think about and would simplify the scripts config.

This comment has been minimized.

Copy link
@michaelwayman

michaelwayman May 12, 2017

Contributor

@kellyrmilligan do you want to open an issue on node-sass-chokidar requesting this change? I will make the change this weekend if you do.

This comment has been minimized.

Copy link
@Timer

Timer May 12, 2017

Collaborator

If you make the files compile when started in watch mode, please add a flag to disable it.
It's very annoying that babel does it because you can't say "wait for first build before starting app".

This comment has been minimized.

Copy link
@ajs139

ajs139 Jun 5, 2017

@michaelwayman: would it be helpful to include node_modules, like so:

    "build-css": "node-sass-chokidar src/ -o src/ --include-path node_modules",
    "watch-css": "npm run build-css && node-sass-chokidar src/ -o src/ --watch --recursive --include-path node_modules",

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan Jun 6, 2017

Author Contributor

@ajs139 we actually recently added a section about that. It gives advice more about importing without relative paths similar to the NODE PATH env variable fix. I always add my src directory as well.

@Timer

This comment has been minimized.

Copy link
Collaborator

commented May 12, 2017

This is some great work, guys! Thanks so much.

@Timer Timer merged commit 2de95c4 into facebook:master May 12, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

@kellyrmilligan kellyrmilligan deleted the kellyrmilligan:readmenodesass branch May 12, 2017

sbuzonas pushed a commit to sbuzonas/react-scripts that referenced this pull request May 22, 2017

Update Sass docs (facebook#2114)
* update readme with fix from facebook#1939

* update with better globbing

* added note

* updating with a note and reverting previous changes

* how about this?

* refactor

* added note about new files back in after verifying locally

* spaces back in, sorry was my editor!

* removed note about new files :)

* added bullet about new files issue currently open on node-sass
"build-css": "node-sass src/ -o src/",
"watch-css": "npm run build-css && node-sass src/ -o src/ --watch --recursive",
"build-css": "node-sass-chokidar src/ -o src/",
"watch-css": "npm run build-css && node-sass-chokidar src/ -o src/ --watch --recursive",

This comment has been minimized.

Copy link
@kidqn

kidqn Jun 8, 2017

Can we hide css compiled files in "npm start"?
I saw many other sources, they can run with "npm start" without compiling scss files. Imagine that my folders have many new css files, it looks ugly. Thanks for any help!

This comment has been minimized.

Copy link
@kellyrmilligan

kellyrmilligan Jun 8, 2017

Author Contributor

Do you mean the initial terminal output? If so yes you can pass -q to build-css like so:
npm run build-css -- -q, this will call it in quiet mode. if this is not why you mean, create react app does not let you ATM add in custom loaders for scss, so this is a workaround to allow for that. In practice it has t been a big deal tbh

This comment has been minimized.

Copy link
@kidqn

kidqn Jun 9, 2017

Thank to your reply. I mean that I want to use "node-sass-chokidar" but still can import .scss files.
For example: my Home folder includes: Home.js, Home.scss, ...
After run "npm start", my folder add Home.css. So I'm scared of that one day I forget and edit css files instead of scss.
Another issue is that it's assumed that I have Styles folder including 10 SCSS files, and now after run "npm start" it will have 20 files. I knew we can ignore CSS files, but it makes structure of app folders cumbrous.

In some react apps built with webpack 2 as I did, we need just import .scss files, can run "npm start" in dev mode without compiling new css files. Therefore, can you improve it? example, build an entire css and hide it somewhere

This comment has been minimized.

Copy link
@michaelwayman

michaelwayman Jun 9, 2017

Contributor

like @kellyrmilligan said, custom scss loaders are not supported at the moment.

  • One option you have available is to npm run eject and add a scss loader to config/webpack.config.*.js. then you should be able to import 'styles.scss';
  • Another option is to output the css to a separate folder with node-sass-chokidar with the -o <path> option, however, this will make importing the css a huge pain if you use self-contained component hierarchy pattern like I do.
  • also, if you add *.css to .gitignore, and you configure your IDE or VIM or Emacs or w.e. to not show css files then maybe it won't seem so cumbrous?

anyways, perhaps you can convince the visionaries working on this to let you open a PR providing an entry point or env variable into the web-pack-config WITHOUT running eject?

This comment has been minimized.

Copy link
@kidqn

kidqn Jun 9, 2017

@michaelwayman : Thanks. That's exactly I want.
I tried the second way, edit web-pack-config, run eject to add scss loader and eventually it failed.
The node-sass-chokidar's way works fine, so I think something likes scss loader will make create-react-app better :) I still dont know the reason why create-react-app didn't suppor SCSS.

P/S: I'm using VS, and config it to hide css files but it should be not the best method (import from a invisible file)

romaindso added a commit to romaindso/create-react-app that referenced this pull request Jul 10, 2017

Update Sass docs (facebook#2114)
* update readme with fix from facebook#1939

* update with better globbing

* added note

* updating with a note and reverting previous changes

* how about this?

* refactor

* added note about new files back in after verifying locally

* spaces back in, sorry was my editor!

* removed note about new files :)

* added bullet about new files issue currently open on node-sass

iamlacroix added a commit to trunkclub/tcweb-build that referenced this pull request Aug 2, 2017

Merge upstream create-react-app v1.0.7 (#90)
* Bust AppVeoyr cache

* Relax ESLint config peerDependency (facebook#1740)

* Fix internal linting setup and add missing headers (facebook#1741)

* Fix eject for linked react-scripts (facebook#1736)

* fix eject for linked react-scripts

* path.resolve => resolveApp

* Add changelog for 0.9.4

* Published branch 0.9.x

 - create-react-app@1.3.0
 - eslint-config-react-app@0.6.1
 - react-dev-utils@0.5.2
 - react-scripts@0.9.4

* Adjust changelog wording

* Switch to preset-env (facebook#1742)

* Switch to preset-env
Disables webpack modules by enabling babel modules to resolve facebook#1638

* Bump babel-core to match babel preset versions

* Add uglify to targets

* Add runtime error overlay (facebook#1101)

* Add red box prototype

* Unmount fail node when hot-reloaded (future proofing)

* Slightly improve error reason

* Add Chrome unhandledrejection listener

* Close red box when Escape is pressed

* Construct our own source if not available

* Resolve sourcemaps for friendlier traces

* Allow error to be scrolled

* Only utilize sourcemaps, not the magic. :(

* Make view similar to React Native

* Fix an uncaught syntax error

* Add workaround for Firefox 50

* Add a hint for closing the prompt

* Multiple error support
When there's multiple errors, simply state that there are more instead of re-rendering

* Log any renderer error

* Dim node_modules in display

* Override chrome stack trace limit

* Magic: show me some source!

* Add ability to toggle internal calls

* Switch text from show -> hide

* Change color scheme to something easier on the eyes

* Change UI to be friendlier (thanks @nicinabox)
facebook#1101 (comment)
facebook#1101 (comment)

* Update styles

* Add container inside overlay

* Apply pre style

* Add line highlight

* Add omitted frames ui

* Move yellow to var

* Do all function names in black

* Adapt container based on screen size

* Extract ansiHTML

Use base16-github theme

* Linting

* Add syntax highlighting of errors

* Linting

* Remove white background

* Append new files to package.json

* Target exact version

* White is a little harsh, use same color as red box.

* Fix a bug where omitted frames would never be rendered
(under certain circumstances)

* Show local file path instead of confusing webpack://

* Do not require the entire file

* Remove css file

* Use context size, not a magic variable.

* Fix title regression

* Update dependency

* Do not center text for internal calls

* Temporarily disable links

* Switch internal toggle to 'i'

* Remove unnecessary rules from container style

* Reduce omitted frames font size

* Fix font family in pre > code

* Re-introduce line highlighting

* Object.<anonymous> -> (anonymous function)

* Add ability to see script source

* Add missing ansi mappings

* Remove SIAF

* Skip native functions

* Extract hints div function

* Extract renderers

* Refacor var names

* If source is disabled, don't use the line.

* Allow toggle between source

* Allow bundles to be expanded

* Wow, how did I let this one slip?

* Toggle text for UX/DX

* Make it so clicking Close unmounts the error component

* Do not allow hot reloading once an error is thrown

* Do not wrap lines for small displays

* Fix toggle when additional errors happen

* Make the close a button

* Capture and store errors

* Dispose on render; move additional logic

* Only make code not wrap

* Switch to a view-by-index method

* Allow user to switch between errors with arrow keys

* Fix text while switching between errors

* Update close button style

* Render additional errors at top

* Add left and right arrows

* Make frames pointy

* UTF-8 arrows

* Don't mount unneeded DOM node

* Switch to single changing text for compiled <-> source

* Don't display arrows with only one error.

* Collapsed and expanded

* Make sure the last collapse toggle is appended

* Do not show the stack trace if it doesn't resolve to a file we wrote

* Style container with media queries

* Do not allow x overflow; break words by default.

* Trim off whitespace of lines

* Remove padding since it's not outer-most

* Add footer message

* Extract css file to JS

* Only inject the css when the overlay is up

* Extract red variable

* Remove env

* Update babel-code-frame

* Set force color to true

* Extract out collapse div logic

* Remove arrow field

* Insert a top collapse

* Make browser friendlier

* Absolutify ^

* Make arrows buttons

* Accessify

* Let there be ES5

* Pretty css

* Use forEach where we can ...

* Remove extracted loop

* Fix IE compatibility

* Capture React warnings

* Add source override via React output parsing

* Whoops, fix arguments to crash.

* es5-ify

* Re-enable e2e-install directory test

* Only rewrite line number if it was resolved and leaves a line at bottom

* Rename failFast to crashOverlay

* Disable console proxy

* Appease linter

* Appease more

* Whitelist files that can be embedded through url-loader (facebook#1305)

* Whitelist files that can be embedded through url-loader

Change the current catch-all loader to use file-loader instead of
url-loader, and exclude common image file extensons. Add another url-loader
for images, configured identically to the original catch-all loader.

Part of issue facebook#1293.

* Update tests to reflect change in loader config

* Integration test fix

* More CI fixes

* Work around broken loader-utils behaviour in integration tests

* Revise the documentation around file loading

* Documentation tweaks

* Docs tweak

* Update test now that webpack/loader-utils has been updated

* Update react-scripts to depend on babel-loader@7.0.0-alpha.2

* Bump deps

* Update deps for webpack 2

* Update broken link

* Display yarn instead of yarnpkg when creating a new app (facebook#1747)

* Display yarn instead of yarnpkg

* Refactored displayd commands

* Removed testing directory

* update to modern code style (facebook#1738)

* mv create-react-app/index.js -> create-react-app/creteReactApp.js

* update to modern code style

* var -> cosnt

* set trailing-coma to es5 for prettier

* Create PR_TEMPLATE.md

* Rename PR_TEMPLATE.md to PULL_REQUEST_TEMPLATE.md

* Update PULL_REQUEST_TEMPLATE.md

* Add yarn steps for adding flow (facebook#1756)

[skip ci]

* Add lint-staged + husky for prettier auto-formatting on commit (facebook#1759)

* Clarify philosophy about configuration (facebook#1679)

* Update configuration philosophy (facebook#1768)

* Update configuration philosophy

* Remove explanation

* Suggest `serve` for running in production (facebook#1760)

* Suggest `serve` for serving the `build` directory

* How to handle it with Node in prod (or other platforms)

* Pretty newline added

* Adjusted default port of static server

* Remove `open` command from output

* Removed constant assignment

* Better explanation for not using having to use a static server

* Cute newline added

* Style nits

* Remove 'guard-for-in' lint rule (facebook#1773)

Iterating over an object's keys using `for/in` is idiomatic and it's safe (in all modern browsers) to not check hasOwnProperty as long as the object is a plain object. Can we remove this lint rule?

* Run CI on Node 7; Bump detect-port: 1.0.1 -> 1.1.0 (facebook#1776) (facebook#1783)

* Run CI on Node 7

* Bump detect-port: 1.0.1 -> 1.1.0

* Run AppVeyor CI on Node 7

* Add 0.9.5 changelog (facebook#1784)

* Add 0.9.5 changelog

* Update CHANGELOG.md

* docs(babel-preset): Update comment info about babel-preset-env. (facebook#1787)

* Feature/readme-nomoretools (facebook#1799)

* docs: replace TDLR with a meaningful heading

* docs: insert section No additional build tools

* Tweak wording

* Suggest "yarn build" rather than "yarn run build" (facebook#1800)

* Fix for issue facebook#1798: Suggested 'yarn build' versus 'yarn run build'

* remove 'run' from 'yarn test' command as well

* conditionally show 'run' if Yarn is not available

* Tweak the wording

* Fixes a silent crash when ejecting (facebook#1810)

* Fixes a silent crash when ejecting

* Delete unnecessary files

* Remove references to eslintrc in Webpack config

* Fix lint

* Correct ESLint CLI options

* Link to CRNA

* Make scripts crash on unhandled rejections (facebook#1819)

* Makes end-to-end testing crash on unhandled rejections

* Comment fix

* Allow creation of apps in empty mercurial repos (facebook#1811)

* Allow creation of apps in empty mercurial repos

* Adding .hgignore to list of validFiles for isSafeToCreateProjectIn check

* Adding .hgcheck to list of validFiles for isSafeToCreateProjectIn check

* Make Surge guide more focused

* User Guide: Removed blockquote from code section, due to markdown conflict (facebook#1869)

* Removed blockquote from code section

* Fix the fix

* Fix AppVeyor CI (facebook#1876)

* Provide commander with package name (facebook#1867)

commander to figure it out on its own

* Fix responsive behavior in iOS 9+ (facebook#1821)

* Adding shrink-to-fit=no for proper responsive handling on Safari 9+

* Check internet connectivity with lookup instead of resolve (facebook#1863)

Resolves facebook#1818

* Update `detect-port` (facebook#1861)

Previous changes caused `detect-port` to pick random port on app startup. Update fixes this regression, `detect-port` pick next available port instead.

* Fix importing npm linked libraries (facebook#1359)

* Fix importing npm linked libraries

* Update webpack.config.dev.js

* Update webpack.config.prod.js

* Test for accidental extraneous dependencies (facebook#1825)

* Added test to check for accidental dependencies

* Refactored test into a function

* Removed non capturing group from grep

* Update e2e-installs.sh

* Fix AppVeyor CI (facebook#1868)

* Fix AppVeyor CI (facebook#1876)

* Run AppVeyor on Visual Studio 2017

* Re-disable babel modules transform (facebook#1894)

* Upgrade webpack & related deps

* Disable module transform (requires webpack 2+)

* Duplicate CLI file warning header

* Suggest Yarn in HTML template (facebook#1911)

* Fix npm to yarn

* yarn & npm

* Update index.html

* Switch ordering of suggestion

We should suggest NPM first for new users.

* Note that only jest-enzyme@2.x is compatible

* Add sku to the list of alternatives (facebook#1962)

* Update information in User Guide for Enzyme dependency (facebook#1982)

* Ensure proxy url starts with `http://` or `https://` (facebook#1890)

* Add linked modules test (facebook#1913)

* Start the dev server at the specified host (facebook#1301)

Pass the host from environment variable as argument of the devServer's
listen function instead of a field of options object.
Set the default host to 0.0.0.0 instead of localhost.

* Add folder structure docs for new contributors (facebook#1991)

* Adding folder structure to help people navigate through project. It helps in resolving issues by providing brief description of each package and its purpose

* Removing unnecessary packages from Folder structure heading

* Update CONTRIBUTING.md

* Relax label rules (facebook#1989)

* Update doc server example to work from any directory (facebook#1988)

* Node.js serving with absolute path

It鈥檚 safer to use the absolute path of the directory that you want to serve, in case you run the express app from another directory.

* Update README.md

* removed options in UglifyJsPlugin which are equal to the defaults (facebook#1993)

* removed redundant already default options in UglifyJsPlugin

* re-enabled remove comments Uglify option

JSDoc-style comments weren't being removed

* Resolve localhost when offline on Windows (facebook#1839)

* Change proxy localhost to I27.0.0.1 for windows

* Update comment

* resolve localhost IP with DNS lookup on windows

* Fix CI errors

* Promisify addWebpackMiddleware

* Remove Node 6 syntax

* Update addWebpackMiddleware.js

* Actually use the resolved proxy

* Minify and map css (facebook#2013)

Minify and map css

* Fix AppVeyor CI (facebook#2010)

* Update README.md CSS Preprocessor --> node-sass-chokidar alternative (facebook#1987)

* resolves facebook#1986 updates CSS Preprocessor docs to include information on node-sass-chokidar alternative to node-sass

* Update README.md

* Turn off CSS source maps

* Use custom sourcemap file names

* Modularize and extract crashOverlay to iframe (facebook#1842)

* Modularize and extract crashOverlay to iframe

* Do not break words

* Disable warning overlay

* Use CJS imports

* Upgrade webpack deps and use strictExportPresence (facebook#2028)

* Fix Netlify heading level. (facebook#2033)

* Use prop-types package (facebook#2029)

* Update README.md (facebook#2040)

* Define dev chunk names (facebook#2050)

* Define dev chunk names

Fixes facebook#2046

* Add comment

* Suggest to create .eslintrc for IDE lint plugins (facebook#2054)

* Suggest to create .eslintrc for IDE lint plugins

* Update README.md

* Update README.md

* Update README.md (facebook#2058)

* Update README.md

* Update README.md

* Fix instructions for serving with now (facebook#2052)

* Fix instructions for serving with now

Not sure if new, but the `--single` flag is now important.

* Keep it shorter

* Temporarily pin Yarn to fix CI

* Fixed documentation link for storybook in README.md (facebook#2081)

* Forbid using window properties as global variables (facebook#1840)

* Forbid using window properties as global variables

* Change globals list to match Standard.

* Fix globals

* Ignore the yarn cache directory (facebook#2063)

* Revert "Forbid using window properties as global variables" (facebook#2099)

* Revert "Ignore the yarn cache directory (facebook#2063)"

This reverts commit 94149c7.

* Revert "Forbid using window properties as global variables (facebook#1840)"

This reverts commit 5a7d8e8.

* Minor tweaks for crash overlay (facebook#2101)

* Bump minimal Node version to 6 (facebook#1897)

* Bump minimal Node version to 4.7.0

* Bump minimal Node version to 4.7.0

Modified additional files that needed a bump to 4.7.0 minimum node version

* Bump minimal Node version to 4.7.0

Reverse changes to packages/create-react-app/index.js as this file needs to continue to work on Node 0.10+

* Bump minimal node version to 6

* Bump minimal node version to 6

* Bump minimal node version to 6

* Prettify errors and warnings for Webpack 2 (facebook#2113)

* Prettify errors and warnings for Webpack 2

* Update formatWebpackMessages.js

* Do not parse `.eslintignore` (facebook#2115)

* Add `react-error-overlay` package (facebook#2111)

* 嗉 銇 鈼昣鈼 嗉姐仱 stack-frame-overlay

* Fix linting

* Remove auto overlay

* Fix e2e

* Pull in the rest

* Appease flow

* Correct dep

* Remove old repo references

* Check flow on test

* Test overlay in e2e

* Add cross env

* Rename package

* Make sure it gets built post-install

* Update the README

* Remove extra builds now that there's a postinstall script

* Revert "Remove extra builds now that there's a postinstall script"

This reverts commit 8bf601d.

* Remove broken script

* Fix some dev ergo

* Default to 0.0.0.0 (facebook#2117)

* Omit ESLint warnings when there are ESLint errors (facebook#2120)

* Adds tests for the overlay (facebook#2118)

* Add get-source-map tests

* Fixtures shouldn't be formatted

* Add mapper tests

* Add stack-frame tests

* Add more util tests

* Add unmapper tests

* Add parser tests

* Switch to snapshots

* Snapshot more

* disable ignoring unused vars prefixed with _ (facebook#1763)

* Bump React in development (facebook#2122)

* Make error box messages friendlier (facebook#2123)

* Only show first error (facebook#2125)

* Fix a bad condition

facebook#2123 (comment)

* Update Sass docs (facebook#2114)

* update readme with fix from facebook#1939

* update with better globbing

* added note

* updating with a note and reverting previous changes

* how about this?

* refactor

* added note about new files back in after verifying locally

* spaces back in, sorry was my editor!

* removed note about new files :)

* added bullet about new files issue currently open on node-sass

* Feature/different env config files facebook#1343 (facebook#1344)

* support different env configs.

* fomrat code

* Hide doc

* Slightly rework the PR

* Remove .env in default template
* Use just one entry in the paths
* Unify env.js and loadEnv.js

* Oops, forgot these folks

* Add note about yarn.lock in CONTRIBUTING.md (facebook#2135)

* Add note about yarn.lock in CONTRIBUTING.md

* Update CONTRIBUTING.md

* Update README.md (facebook#2137)

* Improve unmapper file heuristic, add limited warning support, and ignore internal errors (facebook#2128)

* Browser sort is not stable

* Fix ordering of final message

* Register the warning capture

* Display only createElement warnings

* Use different method name

* Fix regression

* Ignore errors with only node_module files

* Ignore null files, too

* Revise count

* Revise warning

* Update overlay.js

* Add support for facebook/react#9679

* Use absolute paths

* Trim path if it's absolute

* Make sure it's an absolute path

* Oops

* Tweak for new behavior

* Make it safer

* More resilient warnings

* Prettier output

* Fix flow

* Skip React frames that are too close (facebook#2143)

* Click to view source from error overlay (facebook#2141)

* Click to view source

* Update package.json

* Update package.json

* Fix lint

* Work around weird inferred name in Chrome

* Don't collapse unintentional top-level errors (facebook#2145)

* Don't collapse unintentional top-level errors

* Linkify internal stack frames too

* Add a missing color mapping (facebook#2146)

Closes facebook#2127

* Blacklist confusing global variables (facebook#2130)

* Blacklist confusing global variables

* Blacklist globals

* Fix kitchensink test to lint

* Edit the list

* Use no-restricted globals for this

* Temporarily fork detect-port (facebook#2147)

* Temporarily fork detect-port

* Fix get process id

* Use different package

* Unnecessary var

* Replace prompt function from react-dev-utils with Inquirer.js. (facebook#1772)

* Print error messages for editor integration (facebook#2150)

* Add custom eslint formatter (facebook#2138)

* Add custom eslint formatter

* Add formatter docs

* Update formatter docs

* Slightly tweak it

* Update README.md

* Fix CI

* Tweak error and warning output (facebook#2152)

* Tweak error and warning output

* Add a colon

* Focus on line in eslint messages

* Fix CI

* [Internal] Warn for missing brackets (facebook#2151)

* Warn for missing braces

* Overlay, too

* Allow custom proxies in development (facebook#1790)

* Change proxy handling to allow multiple proxies to be specified in package.json.

* Up webpack-dev-server to 2.4.2

Webpack Dev Server version 2.4.2 handles the external websocket upgrade
for all proxies

* Fix the listen() call

* Switch to correct default host

* Remove promises and extract to react-dev-utils

* oops

* Add support for IPv6 hosts

* Prefer localhost as an address (facebook#2154)

* Show network address on start (facebook#2155)

* Show network address on start

* Tweak visual representation

* Bump webpack packages

* Internal Webpack paths should not be clickable

* Make error/warning output more useful (facebook#2161)

* Fix lint

* Fix CI

* Update to Jest 19 (facebook#1614)

* Upgrade to Jest 19

* Use testMatch

* Correct version

* Put console.stack() behind a react vendor prefix (facebook#2164)

Matches what we did in facebook/react#9679

* Unpin Yarn (facebook#2124)

* Unpin Yarn

* Try 0.24.2

* Update e2e-simple.sh

* ESLint Config: Upgrade eslint-plugin-jsx-a11y and activate more rules. (facebook#2163)

* ESLint Config: Upgrade eslint-plugin-jsx-a11y and activate more rules.

* Try to fix Lerna

* Update README.md

* Remove html-has-lang

* Update README.md

* Removing extra `eslint` rules (facebook#2064)

Removing a stylistic lint rule

* Support hoisting react-scripts and add require.resolve() to loaders (facebook#2166)

* Support hoisting react-scripts

* require.resolve() loaders and configs

This makes it so that loaders and configs are resolved relative to the config rather than to the app. This seems to make more sense to me.

* Support node scripts in BROWSER (facebook#1590)

* Support node scripts in BROWSER

Modify OpenBrowser.js to run node scripts specified with the BROWSER environment
variable . If the value of the BROWSER environment variable ends with '.js' a
child process is spawned to execute the script with node.js. Any
arguments passed to npm start are also passed to this script, as well as
the url where the app is served.
The command executed in the child process is:

node <pathToScript> [OPTIONS] <url>

Update User Guide.

* Tweak code style

* Pin dep

* Comment out 0.10 docs

* Enable CSS sourcemaps in production (facebook#2168)

* Adding plugin postcss-flexbugs-fixes and flexbox: 'no-2009' to Autoprefixer (facebook#1771)

* Adding postcss-flexbugs-fixes

Using postcss-flexbugs-fixes to fix all flexbug's issues.

* Adding flexbox: 'no-2009' to Autoprefixer

It will add flexbox prefixes only for final and IE versions of
specification.

* Try to fix CI

* Try again

* Only run tests in <rootDir>/src (facebook#544) (facebook#1808)

* Only run tests in <rootDir>/src (facebook#544)

* updates Jest to 19.0.2

* removes testPathIgnorePatterns from jest config

* adds testMatch to jest config to only match files in src

* Bump babel-jest to 19.0.0 to match jest 19.0.2

* Bump dependencies (facebook#2170)

* Bump dependencies

* Bump CSS deps

* Somehow I missed dotenv

* Bump ESLint deps

* Tweak ESLint rules

* react-dev-utils/openBrowser now supports urls with 2+ params (facebook#2076)

* react-dev-utils/openBrowser now supports urls with 2+ params

Fixed facebook#2047

* react-dev-utils/openBrowser: encode url before open the browser

* Jest 20 (facebook#2171)

* Make coverage and snapshot Jest options overridable in package.json (facebook#1830)

* Override Jest config collectCoverageFrom with package.json

* Protect against overriding other options

* Better error message

* Create Jest config early on eject

* Tweak wording

* Dry it up

* Bump versions

* Resolve regenerator runtime relative to react-scripts (facebook#2175)

* Fix Flow hopefully

* Disable require.ensure() warning (facebook#2177)

* Reenable require.ensure()

* Tweak colors for better contrast on Windows (facebook#2180)

* Handle errors from port detector (facebook#2182)

* Tweak lint rules (facebook#2186)

* Ignore Moment.js locales by default (facebook#2187)

* Ignore Moment.js locales by default

* Update README.md

* Disable Yarn on CI temporarily

* Add module scope plugin (facebook#2189)

* Add module scope plugin

* Oops

* Add comments

* Check windows seps too

* More descriptive error

* Document it

* Webpack config typo (facebook#2193)

* Webpack config typo

* Webpack config more typo

* PWA-ification, via SWPrecacheWebpackPlugin + manifest.json (facebook#1728)

* sw-precache-webpack-plugin, SW registration, manifest.json

* Documentation + a few SW tweaks.

* Added an unregister method, too, just in case.

* More info for the READMEs.

* Add minify to SWPrecacheWebpackPlugin config

* Fix SWPrecacheWebpackPlugin typo

* Fix file references in READMEmd

* Add instructions for testing service-worker locally

* Review feedback

* Some additional PWA metadata

* Use sw-precache-webpack-plugin v0.9.1 for node >=4.0.0 support

* Review feedback.

* Add manifest.json context in a comment.

* Fix typo

* Downgrade to sw-precache-webpack-plugin 0.9.1

* Hide changes in README until 1.0

* Hide changes in User Guide until 1.0

* Hide more docs

* Tidy up some build logs (facebook#2197)

* Bump Jest to 20.0.3 (facebook#2196)

* Test module scoping (facebook#2198)

* Correct readme

* Add tests

* Update README.md

* Disable Uglify reduce_vars (facebook#2200)

* Tweaking error overlay styles (facebook#2201)

* Tweaked overlay styles

* Tweaked pre-style

* Clicked to background overlay dismiss

* Tidied up styles tobe more mobile Safari friendly

* Re-enabled pre-wrap

* Margin fixes

* Base font-size 10 -> 11px

* Error overlay is full-screen now based on feedback

* Make "N errors on the page" visible again

* Fix bottom margin of frame location and lack of tab nav

* Add tooltip to close button

* Bring compile error styles closer to runtime overlay

* s/when/if/

* Refactor and improve build output (facebook#2202)

* Tweaked error overlay styles (pt2) (facebook#2208)

* Fixed several of the issues and nits from PR:

* Moved margin between header and file name to header, so when content was scrolled, the header would remain more separate
* Made build-time and runtime overlays better match
* Secondary error <pre> style now uses yellow bg instead of red
* 'Scrollable Header' (see above comment to why this is necessary) but I did increase the max-height from 35% to 50%.
* Fixed header and 'X' button vertical alignment

* Temporary stack margin fix

* Move "N errors" to the top

* Move more logic from react-scripts to react-dev-utils (facebook#2209)

* Show warnings for builds

* Move WebpackDevServer helpers into react-dev-utils

* Fix vertical alignment of close button

* Cleaned up next/prev error arrow styles; arrows wrap around when clicked now (facebook#2210)

* Add temporary support for Node 4.x to global CLI (facebook#2214)

* Replace text-align: start with left to fix Edge (facebook#2215)

* ES6 syntax (facebook#2213)

* Move error overlay middleware (facebook#2216)

* "rule keywords" => "keywords"

* Improve interaction between compile and runtime overlays (facebook#2219)

* Better document PWA stuff

* Enable 1.0 docs (facebook#2220)

* Uncomment merged PRs

* Switch to br

* Update some webpack links

* Add a little about section for PWA

* oops

* fast on subsequent visits

* Add manual proxy config instructions

* hint package.json

* Change to js for comments

* Tune wording

* Add documentation about using code splitting (facebook#1801)

* Add documentation about using code splitting

* Revise docs a bit

* Update README.md

* Update README.md

* Update README.md

* Swap changelogs (facebook#2222)

* Swap changelogs

* Update and rename CHANGELOG.md to CHANGELOG-0.x.md

* Update and rename CHANGELOG-1.x.md to CHANGELOG.md

* Update CHANGELOG.md

* Publish

 - babel-preset-react-app@3.0.0
 - create-react-app@1.3.1
 - eslint-config-react-app@1.0.0
 - react-dev-utils@1.0.0
 - react-error-overlay@1.0.0
 - react-scripts@1.0.0

* Update CHANGELOG.md

* March -> May

* Fix shortcut handling in react-error-overlay (facebook#2238)

* Add explicit package dependence (facebook#2243)

Closes facebook#2232

* Fix read of .env variables (facebook#2242)

* Gracefully shut down the server on signals (facebook#2246)

* Shame on me

* Correct docs on which .env.* files are supported. (facebook#2247)

* Correct which .env. files are referenced in docs

* Highlight this is not available until 1.0.0

* Formatting

* Update README.md

* Update README.md

* Hide React Storybook from the User Guide while it's incompatible (facebook#2252)

* Hide React Storybook from the User Guide while it's incompatible

* Update README.md

* Show customized build path for serve instruction (facebook#2229)

* Show customized build path for serve instruction

* Remove cyan

* Ignore .env.local in test environment (facebook#2250)

* add noscript to template's index.html (facebook#2224)

* add noscript to template's index.html

* Tweak message

* Work around Windows path issue in SWPrecacheWebpackPlugin (facebook#2255)

* Turn off operator-assignment stylistic rule (facebook#2256)

* update readme with example of include path (facebook#2258)

* update readme with example of include path

* Update README.md

* update reference with new name (facebook#2259)

s/adding-images-and-fonts/adding-images-fonts-and-files/

* Additional fix to service worker config for "homepage" field (facebook#2262)

* Always resolve NODE_PATH (facebook#2261)

* Always resolve NODE_PATH

* Update env.js

* Fix a bug on empty NODE_PATH (facebook#2264)

* Shut down server silently, as it is too noisy

* Add changelog for 1.0.1 (facebook#2266)

* Publish

 - eslint-config-react-app@1.0.1
 - react-dev-utils@1.0.1
 - react-error-overlay@1.0.1
 - react-scripts@1.0.1

* Fix missing dependency (facebook#2269)

* Adding missing dependency

* Pinning text-table dependency

* Describe build in less fluffy terms

* Update README.md

* Update README.md

* Update CHANGELOG.md

* Add WSL support to launchEditor utility (facebook#2282)

* Only enable host check if you use proxy, and add a way to opt out of it (facebook#2288)

* Disable host check if you don't use proxy

* Add a way to opt out and document it

* Ejecting should ensure you have clean git status (facebook#2221)

* Ejecting should ensure you have clean git status

* Rename function

* Style

* Minor changes

- extract function
- exclude error output for missing git
- more descriptive error message
- no need to mutate answer
- fix answering "no" to return 0 exit code

* Add missing license headers

* Wrap console calls into a check (facebook#2290)

* Provide a no-op SW that will be served by the dev environment. (facebook#2276)

* Provide a no-op SW that will be served by the dev environment.

* Hide no-op service worker from user

* Remove unnecessary dependencies(facebook#751) (facebook#2283)

* Remove unnecessary dependencies(facebook#751)

* Sort alphabetically

* Add changelog for 1.0.2 (facebook#2291)

* Publish

 - react-dev-utils@1.0.2
 - react-error-overlay@1.0.2
 - react-scripts@1.0.2

* Roll back to an older version of case-sensitive-paths-webpack-plugin (facebook#2314)

* Wrap console calls into a check (facebook#2301)

* Wrap console calls into a check

* Add another check

* Remove `flowtype/require-valid-file-annotation` temporarily. (facebook#2311)

Until this issue (gajus/eslint-plugin-flowtype#165) is
fixed we're disabling `flowtype/require-valid-file-annotation`.

* Ensure address is private (facebook#2297)

* Ensure address is private
Resolves facebook#2296

* adjust rule

* Update WebpackDevServerUtils.js

* Changelog for 1.0.3 (facebook#2315)

* Publish

 - eslint-config-react-app@1.0.2
 - react-dev-utils@1.0.3
 - react-error-overlay@1.0.3
 - react-scripts@1.0.3

* Remove tarec from README (facebook#2323)

I no longer support this package.

Create-react-app is so great I can no longer call tarec a credible alternative 馃槃

* 1.0.4 changelog

* Publish

 - react-error-overlay@1.0.4
 - react-scripts@1.0.4

* Remove connect-history-api-fallback and cross-spawn dependencies from react-scripts (facebook#751) (facebook#2320)

* Allow declaring variables before use in a scope above (facebook#2325)

* Limit console warnings to 5 files at most (facebook#2327)

* Files in public/ folder should not be requested through proxy (facebook#2326)

* Add changelog for 1.0.5 (facebook#2329)

* Add "Migrating" section

* Publish

 - eslint-config-react-app@1.0.3
 - react-dev-utils@2.0.0
 - react-error-overlay@1.0.5
 - react-scripts@1.0.5

* Add missing files to README (facebook#2334)

* add missing files

* Update README.md

* Update CHANGELOG.md

* Don't resolve localhost if on network (facebook#2332)

* Don't resolve if on network

* Update WebpackDevServerUtils.js

* Resolve flow errors in eslint JSX a11y (facebook#2346)

* Upgraded eslint-plugin-jsx-a11y to 5.0.3 to take advantage of
  d70ac7d7975819e7a52b85465ec67a0d93eb962a

* Add navigateFallbackWhitelist /__* to SW Precache config (facebook#2347)

* Add navigateFallbackWhitelist /__* to SW Precache config

* Add comments

* Add changelog for 1.0.6 (facebook#2348)

* Publish

 - eslint-config-react-app@1.0.4
 - react-dev-utils@2.0.1
 - react-error-overlay@1.0.6
 - react-scripts@1.0.6

* Update webpack to v2.6.0 in react-scripts (facebook#2349)

* Fix broken links (facebook#2350)

* Print file sizes with correct build folder path. (facebook#2361)

* Print file sizes with correct build folder path.

* Just use the print the basename.

* Update README.md for `now` deployments (facebook#2372)

Simplified steps for deploying app to `now` as a static site. No need to `serve` script in `package.json` file. As of May 15, 2017, all static deployments on `now` are free and unlimited.

* Removed the overriding of reduce_vars to false since webpack v2.6.0 included the fixed for Uglify bug (facebook#2351)

* Disable comparisons feature in uglify compression in production (facebook#2379)

* Disable a micro-option in uglify that appears to be buggy

See facebook#2376

* wrong plugin

* Add a comment

* Consistently set environment variables (facebook#2382)

* Update webpack to 2.6.1 (facebook#2383)

* Add changelog for 1.0.7 (facebook#2384)

* Publish

 - react-dev-utils@3.0.0
 - react-error-overlay@1.0.7
 - react-scripts@1.0.7

* Bump beta version

* Fix deploy script env vars

* Bump react-scripts beta version

* Fix Sass transforms and module mapping in the Jest config

* Update babel-preset-trunkclub beta version; add code coverage to tests

* Update Flow dependency, remove old devDeps, bump beta version

* Update the v8 upgrade docs

* Update Jest config

* Run prettier on build-module script before merging TC upstream

* Update upgrade docs

* Release v9.0.0
@FDiskas

This comment has been minimized.

Copy link

commented Aug 2, 2017

I suggest to use scripts like so

    "prebuild": "node-sass-chokidar src/ -o src/",
    "prestart": "npm run prebuild && node-sass-chokidar src/ -o src/ --watch --recursive"

mfogel added a commit to allthetravelmaps/webapp that referenced this pull request Dec 2, 2017

@lock lock bot locked and limited conversation to collaborators Jan 21, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can鈥檛 perform that action at this time.