Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Remove note about webpackHotDevClient being webpack 1.0 only #2798

Merged
merged 3 commits into from Aug 2, 2017

Conversation

Projects
None yet
4 participants
@ForbesLindesay
Copy link
Contributor

commented Jul 16, 2017

It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.

Remove note about webpackHotDevClient being webpack 1.0 only
It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.
@Timer

This comment has been minimized.

Copy link
Collaborator

commented Jul 16, 2017

Maybe we should update it to say it only supports webpack 2.x? We provide no guarantees for older webpacks.

@gaearon

This comment has been minimized.

Copy link
Member

commented Jul 16, 2017

Yep we should do that.

@ForbesLindesay

This comment has been minimized.

Copy link
Contributor Author

commented Jul 20, 2017

Updated as per your suggestion.

@Timer Timer merged commit 13c7360 into facebook:master Aug 2, 2017

1 check was pending

continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
@Timer

This comment has been minimized.

Copy link
Collaborator

commented Aug 2, 2017

Thanks! I updated it to webpack 3.x since we switched to it now.

JohnNilsson referenced this pull request in JohnNilsson/create-react-app-typescript Aug 9, 2017

Update webpack version note (#2798)
* Remove note about webpackHotDevClient being webpack 1.0 only

It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.

* Update README.md

* Update README.md

zangrafx added a commit to absolvent/create-react-app that referenced this pull request Aug 13, 2017

Merge commit 'bfaee410c502a95076a6bd89721c76ca08e15f7b'
* commit 'bfaee410c502a95076a6bd89721c76ca08e15f7b': (39 commits)
  Publish
  Prepare for 1.0.11 release (facebook#2924)
  Update dev deps (facebook#2923)
  Update README.md
  Use env variable to disable source maps (facebook#2818)
  Make formatWebpackMessages return all messages (facebook#2834)
  Adjust the `checkIfOnline` check if in a corporate proxy environment (facebook#2884)
  Fix the order of arguments in spawned child proc (facebook#2913)
  Feature/webpack 3 4 (facebook#2875)
  Allow importing package.json (facebook#2468)
  Re-enable flowtype warning (facebook#2718)
  Format UglifyJs error (facebook#2650)
  Unstage yarn.lock pre-commit (facebook#2700)
  Update README.md
  Update README.md
  Add Electrode to alternatives (facebook#2728)
  Fix parsing HTML/JSX tags to real elements (facebook#2796)
  Update webpack version note (facebook#2798)
  Use modern syntax feature (facebook#2873)
  Allow use of scoped packages with a pinned version (facebook#2853)
  ...

# Conflicts:
#	packages/react-scripts/config/webpack.config.dev.js
#	packages/react-scripts/config/webpack.config.prod.js
#	packages/react-scripts/package.json

JohnNilsson referenced this pull request in JohnNilsson/create-react-app-typescript Sep 9, 2017

Update webpack version note (#2798)
* Remove note about webpackHotDevClient being webpack 1.0 only

It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.

* Update README.md

* Update README.md

Ayc0 pushed a commit to Ayc0/create-react-app that referenced this pull request Sep 18, 2017

Update webpack version note (facebook#2798)
* Remove note about webpackHotDevClient being webpack 1.0 only

It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.

* Update README.md

* Update README.md

kasperpeulen added a commit to kasperpeulen/create-react-app that referenced this pull request Sep 24, 2017

Update webpack version note (facebook#2798)
* Remove note about webpackHotDevClient being webpack 1.0 only

It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.

* Update README.md

* Update README.md

swengorschewski referenced this pull request in swengorschewski/cra-typescript-electron Oct 16, 2017

Update webpack version note (#2798)
* Remove note about webpackHotDevClient being webpack 1.0 only

It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.

* Update README.md

* Update README.md

jdcrensh added a commit to jdcrensh/create-react-app that referenced this pull request Oct 24, 2017

Update webpack version note (facebook#2798)
* Remove note about webpackHotDevClient being webpack 1.0 only

It must work in webpack 2 since create-react-app is still using it and is using webpack 2 now.

It would be great if you could add some kind of note about how it differs from the default webpack hot reloaders.

* Update README.md

* Update README.md

@lock lock bot locked and limited conversation to collaborators Jan 21, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.