New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Old library end of life (EOL) support. #193

Closed
vtsao opened this Issue Dec 20, 2016 · 1 comment

Comments

Projects
None yet
2 participants
@vtsao
Member

vtsao commented Dec 20, 2016

This issue tracks the support plan and timeline for the old library before it reaches end of life (EOL). The old library will be sunset at the end of July 2017 where it will no longer be updated and we will no longer offer support for it.

11/2016 12/2016 01/2017 ... 7/2017 8/2017 ...
Old library Stable Deprecated Deprecated ... Sunset end of month N/A ...
New library Beta Stable release Stable ... Stable Stable ...

In the meantime, the old library will continue to receive reduced support until it reaches EOL. The new library was released as 25.0.0 to allow releases to still be made for the old library, which are versions < 25.0.0.

For the old library, we will still do the following:

  • Bug fixes will still be made.
  • Updates to support new AdWords and DFP API version releases and sunsets.
  • Releases will still be made.

And no longer be doing the following:

  • Adding new examples, features, or utilities, unless they are absolutely necessary.
  • Accepting pull requests.

@googleads googleads locked and limited conversation to collaborators Dec 20, 2016

@vtsao vtsao self-assigned this Dec 20, 2016

@vtsao vtsao changed the title from E to Old library end of life (EOL) support. Dec 22, 2016

@googleads googleads unlocked this conversation Dec 22, 2016

@vtsao vtsao added the old library label Dec 22, 2016

@vtsao vtsao assigned fiboknacky and unassigned vtsao Feb 24, 2017

@fiboknacky

This comment has been minimized.

Show comment
Hide comment
@fiboknacky

fiboknacky Mar 28, 2018

Contributor

All supported versions of the deprecated library are sunset, so I close this issue.

Contributor

fiboknacky commented Mar 28, 2018

All supported versions of the deprecated library are sunset, so I close this issue.

@fiboknacky fiboknacky closed this Mar 28, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment