Skip to content
master
Go to file
Code

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
Sep 10, 2020

README.md

Build Status

HERE Mobile SDK 3.x for iOS example projects

Copyright (c) 2011-2020 HERE Europe B.V.

This repository holds a series of Objective-C and Swift projects using the HERE Mobile SDK for iOS. More information about the API can be found on developer.here.com under the Android & iOS SDKs section.

This set of self-contained, use-case based projects is designed to be cloned by developers for their own use.

Note: In order to get the sample code to work, you must replace all instances of {YOUR_APP_ID}, {YOUR_APP_CODE} and {YOUR_LICENSE_KEY} within the code and use your own HERE credentials.

You can obtain a set of credentials from the Contact Us page on developer.here.com.The bundle ID registered must match it in your app.

License

Unless otherwise noted in LICENSE files for specific files or directories, the LICENSE in the root applies to all content in this repository.

HERE Mobile SDK for iOS (Premium)

All of the following projects use version 3.16 of the HERE Mobile SDK for iOS (Premium)

How to build apps

Using CocoaPods

  1. Run "pod install" or "pod update" in the application's root directory to install the HERE Mobile SDK.

  2. In the "General" settings of the App target:

    • Select an eligible provisioning profile or enable "Automatically manage signing".
  3. In AppDelegate.m:

    • Enter an app id, app code and license key.

Without CocoaPods

  1. In the "General" settings of the App target:

    • Select an eligible provisioning profile or enable "Automatically manage signing".
    • Add NMAKit.framework to the "Embedded Content" section in Xcode. Otherwise you will get a "dyld: Library not loaded: @rpath/NMAKit.framework/NMAKit" error at runtime.
  2. In the "Builds Settings" of the App target:

    • Ensure "Frameworks Search Paths" includes the location of NMAKit.framework. Drag and drop NMAKit.framework to $(PROJECT_DIR) in case of import error.
  3. In AppDelegate.m:

    • Enter an app id, app code and license key.

Build Requirements

  • Xcode 11 or above
  • HERE Mobile SDK for iOS (Premium) Version 3.16 or above

Target Platform

  • iOS 12 or above
  • iOS 13 or above for SwiftUI sample
You can’t perform that action at this time.