Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Doesn't run correctly on Windows 10 #22

Open
MarkCallow opened this issue Sep 16, 2016 · 7 comments
Open

Doesn't run correctly on Windows 10 #22

MarkCallow opened this issue Sep 16, 2016 · 7 comments

Comments

@MarkCallow
Copy link

@MarkCallow MarkCallow commented Sep 16, 2016

Get an Aero-like window border with no controls and nothing happens when you click on "File".

I had to use the compatibility troubleshooter and set PP to be run as a Windows 8 app to be able to use it.

@jaytaoko
Copy link
Contributor

@jaytaoko jaytaoko commented Sep 18, 2016

This issue could be similar to #18. See if PicoPixel 0.6.12 fixes this issue for you. Please report here if you still have the issue.

Thanks!

@MarkCallow
Copy link
Author

@MarkCallow MarkCallow commented Sep 19, 2016

Still have the issue with 0.6.12. It is slightly different in that there is now no window frame (border) at all. Before there was an aero-like window frame. The application's client content (UI etc.) is drawn as expected but nothing happens when clicking File or the menu buttons.

This is different from #18. I'm on an Intel GPU and I see much more than an empty window.

@jaytaoko
Copy link
Contributor

@jaytaoko jaytaoko commented Sep 19, 2016

Can you tell the Intel CPU you are running on? Also can you add a screenshot of the issue to this ticket?
Thanks

@MarkCallow
Copy link
Author

@MarkCallow MarkCallow commented Sep 19, 2016

Intel Core i5-5200, HD Graphics 5500. But I don't think the problem is GPU related. It's Windows 10 related. If I tell Windows to run the program in compatibility mode for Window 8 it works fine. I can operate the program via keyboard commands when not in compatibility mode. It's just the GUI controls that don't work.

The aero-like frame is still there, after all. Not sure why it didn't appear one time. Here's the image.

picopixel

@jaytaoko
Copy link
Contributor

@jaytaoko jaytaoko commented Sep 26, 2016

I confirm the issue. I am working on a fix.
Thanks

@jaytaoko
Copy link
Contributor

@jaytaoko jaytaoko commented Nov 20, 2016

I have released a new version of PicoPixel (0.6.13). Unfortunately, I believe there is an issue with the Intel graphics driver that prevents from resolving this issue in a way that does not affect the appearance of PicoPixel. So, for the moment PicoPixel will automatically show the window frame when running on an Intel HD GPU.

picopixel-withframe

All the features of PicoPixel are there. Only the window frame has changed. When running on a Geforce or Radeon GPU, PicoPixel appearance is unchanged.

@jaytaoko
Copy link
Contributor

@jaytaoko jaytaoko commented Nov 20, 2016

Please report if you still see the original issue on your system. Is the fix improving the situation?
Regards

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.