Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Avoid breaking change in latest directory_watcher #883

Merged
merged 1 commit into from

3 participants

@liliakai

We need to be a little more pressimistic about the directory_watcher
gem, since it's latest version (1.5) breaks jekyll's --auto option.

Fixes jekyll/jekyll#882.

Lilia Markham Avoid breaking change in latest directory_watcher
We need to be a little more pressimistic about the directory_watcher
gem, since it's latest version (1.5) breaks jekyll's --auto option.

Fixes jekyll/jekyll#882.
e99d35a
@parkr
Owner

What error do you get? Let's update the code in lib/jekyll/commands/build.rb to work with the new version!

@mattr-
Owner
@parkr
Owner

How's it broken?

@parkr parkr merged commit 6cc5341 into jekyll:0.12.1-release

1 check passed

Details default The Travis build passed
@parkr
Owner

Whoops, that was totally the wrong branch. Adding this to master.

@parkr parkr referenced this pull request from a commit
@parkr parkr Update history to reflect merge of #883 0520ecb
@mattr-
Owner

For example of alleged brokenness, see TwP/directory_watcher#22

This was referenced
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Mar 25, 2013
  1. Avoid breaking change in latest directory_watcher

    Lilia Markham authored
    We need to be a little more pressimistic about the directory_watcher
    gem, since it's latest version (1.5) breaks jekyll's --auto option.
    
    Fixes jekyll/jekyll#882.
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 1 deletion.
  1. +1 −1  jekyll.gemspec
View
2  jekyll.gemspec
@@ -25,7 +25,7 @@ Gem::Specification.new do |s|
s.add_runtime_dependency('liquid', "~> 2.3")
s.add_runtime_dependency('classifier', "~> 1.3")
- s.add_runtime_dependency('directory_watcher', "~> 1.1")
+ s.add_runtime_dependency('directory_watcher', "~> 1.4.1")
s.add_runtime_dependency('maruku', "~> 0.5")
s.add_runtime_dependency('kramdown', "~> 0.14")
s.add_runtime_dependency('pygments.rb', "~> 0.3.2")
Something went wrong with that request. Please try again.