New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Downgrading requests causes issues with old versions of pip #5264

Closed
mrpau-eduard opened this Issue Aug 29, 2016 · 3 comments

Comments

Projects
None yet
2 participants
@mrpau-eduard
Member

mrpau-eduard commented Aug 29, 2016

Summary

Edit: @benjaoming

The downgrading of requests causes issues with pip both system-wide and inside virtualenvs (in which, however, pip isn't needed unless user installs additional pkgs from PyPi)

This is known to affect older versions of pip, 1.5.6 especially

The fix will arrive in 0.17.


The original issue here is we downgrade requests to fix the Unclean shutdown on OS X.
Spawn issue after the downgrade Ka-lite installed with PIP break the latter.

System information

  • Operating system: OS X, Debian Jessie
  • Version: 0.16.

Real-life consequences (anything community should be aware, for instance how it affects your deployment)

@mrpau-eduard

This comment has been minimized.

Show comment
Hide comment
@mrpau-eduard

mrpau-eduard Aug 29, 2016

Member

We need to replace Pyrun by PEX base on the spawning issue. PEX will isolate the virtual environment for ka-lite to prevent some issue like this. Then we need upgrade the requests to requests==2.10.0

Member

mrpau-eduard commented Aug 29, 2016

We need to replace Pyrun by PEX base on the spawning issue. PEX will isolate the virtual environment for ka-lite to prevent some issue like this. Then we need upgrade the requests to requests==2.10.0

@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Sep 5, 2016

Member

@mrpau-eduard - it's unclear to me what the issue on Debian Jessie is?

But I agree, we need to get requests upgraded ASAP because of the pip breakage.

Member

benjaoming commented Sep 5, 2016

@mrpau-eduard - it's unclear to me what the issue on Debian Jessie is?

But I agree, we need to get requests upgraded ASAP because of the pip breakage.

@benjaoming benjaoming changed the title from Downgrading requests having an issue on Debian Jessie to Downgrading requests causes issues with pip Sep 5, 2016

@benjaoming benjaoming changed the title from Downgrading requests causes issues with pip to Downgrading requests causes issues with old versions of pip Sep 5, 2016

@benjaoming benjaoming added the bug label Sep 5, 2016

@benjaoming benjaoming added this to the 0.17.0 milestone Sep 5, 2016

@mrpau-eduard mrpau-eduard referenced this issue Sep 14, 2016

Closed

Update requests version to 2.10.0 #5278

0 of 3 tasks complete
@benjaoming

This comment has been minimized.

Show comment
Hide comment
@benjaoming

benjaoming Oct 2, 2016

Member

Fixed in #5285

requests is now in version 2.11.1 in develop, will be released in 0.17 - prereleased in 0.17b1 on PyPi

Member

benjaoming commented Oct 2, 2016

Fixed in #5285

requests is now in version 2.11.1 in develop, will be released in 0.17 - prereleased in 0.17b1 on PyPi

@benjaoming benjaoming closed this Oct 2, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment