Permalink
Browse files

build: use wxneeded on openbsd

On OpenBSD 6.0 and greater W^X is enabled by default. All executables
that violate W^X need to be marked with PT_OPENBSD_WXNEEDED. In
addition to this, they must be executed from a filesystem mounted with
'wxallowed'.

More info on W^X: https://en.wikipedia.org/wiki/W%5EX

PR-URL: #9232
Reviewed-By: James M Snell <jasnell@gmail.com>
Reviewed-By: Johan Bergström <bugs@bergstroem.nu>
Reviewed-By: Ben Noordhuis <info@bnoordhuis.nl>
  • Loading branch information...
qbit authored and MylesBorins committed Oct 21, 2016
1 parent ed31f9c commit 59d821debeec4ef18cfb209e93d913f43cee7df7
Showing with 3 additions and 0 deletions.
  1. +3 −0 common.gypi
View
@@ -276,6 +276,9 @@
['_type=="static_library" and OS=="solaris"', {
'standalone_static_library': 1,
}],
['OS=="openbsd"', {
'ldflags': [ '-Wl,-z,wxneeded' ],
}],
],
'conditions': [
[ 'target_arch=="ia32"', {

0 comments on commit 59d821d

Please sign in to comment.