Permalink
Browse files

deps: upgrade npm to 4.0.5

PR-URL: #10330
Reviewed-By: Myles Borins <myles.borins@gmail.com>
  • Loading branch information...
1 parent 7ad0f7b commit 92eacdb5c60072295f9a50306d40f69b5aeb97c6 @zkat zkat committed with evanlucas Dec 19, 2016
Showing 719 changed files with 38,691 additions and 13,904 deletions.
@@ -13,13 +13,17 @@ matrix:
env: DEPLOY_VERSION=testing COVERALLS_REPO_TOKEN="$COVERALLS_OPTIONAL_TOKEN"
script:
- "node . run tap-cover -- \"test/tap/*.js\""
- - "unset COVERALLS_REPO_TOKEN ; node . run tap -- \"test/slow/*.js\" \"test/broken-under-*/*.js\""
+ - "unset COVERALLS_REPO_TOKEN ; node . run tap -- \"test/broken-under-*/*.js\""
# previous LTS is next most important
- node_js: "4"
env: DEPLOY_VERSION=testing
# then master
- node_js: "7"
env: DEPLOY_VERSION=testing
+ # then 0.12, which is still in maintenance mode until the end of 2016 I guess?
+ # https://github.com/nodejs/LTS#lts-schedule
+ - node_js: "0.12"
+ env: DEPLOY_VERSION=testing
before_install:
# required by test/tap/registry.js
- "mkdir -p /var/run/couchdb"
@@ -29,6 +33,7 @@ cache:
directories:
- $HOME/.npm
- node_modules/.bin
+ - node_modules/.cache
- node_modules/deep-equal
- node_modules/marked
- node_modules/marked-man
@@ -45,4 +50,4 @@ install:
- "node . install --ignore-scripts"
- "make -j4 doc"
script:
- - "node . run tap -- \"test/tap/*.js\" \"test/slow/*.js\" \"test/broken-under-nyc/*.js\""
+ - "node . run tap -- \"test/tap/*.js\" \"test/broken-under-nyc/*.js\""
View
@@ -435,3 +435,13 @@ Ionică Bizău <bizauionica@gmail.com>
Alex Chesters <AlexChesters@users.noreply.github.com>
Robert Gay <robert.gay@redfin.com>
Steven <stevokk@hotmail.com>
+Tim Caswell <tim@creationix.com>
+Anna Henningsen <github@addaleax.net>
+Kim Røen <kim@kimroen.com>
+Douglas Wilson <dougwilson@live.com>
+Mike Engel <mike@mike-engel.com>
+baderbuddy <baderbuddy@gmail.com>
+Alex Jordan <alex@strugee.net>
+Ville Lahdenvuo <tuhoojabotti@gmail.com>
+Natalie Wolfe <nwolfe@newrelic.com>
+Andrew Schmadel <aschmadel@learningobjects.com>
View
Oops, something went wrong.
View
@@ -1,6 +1,6 @@
npm(1) -- a JavaScript package manager
==============================
-[![Build Status](https://img.shields.io/travis/npm/npm/master.svg)](https://travis-ci.org/npm/npm)
+[![Build Status](https://img.shields.io/travis/npm/npm/latest.svg)](https://travis-ci.org/npm/npm)
## SYNOPSIS
This is just enough info to get you up and running.
@@ -27,15 +27,15 @@ terms of use for the default public registry are available at
## Super Easy Install
-npm is bundled with [node](http://nodejs.org/download/).
+npm is bundled with [node](https://nodejs.org/en/download/).
### Windows Computers
-[Get the MSI](http://nodejs.org/download/). npm is in it.
+[Get the MSI](https://nodejs.org/en/download/). npm is in it.
### Apple Macintosh Computers
-[Get the pkg](http://nodejs.org/download/). npm is in it.
+[Get the pkg](https://nodejs.org/en/download/). npm is in it.
### Other Sorts of Unices
@@ -156,7 +156,7 @@ When you find issues, please report them:
Be sure to include *all* of the output from the npm command that didn't work
as expected. The `npm-debug.log` file is also helpful to provide.
-You can also look for isaacs in #node.js on irc://irc.freenode.net. He
+You can also look for isaacs in #node.js on irc://irc.freenode.net. She
will no doubt tell you to put the output in a gist or email.
## SEE ALSO
@@ -16,11 +16,15 @@
process.title = 'npm'
+ var unsupported = require('../lib/utils/unsupported.js')
+ unsupported.checkForBrokenNode()
+
var log = require('npmlog')
log.pause() // will be unpaused when config is loaded.
-
log.info('it worked if it ends with', 'ok')
+ unsupported.checkForUnsupportedNode()
+
var path = require('path')
var npm = require('../lib/npm.js')
var npmconf = require('../lib/config/core.js')
Oops, something went wrong.

0 comments on commit 92eacdb

Please sign in to comment.