Skip to content

@aperezg aperezg released this Jan 12, 2020 · 1 commit to master since this release

errors 0.9.0 is a preparation release for a 1.0 final release. Also we were working on removing support for Go 1.8, 1.9 and 1.10 and earlier, and become compatible this package with new way of errors on Go 1.13.

We tried to move into runtime.CallerFrames but this was not possible, you can show the explanation here: Issue 188.

The motivation for do the backward compatible this package with Go 1.13 is that you can migrate the easy way for this to the new way.

Now you could use the methods, Is and As, and the Unwrap() interface like on the standard library.

The method Cause is now compatible with fmt.Errorf("%w", err) and with the Unwrap() interface.

On the same way the methods related with wrapping on this package now are compatible with Cause and Unwrap() interface.

Improvements

  • .travis.yml Now use make file.
  • reduce allocations when printing stack traces. Thanks @cstockton
  • Reduce allocations in Stacktrace.Format
  • Add Support to Go 1.13. Thanks @jayschwa, @Sherlock-Holo and @puellanivis.
  • Add json.Marshaler support to the Frame type. Thanks @flimzy

Bugs fixed

  • .travis.yml Adjust Go versions. Thanks @komuw, @aperezg
  • minor fix in an example to print Stack Trace. Thanks @bep.
  • Remove not necessary code.
  • Clean up documentation. Thanks @seh.
Assets 2
You can’t perform that action at this time.