Repository navigation
Security notice: critical PHP vulnerabilities (CVE-2026-109618, CVE-2026-109619) #247
LucaGiardi20
announced in
Announcements
Replies: 0 comments
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Uh oh!
There was an error while loading. Please reload this page.
On 21 October 2026 the PHP project released emergency security updates for two critical remote code execution vulnerabilities (both CVSS v4.0 9.2):
These are bugs in PHP itself, not in Externa, but every Externa install runs on PHP, so please update.
Affected and fixed versions
Externa requires PHP 8.4+ (
^8.4), so you need PHP 8.4.27 or 8.5.12 or later.What to do
php -v.ghcr.io/qiick-io/externa-core): The 1.2.1 image (andlatest) has been rebuilt on PHP 8.4.27. Pullghcr.io/qiick-io/externa-core:1.2.1again and recreate the containers (docker compose pull && docker compose up -d), then check withdocker compose exec <php-service> php -v.--pull --no-cacheso you pick up the updatedphp:8.4-fpm-bookwormbase (PHP 8.4.27).If you can't update right away
Updating PHP is the only complete fix. The PHP advisories list these partial mitigations:
memory_limit=-1in the server-level PHP config (php.ini / FPM pool, not per-directory), restart every worker, and rely on a container or cgroup memory limit instead. Do not useRLIMIT_AS/RLIMIT_DATA.post_max_sizeconservative, enforce request size at your reverse proxy, and limit multipart parts, headers per part, uploads andmax_input_nesting_level. If you don't need multipart uploads on a route, block them at the proxy.session.upload_progress.enabled=0and restart every worker.fatal_error_backtraces=0and restart every worker.pm.max_requests=1in PHP-FPM if performance allows.Note: Externa's file uploads use multipart requests, so blocking multipart entirely will break uploads in the admin.
Coming in Externa 1.2.2
Externa 1.2.2 will ship additional
php.inihardening for the official image (#216).All reactions