Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Does not appear to be an R package (No Description) #1939

Closed
asimumba opened this issue Dec 7, 2018 · 6 comments

Comments

@asimumba
Copy link

commented Dec 7, 2018

Hi, when I try to install from Github using devtools I get these error messages:

devtools::install_github("pablobarbera/instaR/instaR")
Downloading GitHub repo pablobarbera/instaR@master
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Archive entry has empty or unreadable filename ... skipping.
tar.exe: Error exit delayed from previous errors.
Error: Does not appear to be an R package (no DESCRIPTION)
In addition: Warning messages:
1: In utils::untar(tarfile, ...) :
  ‘tar.exe -zxf

This seem to happen with other packages from Github too.

Session info

- Session info -------------------------------------------------------------------------------------------
 setting  value                       
 version  R version 3.5.1 (2018-07-02)
 os       Windows 10 x64              
 system   x86_64, mingw32             
 ui       RStudio                     
 language (EN)                        
 collate  English_United States.1252  
 ctype    English_United States.1252  
 tz       Africa/Johannesburg         
 date     2018-12-07                  

- Packages -----------------------------------------------------------------------------------------------
 package     * version date       lib source        
 assertthat    0.2.0   2017-04-11 [1] CRAN (R 3.5.1)
 backports     1.1.2   2017-12-13 [1] CRAN (R 3.5.0)
 base64enc     0.1-3   2015-07-28 [1] CRAN (R 3.5.0)
 callr         3.0.0   2018-08-24 [1] CRAN (R 3.5.1)
 cli           1.0.1   2018-09-25 [1] CRAN (R 3.5.1)
 crayon        1.3.4   2017-09-16 [1] CRAN (R 3.5.1)
 curl          3.2     2018-03-28 [1] CRAN (R 3.5.1)
 desc          1.2.0   2018-05-01 [1] CRAN (R 3.5.1)
 devtools    * 2.0.1   2018-10-26 [1] CRAN (R 3.5.1)
 digest        0.6.18  2018-10-10 [1] CRAN (R 3.5.1)
 evaluate      0.12    2018-10-09 [1] CRAN (R 3.5.1)
 fs            1.2.6   2018-08-23 [1] CRAN (R 3.5.1)
 glue          1.3.0   2018-07-17 [1] CRAN (R 3.5.1)
 htmltools     0.3.6   2017-04-28 [1] CRAN (R 3.5.1)
 knitr         1.20    2018-02-20 [1] CRAN (R 3.5.1)
 magrittr      1.5     2014-11-22 [1] CRAN (R 3.5.1)
 memoise       1.1.0   2017-04-21 [1] CRAN (R 3.5.1)
 pkgbuild      1.0.2   2018-10-16 [1] CRAN (R 3.5.1)
 pkgload       1.0.2   2018-10-29 [1] CRAN (R 3.5.1)
 prettyunits   1.0.2   2015-07-13 [1] CRAN (R 3.5.1)
 processx      3.2.1   2018-12-05 [1] CRAN (R 3.5.1)
 ps            1.2.1   2018-11-06 [1] CRAN (R 3.5.1)
 R6            2.3.0   2018-10-04 [1] CRAN (R 3.5.1)
 Rcpp          1.0.0   2018-11-07 [1] CRAN (R 3.5.1)
 remotes       2.0.2   2018-10-30 [1] CRAN (R 3.5.1)
 rlang         0.3.0.1 2018-10-25 [1] CRAN (R 3.5.1)
 rmarkdown     1.10    2018-06-11 [1] CRAN (R 3.5.1)
 rprojroot     1.3-2   2018-01-03 [1] CRAN (R 3.5.1)
 rstudioapi    0.8     2018-10-02 [1] CRAN (R 3.5.1)
 sessioninfo   1.1.1   2018-11-05 [1] CRAN (R 3.5.1)
 usethis     * 1.4.0   2018-08-14 [1] CRAN (R 3.5.1)
 withr         2.1.2   2018-03-15 [1] CRAN (R 3.5.1)
 yaml          2.2.0   2018-07-25 [1] CRAN (R 3.5.1)
@jimhester

This comment has been minimized.

Copy link
Member

commented Dec 7, 2018

You seem to have a non-standard tar on your PATH. You could try setting Sys.setenv("TAR" = "internal") to use R's internal tar instead.

@asimumba

This comment has been minimized.

Copy link
Author

commented Dec 7, 2018

I tried to implement your suggestion, but to no avail. When I run Sys.getenv("TAR")
this is the result, [1] "".

@asimumba

This comment has been minimized.

Copy link
Author

commented Dec 7, 2018

After setting the Sys.setenv("TAR" = "internal") to a directory and then back to internal did the trick. Now I get internal as a result when I run Sys.getenv("TAR"). And the packages can now install.

@DataStrategist

This comment has been minimized.

Copy link

commented Feb 6, 2019

I've been having this issue again on the latest version of devtools and Rstudio... do you know why? Running Sys.setenv("TAR" = "internal") makes it work, but I have to reset that everytime I start Rstudio.

sessionInfo()
R version 3.5.2 (2018-12-20)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] Rcpp_1.0.0 rstudioapi_0.7 magrittr_1.5 usethis_1.4.0
[5] devtools_2.0.1 pkgload_1.0.2 debugme_1.1.0 R6_2.3.0
[9] rlang_0.3.1 tools_3.5.2 pkgbuild_1.0.2 sessioninfo_1.1.1
[13] cli_1.0.1 withr_2.1.2 remotes_2.0.2.9000 yaml_2.1.19
[17] assertthat_0.2.0 digest_0.6.18 rprojroot_1.3-2 crayon_1.3.4
[21] callr_2.0.3 fs_1.2.6 curl_3.2 testthat_2.0.1
[25] memoise_1.1.0 glue_1.3.0 compiler_3.5.2 desc_1.2.0
[29] backports_1.1.2 prettyunits_1.0.2

@asimumba

This comment has been minimized.

Copy link
Author

commented Feb 10, 2019

I've been having this issue again on the latest version of devtools and Rstudio... do you know why? Running Sys.setenv("TAR" = "internal") makes it work, but I have to reset that everytime I start Rstudio.

sessionInfo()
R version 3.5.2 (2018-12-20)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)

Matrix products: default

locale:
[1] LC_COLLATE=English_United States.1252 LC_CTYPE=English_United States.1252
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] Rcpp_1.0.0 rstudioapi_0.7 magrittr_1.5 usethis_1.4.0
[5] devtools_2.0.1 pkgload_1.0.2 debugme_1.1.0 R6_2.3.0
[9] rlang_0.3.1 tools_3.5.2 pkgbuild_1.0.2 sessioninfo_1.1.1
[13] cli_1.0.1 withr_2.1.2 remotes_2.0.2.9000 yaml_2.1.19
[17] assertthat_0.2.0 digest_0.6.18 rprojroot_1.3-2 crayon_1.3.4
[21] callr_2.0.3 fs_1.2.6 curl_3.2 testthat_2.0.1
[25] memoise_1.1.0 glue_1.3.0 compiler_3.5.2 desc_1.2.0
[29] backports_1.1.2 prettyunits_1.0.2

@DataStrategist All you need to do is place this Sys.setenv("TAR" = "internal") in your .Rprofile file so that every time R starts, the code is run.

@lock

This comment has been minimized.

Copy link

commented Aug 9, 2019

This old issue has been automatically locked. If you believe you have found a related problem, please file a new issue (with reprex) and link to this issue. https://reprex.tidyverse.org/

@lock lock bot locked and limited conversation to collaborators Aug 9, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
3 participants
You can’t perform that action at this time.