New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cli improvements #28

Merged
merged 5 commits into from Aug 20, 2015

Conversation

Projects
None yet
2 participants
@phadej
Collaborator

phadej commented Aug 20, 2015

Two first commits are trivial UI improvements.

Third probably needs an explanation. I was almost hit by the situation where I increased the upper bounds of my dependencies, but there aren't valid install-plan which would contain actually newest versions of packages. Therefore I could be given an expression that my package works against new version of some dependency, but actually it doesn't.

For example, if I add vector: >=0.9 && <0.11 direct dependency to reflex-0.3:

packdeps reflex.cabal
reflex-0.3: Can use newest versions of all dependencies

But if I run with --recursive flag, I get a lot of output with some interesting information:

packdeps --recursive reflex.cabal
reflex-0.3: Can use newest versions of all dependencies

Transitive dependencies:
reflex-0.3: Can use newest versions of all dependencies
base-4.8.1.0: Can use newest versions of all dependencies
ghc-prim-0.4.0.0: Can use newest versions of all dependencies
dependent-sum-0.2.1.0: Can use newest versions of all dependencies
dependent-map-0.1.1.3: Can use newest versions of all dependencies
containers-0.5.6.3: Can use newest versions of all dependencies
array-0.5.1.0: Can use newest versions of all dependencies
deepseq-1.4.1.1: Can use newest versions of all dependencies
semigroups-0.16.2.2: Can use newest versions of all dependencies
nats-1: Can use newest versions of all dependencies
mtl-2.2.1: Can use newest versions of all dependencies
transformers-0.4.3.0: Can use newest versions of all dependencies
these-0.4.2: Cannot accept the following packages
bifunctors 5
mtl 2.2.1
profunctors 5.1.1
semigroupoids 5.0.0.4
semigroups 0.16.2.2
transformers 0.4.3.0
vector 0.11.0.0
bifunctors-5: Can use newest versions of all dependencies
semigroupoids-5.0.0.4: Can use newest versions of all dependencies
base-orphans-0.4.4: Can use newest versions of all dependencies
transformers-compat-0.4.0.4: Can use newest versions of all dependencies
profunctors-5.1.1: Can use newest versions of all dependencies
comonad-4.2.7.2: Can use newest versions of all dependencies
tagged-0.8.1: Can use newest versions of all dependencies
distributive-0.4.4: Can use newest versions of all dependencies
vector-0.11.0.0: Can use newest versions of all dependencies
primitive-0.6: Can use newest versions of all dependencies
template-haskell-2.10.0.0: Can use newest versions of all dependencies
pretty-1.1.3.2: Can use newest versions of all dependencies
ref-tf-0.4: Can use newest versions of all dependencies
stm-2.4.4: Can use newest versions of all dependencies
exception-transformers-0.4.0.1: Can use newest versions of all dependencies
@snoyberg

This comment has been minimized.

Show comment
Hide comment
@snoyberg

snoyberg Aug 20, 2015

Owner

I just set up Travis on this project, and I'm testing your changes.

Owner

snoyberg commented Aug 20, 2015

I just set up Travis on this project, and I'm testing your changes.

@snoyberg snoyberg merged commit 6036a7e into snoyberg:cli Aug 20, 2015

snoyberg added a commit that referenced this pull request Aug 20, 2015

@snoyberg

This comment has been minimized.

Show comment
Hide comment
@snoyberg

snoyberg Aug 20, 2015

Owner

Merged and released as 0.4.1, thanks!

Owner

snoyberg commented Aug 20, 2015

Merged and released as 0.4.1, thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment