Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Module version mismatch. Expected 11, got 1. #264

Closed
aimnadze opened this Issue Mar 16, 2013 · 3 comments

Comments

Projects
None yet
3 participants

canvas module is not working on Node.js v.0.10.0 and crashes with "Module version mismatch. Expected 11, got 1." error.

Full error:

Error: Module version mismatch. Expected 11, got 1.
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/home/user/node_modules/canvas/lib/bindings.js:2:18)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
Contributor

TooTallNate commented Mar 17, 2013

Did you just update to v0.10.0? You probably need to recompile.

On Saturday, March 16, 2013, archilimnadze wrote:

canvas module is not working on Node.js v.0.10.0 and crashes with "Module
version mismatch. Expected 11, got 1." error.

Full error:

Error: Module version mismatch. Expected 11, got 1.
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/home/user/node_modules/canvas/lib/bindings.js:2:18)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)


Reply to this email directly or view it on GitHubhttps://github.com/LearnBoost/node-canvas/issues/264
.

Yeah, I forgot to recompile. It used to do it automatically after npm update but this time it didn't. Alright, for those who encounter this issue, go to canvas module directory and run make clean && make. Hope this saves somebody else's time.

@aimnadze aimnadze closed this Mar 17, 2013

@justinlatimer justinlatimer referenced this issue in justinlatimer/node-midi Apr 30, 2013

Closed

Error: Module version mismatch #18

I got the same problem running Meteor JS (uses node as backend). I'm not sure how to resolve the problem as the fix suggested here doesnt seem to work when using Meteor. I posted a question on SO since there isnt necessarily anything wrong with this module, but feel free to view the issue here http://stackoverflow.com/questions/17812716/version-mismatch-with-node-canvas-on-meteor-on-ubuntu .

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment