Skip to content
Which hosts support which PHP versions, and which is default
Branch: master
Clone or download
Pull request Compare This branch is 875 commits behind phpversions:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
_data
_includes
_layouts
_sass
css
.DS_Store
.gitignore
CNAME
CONTRIBUTING.md
Gemfile
Gemfile.lock
LICENSE
README.md
_config.yml
index.html
layout.css
linux-distros.html
paas-hosting.html
php-7.html
php-elephant.png
php-versions.png
shared-hosting.html

README.md

phpversions.info

As a PHP developer, we are often stuck with hosts that support insanely old versions of PHP. This means that some projects end up supporting those insanely old versions, and we all get stuck in this "Mexican Standoff" situation.

Some developers force their requirements to be much higher than these default versions in a bid to force the hosting companies to upgrade, but in reality we just end up with people reducing their software to try and get it onto old servers.

Let's keep close tabs on who is offering which versions of PHP, so we can help those less in the know find good companies to host their stuff on.

Website: phpversions.info

Contributing

See CONTRIBUTING.md.

TODO

  • Improve Design - this is a default Jekyll theme with two massive tables jammed in
  • Everything Else
You can’t perform that action at this time.