Skip to content
Permalink
Browse files

don't run tls_version test if TLSv1.1 is disabled

in /etc/ssl/openssl.cnf

as it happens to be on the buster builder
  • Loading branch information...
vuvova committed Jun 17, 2019
1 parent 4bfb19d commit e79b9005f19748964345e9f4b35a21529bf7f0e7
Showing with 8 additions and 0 deletions.
  1. +8 −0 mysql-test/suite.pm
@@ -74,6 +74,14 @@ sub skip_combinations {
$skip{'main/ssl_verify_ip.test'} = 'x509v3 support required'
unless $openssl_ver ge "1.0.2";

my $openssl_cnf='/etc/ssl/openssl.cnf';
if ($openssl_ver and open my $f, '<', $openssl_cnf) {
local $/;
$_=<$f>;
$skip{'main/tls_version.test'} = "TLSv1.1 disabled in $openssl_cnf"
if /^\s*MinProtocol\s*=\s*TLSv1.[2-9]/m;
}

%skip;
}

0 comments on commit e79b900

Please sign in to comment.
You can’t perform that action at this time.