Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

mill: removing MILL_VERSION variable #103736

Merged
merged 1 commit into from Nov 13, 2020
Merged

Conversation

@scalavision
Copy link
Contributor

@scalavision scalavision commented Nov 13, 2020

Motivation for this change

MILL_VERSION block the use of previous installed versions of mill. When removing this variable you can do:

MILL_VERSION=0.7.4 mill myproject.run

This has been tested manually by first installing 0.7.4, then 0.8.0, and running the command above.

Things done
  • [x ] Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • [x ] NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nixpkgs-review --run "nixpkgs-review wip"
  • [x ] Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • [x ] Ensured that relevant documentation is up to date
  • [x ] Fits CONTRIBUTING.md.
@veprbl
Copy link
Member

@veprbl veprbl commented Nov 13, 2020

Do you think you should use --set-default instead?

# --set-default VAR VAL : like --set, but only adds VAR if not already set in
# the environment

@scalavision
Copy link
Contributor Author

@scalavision scalavision commented Nov 13, 2020

thanks for the feedback, I didn't know about that setting :-)

There is a variable setting the default version, here in the mill launcher script:

https://github.com/lihaoyi/mill/blob/master/mill#L6

Isn't it cleaner to let the tool handle this, and let the user override it if necessary? I have no strong opinions about this though. Is there any advantage to let nix handle this? Will it be more reproducible / reliable?

The reason I removed it, was because a user wanted to be able to handle this himself. I agree with that, and adding this was probably a mistake on my part.

@veprbl
Copy link
Member

@veprbl veprbl commented Nov 13, 2020

I assumed that it was set in the wrapper for a reason. If you believe that we don’t need it anymore, then let’s remove it.

@m-a-t
Copy link

@m-a-t m-a-t commented Nov 13, 2020

The .mill-wrapped script will call the installed mill version (given by ${version}) by default, there is no replacement necessary for the deleted line.
Removing this line was requested by me, as it allows to use a different mill version as explained in http://www.lihaoyi.com/mill/#overriding-mill-versions

@scalavision You can even override mill version to be a version you never downloaded before, mill will automatically fetch it.

I tested it locally and I would be happy if this could be merged.

@veprbl
veprbl approved these changes Nov 13, 2020
Copy link
Member

@veprbl veprbl left a comment

LGTM

@veprbl veprbl merged commit c1dfbaa into NixOS:master Nov 13, 2020
19 checks passed
19 checks passed
tests
Details
action
Details
Evaluation Performance Report Evaluator Performance Report
Details
Wait for ofborg
Details
grahamcofborg-eval ^.^!
Details
grahamcofborg-eval-check-maintainers matching changed paths to changed attrs...
Details
grahamcofborg-eval-check-meta config.nix: checkMeta = true
Details
grahamcofborg-eval-darwin nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="e4bf365"; rev="e4bf36579df375a59118c202514ec02b017f132b"; } ./pkgs/t
Details
grahamcofborg-eval-lib-tests nix-build --arg pkgs import ./. {} ./lib/tests/release.nix
Details
grahamcofborg-eval-nixos nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="e4bf365"; rev="e4bf36579df375a59118c202514ec02b017f132b"; } ./nixos/
Details
grahamcofborg-eval-nixos-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="e4bf365"; rev="e4bf36579df375a59118c202514ec02b017f132b"; } ./nixos/
Details
grahamcofborg-eval-nixos-options nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="e4bf365"; rev="e4bf36579df375a59118c202514ec02b017f132b"; } ./nixos/
Details
grahamcofborg-eval-nixpkgs-manual nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="e4bf365"; rev="e4bf36579df375a59118c202514ec02b017f132b"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-tarball nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="e4bf365"; rev="e4bf36579df375a59118c202514ec02b017f132b"; } ./pkgs/t
Details
grahamcofborg-eval-nixpkgs-unstable-jobset nix-instantiate --arg nixpkgs { outPath=./.; revCount=999999; shortRev="e4bf365"; rev="e4bf36579df375a59118c202514ec02b017f132b"; } ./pkgs/t
Details
grahamcofborg-eval-package-list nix-env -qa --json --file .
Details
grahamcofborg-eval-package-list-no-aliases nix-env -qa --json --file . --arg config { allowAliases = false; }
Details
mill, mill.passthru.tests on aarch64-linux Success
Details
mill, mill.passthru.tests on x86_64-linux Success
Details
AnisimoffNikita added a commit to AnisimoffNikita/nixpkgs that referenced this pull request Nov 16, 2020
Fix4 (#1)
* vgrep: 2.5.0 -> 2.5.1

https://github.com/vrothberg/vgrep/releases/tag/v2.5.1

* ocamlPackages.digestif: 0.8.0 → 0.9.0

* tor-browser-bundle-bin: 10.0.2 -> 10.0.4

* webkitgtk: 2.30.1 → 2.30.2

https://webkitgtk.org/2020/10/23/webkitgtk2.30.2-released.html

* abcl: update source archive hash

Seems like the source archive for abcl 1.8.0 was replaced on 2020-10-30
on both common-lisp.net and abcl.org. Now using the new hash and
abcl.org for src.

* flyway: 7.1.1 -> 7.2.0

* turbo-geth: 2020.11.01 -> 2020.11.02

* geany: 1.37 -> 1.37.1

* vscodium: 1.51.0 -> 1.51.1

* vscode: 1.51.0 -> 1.51.1

* kitty: use installShellCompletion to install the shell completions

* kitty: 0.19.1 -> 0.19.2

https://github.com/kovidgoyal/kitty/releases/tag/v0.19.2

* librdf_raptor2: add patch for CVE-2017-18926

Fixes two heap overflows in the raptor2 rdf parsing library.

https://www.openwall.com/lists/oss-security/2017/06/07/1

* wofi: 1.2.1 -> 1.2.3

This also fixes a GDK Protocol error.

* gnomeExtensions.dash-to-panel: 39 -> 40

* oh-my-zsh: 2020-11-11 → 2020-11-12

* linux-rt_5_4: 5.4.74-rt41 -> 5.4.74-rt42

* gp2c: 0.0.11pl4 -> 0.0.12

* yabai: 3.3.0 -> 3.3.3

* haproxy: 2.2.4 -> 2.3.0

* pastebinit: fix basic usage

* k6: 0.28.0 -> 0.29.0

* linux: 5.10-rc2 -> 5.10-rc3

* icewm: 1.9.0 -> 1.9.2

* octant: init at 0.16.0 (NixOS#99546)

* jotta-cli: 0.7.33634 -> 0.7.35160

* zfsUnstable: 2.0.0-rc5 -> 2.0.0-rc6

* vimPlugins: update

* vimPlugins: resolve github repository redirects

* jetty: 9.4.31.v20200723 -> 9.4.34.v20201102

* igv: 2.8.11 -> 2.8.12

* libreoffice-qt: wrap application

Libreoffice-qt is not wrapped, thus does not launch. Notice that
wrapQtQAppsHook is used manually since all executables are shell
scripts which are not wrapped automatically.

* zathura: 0.4.5 -> 0.4.7

* zathura-pdf-mupdf: 0.3.5 -> 0.3.6, fix linking

* intel-media-sdk: 20.3.1 -> 20.4.1

* hackage2nix: disable broken builds to fix evaluation errors on Hydra

* hackage-packages.nix: automatic Haskell package set update

This update was generated by hackage2nix v2.15.5-27-g11a103b from Hackage revision
commercialhaskell/all-cabal-hashes@cb01aa6.

* haskell-time-compat: update to latest version so that binary-instances compiles

* haskell: add addTestToolDepends

* haskellPackages.optparse-applicative_0_16_0_0: Fix for compgen error

* haskellPackages.optparse-generic_1_4_4: Correct version of dependency

* haskellPackages.update-nix-fetchgit: Several fixes

Fix versions of dependencies

Generate shell completions

Wrap executable so that required executables are in PATH

Make sure necessary executables for tests are present during build

* update-nix-fetchgit: standalone small closure

* haskell: whitespace fixes

* haskellPackages.quickcheck-instances: no longer needs doJailbreak in ghc-8.8.

* haskellPackages.binary-instances: get building again

* haskell: Add documentationTarball to lib

* haskellPackages.pandoc: 2.11.1 -> 2.11.1.1

* haskellPackages.reflex-dom-core: Remove obsolete patches

* haskellPackages.matterhorn: Fix eval

* haskellPackages.haskell-language-server: Fix build

In preparation of the upcoming 0.6.0 release I wanted to fix hls.

It introduces two new plugin packages, which are not on hackage yet.

I remove apply-refact overrides, because current apply-refact versions
are compatible with all ghcs we support, according to their changelog.

I override more of the hls dependencies globally on the whole package
set, to avoid a lot of duplicate compilations. And because @peti changed
my mind about this being a good practice.

hls now uses a released version of ghcide

* haskell-language-server: 0.6.0rc -> 0.6.0

* haskellPackages: Fix eval errors

* haskellPackages: Cleanup unneeded builds

* haskell-language-server: Fix hydra config for deps

* haskellPackages.hls-hlint-plugin: Fix build on hydra

* lib: Add composeManyExtensions

* haskell: improve documentation on ghcWithHoogle and developPackage

* haskell: add withHoogle option to developPackage

* haskell: Add cabal2nixOptions to developPackage

Also neaten documentation slightly

* haskell-language-server: Fix build

Fixing a bound problem in ghcide and bumping ghc-exactprint

* haskellPackages.stack: Fix eval error

* haskell-pantry: update overrides for the new version

* qvge: init at 0.6.1

* julia: init at 1.5 (NixOS#101933)

* jmol: 14.31.14 -> 14.31.17

* mill: removing MILL_VERSION variable (NixOS#103736)

* last: 1133 -> 1145

* kpt: 0.36.1 -> 0.37.0

* python3Packages.dipy: 1.2.0 -> 1.3.0

* PULL_REQUEST_TEMPLATE.md: use rendered docs

* python3Packages.pytorch-metric-learning: 0.9.81 -> 0.9.94

* kubernetes-helm: 3.4.0 -> 3.4.1

* ubootRockPi4: init

This adds support for the Radxa Rock Pi 4 board which is based on
RK3399. The u-boot outputs from the introduced build are suitable to
build a generic image for the Rock Pi 4 by setting the following in a
custom build of $nixpkgs/nixos/modules/installer/cd-dvd/sd-image-aarch64.nix:

```
  sdImage.postBuildCommands = ''
    dd if=${pkgs.ubootRockPi4}/idbloader.img of=$img seek=64 conv=notrunc
    dd if=${pkgs.ubootROckPi4}/u-boot.itb of=$img seek=16384 conv=notrunc
  '';
```

* libthreadar: 1.3.0 -> 1.3.1

* antiprism: init at 0.26

* all-packages.nix: a small reorganization

Now the science/geometry expressions are in a same block of the all-packages
file.

* haproxy: add passthru.tests

* cloud-nuke: 0.1.18 -> 0.1.23

* lxd: 4.7 -> 4.8

https://discuss.linuxcontainers.org/t/lxd-4-8-has-been-released/9458

* liblinear: 2.41 -> 2.42

* mavproxy: 1.8.22 -> 1.8.23

* openocd: unstable-2020-09-02 -> unstable-2020-11-11

fix build failure with hidapi 0.10.0

* python37Packages.vowpalwabbit: 8.8.1 -> 8.9.0

* ocamlPackages.mirage-unix: use Dune 2

* ocamlPackages.mirage-runtime: use Dune 2

* ocamlPackages.mirage: init at 3.9.0

* arc_unpacker: init at unstable-2019-01-28

* python37Packages.sshtunnel: 0.2.1 -> 0.2.2

* python37Packages.gtts: 2.1.1 -> 2.1.2

* python37Packages.internetarchive: 1.9.5 -> 1.9.6

* python37Packages.sphinxcontrib-katex: 0.6.1 -> 0.7.1

* vte-ng: update patches to apply on vte 0.62

* musescore: fix unpack on darwin (NixOS#103651)

* utsushi: 3.59.2 -> unstable-2020-11-10

+ master should be roughly equivalent to 3.62.0
+ moving to the community repo because they are way better at fixing
  things, while upstream epson almost never merges fixes
+ great thanks to @mwilsoncoding for debugging the problem:
   + `autoconf-archive` was missing

* python37Packages.hyperopt: 0.1.2 -> 0.2.5

* nixos/telegraf: add support for native ping

* nixos/telegraf: add environmentFile option

* nixos/telegraf: switch to setting types

This allows to split up configuration into multiple modules

* nixos/telegraf: allow multiple env files

* telegraf: 1.15.2 -> 1.16.2

* fahviewer: 7.6.13 -> 7.6.21 (NixOS#103688)

* fahcontrol: 7.6.13 -> 7.6.21 (NixOS#103677)

* phonemizer: init at 2.2.1

* sacc: 1.01 → 1.02

* verilog: unstable-2020-10-24 -> 11.0

* vhd2vl: fix compatibility with verilog 11.0

* hsetroot: 1.0.2 -> 1.0.5

* python37Packages.casbin: 0.9.0 -> 0.10.0

* Revert "Merge NixOS#102138: thunderbird: set build timeout at eight hours"

This reverts commit ef543fb, reversing
changes made to 0d657b9.
See the parent commit.

* linux-rt_5_4: 5.4.74-rt42 -> 5.4.77-rt43

* pijul: 1.0.0-alpha -> 1.0.0-alpha.1

* simh: init at 3.11-1

* pythonPackages.notmuch2: init at 0.31

generates bindings via cffi

* doc/contributing: remove label instructions

ofborg largely does this now

* nvidia-x11: 455.28 -> 455.38 (NixOS#103830)

* cloudflared: 2020.11.3 -> 2020.11.5

* dasel: 1.2.0 -> 1.5.1

* doctl: 1.51.0 -> 1.52.0

* flyctl: 0.0.146 -> 0.0.149

* font-manager: 0.7.8 -> 0.7.9

* ft2-clone: 1.39 -> 1.40

* hugo: 0.78.1 -> 0.78.2

* iconpack-obsidian: 4.13 -> 4.14

* python37Packages.pyvips: 2.1.12 -> 2.1.13

* python37Packages.dropbox: 10.8.0 -> 10.10.0

* python37Packages.versioneer: 0.18 -> 0.19

* python2Packages.versioneer: disable python2

* python37Packages.cmd2: 1.3.11 -> 1.4.0

* python37Packages.azure-mgmt-policyinsights: 0.5.0 -> 0.6.0

* python37Packages.bpython: 0.20 -> 0.20.1

* python37Packages.distributed: 2.30.0 -> 2.30.1

* kube3d: 3.2.0 -> 3.2.1

* scheherazade-new: init at 3.000

* lazydocker: 0.9 -> 0.10

* matcha-gtk-theme: 2020-10-23 -> 2020-11-11-0

* html-proofer: 3.16.0 -> 3.17.0

* coq_8_12: 8.12.0 → 8.12.1

* musikcube: 0.94.0 -> 0.95.0

* mutt: 2.0.0 -> 2.0.1

Signed-off-by: Matthias Beyer <mail@beyermatthias.de>

* firefox: 82.0.2 -> 82.0.3

* firefox-esr: 78.4.0esr -> 78.4.1esr

* pmix: 3.2.0 -> 3.2.1

* chicken: support darwin platform (NixOS#103748)

Darwin was not included as a supported platform for chicken. However, it compiled and
worked fine after bypassing unsupported platforms.

We make two changes to chicken's derivation. First, we add darwin as a supported
platform.

Second, we set some envvars that force the build to use nix-supplied build
tools. Chicken's Makefile for macOS hardcodes paths to gcc and other build tools
(see
https://code.call-cc.org/cgi-bin/gitweb.cgi?p=chicken-core.git;a=blob;f=Makefile.macosx;h=5d4d9b0aa1bb4c95e1ba7a55f9586fa86ee5034f;hb=317468e4994e6245d787400359726a9fb97d5d60#l31). We
override these envvars to use the wrapped $CC and bintools provided by nix to make
the build pure.

* rtsp-simple-server: 0.12.0 -> 0.12.1

* cockroachdb: fix license information

* firecracker: 0.22.0 -> 0.23.0

Closes NixOS#102789.

Signed-off-by: Austin Seipp <aseipp@pobox.com>

Co-authored-by: zowoq <59103226+zowoq@users.noreply.github.com>
Co-authored-by: Vincent Laporte <Vincent.Laporte@gmail.com>
Co-authored-by: Dominik Xaver Hörl <hoe.dom@gmx.de>
Co-authored-by: Jan Tojnar <jtojnar@gmail.com>
Co-authored-by: sternenseemann <0rpkxez4ksa01gb3typccl0i@systemli.org>
Co-authored-by: R. RyanTM <ryantm-bot@ryantm.com>
Co-authored-by: David Terry <me@xwvvvvwx.com>
Co-authored-by: JesusMtnez <jesusmartinez93@gmail.com>
Co-authored-by: Martin Weinelt <mweinelt@users.noreply.github.com>
Co-authored-by: Luflosi <luflosi@luflosi.de>
Co-authored-by: Ryan Mulligan <ryan@ryantm.com>
Co-authored-by: Martin Weinelt <hexa@darmstadt.ccc.de>
Co-authored-by: Aamaruvi Yogamani <38222826+Technical27@users.noreply.github.com>
Co-authored-by: Sean Buckley <sean.bck@gmail.com>
Co-authored-by: Andreas Rammhold <andreas@rammhold.de>
Co-authored-by: Tim Steinbach <tim@nequissimus.com>
Co-authored-by: cmacrae <hi@cmacr.ae>
Co-authored-by: Arnout Engelen <arnout@bzzt.net>
Co-authored-by: Jack Kelly <dev@j-k.io>
Co-authored-by: Vladyslav M <dywedir@gra.red>
Co-authored-by: Jonathan Ringer <jonringer117@gmail.com>
Co-authored-by: Will Badart <will@willbadart.com>
Co-authored-by: Jonas Meurer <jmpunkt@outlook.com>
Co-authored-by: Frederik Rietdijk <fridh@fridh.nl>
Co-authored-by: Peter Simons <simons@cryp.to>
Co-authored-by: Joe Hermaszewski <git@monoid.al>
Co-authored-by: (cdep)illabout <cdep.illabout@gmail.com>
Co-authored-by: Malte Brandy <malte.brandy@maralorn.de>
Co-authored-by: Nikolay Korotkiy <sikmir@gmail.com>
Co-authored-by: Christoph Stich <cstich@users.noreply.github.com>
Co-authored-by: Anderson Torres <torres.anderson.85@protonmail.com>
Co-authored-by: scalavision <scalavision@gmail.com>
Co-authored-by: Ben Darwin <bcdarwin@gmail.com>
Co-authored-by: Mario Rodas <marsam@users.noreply.github.com>
Co-authored-by: Samuel Dionne-Riel <samuel@dionne-riel.com>
Co-authored-by: WORLDofPEACE <worldofpeace@protonmail.ch>
Co-authored-by: Pavol Rusnak <pavol@rusnak.io>
Co-authored-by: Doron Behar <doron.behar@gmail.com>
Co-authored-by: Timo Kaufmann <timokau@zoho.com>
Co-authored-by: midchildan <git@midchildan.org>
Co-authored-by: Daniël de Kok <me@danieldk.eu>
Co-authored-by: Jamie McClymont <jamie@kwiius.com>
Co-authored-by: Dmitry Kalinkin <dmitry.kalinkin@gmail.com>
Co-authored-by: Andrew Childs <lorne@cons.org.nz>
Co-authored-by: wucke13 <wucke13@gmail.com>
Co-authored-by: Michael Raskin <7c6f434c@mail.ru>
Co-authored-by: Jörg Thalheim <joerg@thalheim.io>
Co-authored-by: Jörg Thalheim <Mic92@users.noreply.github.com>
Co-authored-by: Ninjatrappeur <NinjaTrappeur@users.noreply.github.com>
Co-authored-by: John Ericson <git@JohnEricson.me>
Co-authored-by: Marek Mahut <marek.mahut@gmail.com>
Co-authored-by: Lassulus <github@lassul.us>
Co-authored-by: SCOTT-HAMILTON <sgn.hamilton+github@protonmail.com>
Co-authored-by: Vladimír Čunát <v@cunat.cz>
Co-authored-by: Matthieu Coudron <mcoudron@hotmail.com>
Co-authored-by: Daniel Fox Franke <dfoxfranke@gmail.com>
Co-authored-by: José Romildo Malaquias <malaquias@gmail.com>
Co-authored-by: StigP <stig@stig.io>
Co-authored-by: Michael Weiss <dev.primeos@gmail.com>
Co-authored-by: Matthias Beyer <mail@beyermatthias.de>
Co-authored-by: Aaron Andersen <aaron@fosslib.net>
Co-authored-by: Mark Hudnall <me@markhudnall.com>
Co-authored-by: markuskowa <markus.kowalewski@gmail.com>
Co-authored-by: Silvan Mosberger <contact@infinisil.com>
Co-authored-by: Antonio Nuno Monteiro <anmonteiro@gmail.com>
Co-authored-by: ajs124 <ajs124@users.noreply.github.com>
Co-authored-by: Austin Seipp <aseipp@pobox.com>
github-actions bot added a commit to andir/nixos.cloud that referenced this pull request Nov 20, 2020
## Changelog for nixpkgs:
Commits: [NixOS/nixpkgs@2deeb58...069f183f](NixOS/nixpkgs@2deeb58...069f183)

* [`e86b0509`](NixOS/nixpkgs@e86b050) go-ethereum: 1.9.23 -> 1.9.24
* [`4bdd40df`](NixOS/nixpkgs@4bdd40d) awsweeper: 0.7.0 -> 0.10.2
* [`dce3b451`](NixOS/nixpkgs@dce3b45) wal-g: 0.2.17 -> 0.2.18
* [`6b4ef62e`](NixOS/nixpkgs@6b4ef62) eksctl: 0.30.0 -> 0.31.0
* [`e4ac103c`](NixOS/nixpkgs@e4ac103) dar: 2.6.12 -> 2.6.13
* [`d2a55a7f`](NixOS/nixpkgs@d2a55a7) gnomeExtensions.gsconnect: 43 -> 44
* [`897ce96b`](NixOS/nixpkgs@897ce96) kustomize: 3.8.1 -> 3.8.7
* [`be0555b8`](NixOS/nixpkgs@be0555b) nixos/doc: Add note about /usr/sbin and /sbin
* [`e5d4ce72`](NixOS/nixpkgs@e5d4ce7) discord-canary: 0.0.114 -> 0.0.115
* [`2d915726`](NixOS/nixpkgs@2d91572) dump1090: 3.8.1 -> 4.0
* [`10fc2a3a`](NixOS/nixpkgs@10fc2a3) ocamlPackages.mstruct: remove at 1.4.0
* [`568d95e1`](NixOS/nixpkgs@568d95e) forkstat: 0.02.15 -> 0.02.16
* [`26f1edbb`](NixOS/nixpkgs@26f1edb) fortune: 3.2.0 -> 3.4.1
* [`cf30b008`](NixOS/nixpkgs@cf30b00) vgrep: 2.5.0 -> 2.5.1
* [`1ce26aac`](NixOS/nixpkgs@1ce26aa) ocamlPackages.digestif: 0.8.0 → 0.9.0
* [`9e8f4ff7`](NixOS/nixpkgs@9e8f4ff) tor-browser-bundle-bin: 10.0.2 -> 10.0.4
* [`e9267c88`](NixOS/nixpkgs@e9267c8) abcl: update source archive hash
* [`c68e9c54`](NixOS/nixpkgs@c68e9c5) flyway: 7.1.1 -> 7.2.0
* [`08ca1ee8`](NixOS/nixpkgs@08ca1ee) turbo-geth: 2020.11.01 -> 2020.11.02
* [`325d9778`](NixOS/nixpkgs@325d977) geany: 1.37 -> 1.37.1
* [`bca0c78d`](NixOS/nixpkgs@bca0c78) vscodium: 1.51.0 -> 1.51.1
* [`aa9a29c4`](NixOS/nixpkgs@aa9a29c) vscode: 1.51.0 -> 1.51.1
* [`09eabf6a`](NixOS/nixpkgs@09eabf6) kitty: use installShellCompletion to install the shell completions
* [`182b7cfb`](NixOS/nixpkgs@182b7cf) kitty: 0.19.1 -> 0.19.2
* [`22140b27`](NixOS/nixpkgs@22140b2) librdf_raptor2: add patch for CVE-2017-18926
* [`8775e397`](NixOS/nixpkgs@8775e39) wofi: 1.2.1 -> 1.2.3
* [`67394b5e`](NixOS/nixpkgs@67394b5) gnomeExtensions.dash-to-panel: 39 -> 40
* [`7a36556e`](NixOS/nixpkgs@7a36556) oh-my-zsh: 2020-11-11 → 2020-11-12
* [`eb64d151`](NixOS/nixpkgs@eb64d15) linux-rt_5_4: 5.4.74-rt41 -> 5.4.74-rt42
* [`3457f858`](NixOS/nixpkgs@3457f85) gp2c: 0.0.11pl4 -> 0.0.12
* [`7fb1069a`](NixOS/nixpkgs@7fb1069) yabai: 3.3.0 -> 3.3.3
* [`4fb71e29`](NixOS/nixpkgs@4fb71e2) haproxy: 2.2.4 -> 2.3.0
* [`9ebf4409`](NixOS/nixpkgs@9ebf440) pastebinit: fix basic usage
* [`65ac9e26`](NixOS/nixpkgs@65ac9e2) k6: 0.28.0 -> 0.29.0
* [`c9845cda`](NixOS/nixpkgs@c9845cd) linux: 5.10-rc2 -> 5.10-rc3
* [`04d5b2f8`](NixOS/nixpkgs@04d5b2f) icewm: 1.9.0 -> 1.9.2
* [`d01e5dc6`](NixOS/nixpkgs@d01e5dc) octant: init at 0.16.0 (NixOS/nixpkgs#99546)
* [`0428243f`](NixOS/nixpkgs@0428243) jotta-cli: 0.7.33634 -> 0.7.35160
* [`f525d54c`](NixOS/nixpkgs@f525d54) zfsUnstable: 2.0.0-rc5 -> 2.0.0-rc6
* [`5eeff0d2`](NixOS/nixpkgs@5eeff0d) vimPlugins: update
* [`f53113e5`](NixOS/nixpkgs@f53113e) vimPlugins: resolve github repository redirects
* [`d4da5f9d`](NixOS/nixpkgs@d4da5f9) jetty: 9.4.31.v20200723 -> 9.4.34.v20201102
* [`82d11130`](NixOS/nixpkgs@82d1113) igv: 2.8.11 -> 2.8.12
* [`ea12d880`](NixOS/nixpkgs@ea12d88) libreoffice-qt: wrap application
* [`c62f9475`](NixOS/nixpkgs@c62f947) zathura: 0.4.5 -> 0.4.7
* [`6e9b71f0`](NixOS/nixpkgs@6e9b71f) zathura-pdf-mupdf: 0.3.5 -> 0.3.6, fix linking
* [`73ca6f3e`](NixOS/nixpkgs@73ca6f3) intel-media-sdk: 20.3.1 -> 20.4.1
* [`3bf200de`](NixOS/nixpkgs@3bf200d) hackage2nix: disable broken builds to fix evaluation errors on Hydra
* [`1f021c26`](NixOS/nixpkgs@1f021c2) hackage-packages.nix: automatic Haskell package set update
* [`9028b8f3`](NixOS/nixpkgs@9028b8f) haskell-time-compat: update to latest version so that binary-instances compiles
* [`a3d8c128`](NixOS/nixpkgs@a3d8c12) haskell: add addTestToolDepends
* [`4f0af81b`](NixOS/nixpkgs@4f0af81) haskellPackages.optparse-applicative_0_16_0_0: Fix for compgen error
* [`738d4fef`](NixOS/nixpkgs@738d4fe) haskellPackages.optparse-generic_1_4_4: Correct version of dependency
* [`b95bea03`](NixOS/nixpkgs@b95bea0) haskellPackages.update-nix-fetchgit: Several fixes
* [`e5570d9f`](NixOS/nixpkgs@e5570d9) update-nix-fetchgit: standalone small closure
* [`407bb3ba`](NixOS/nixpkgs@407bb3b) haskell: whitespace fixes
* [`01a403fb`](NixOS/nixpkgs@01a403f) haskellPackages.quickcheck-instances: no longer needs doJailbreak in ghc-8.8.
* [`bbb5016d`](NixOS/nixpkgs@bbb5016) haskellPackages.binary-instances: get building again
* [`7673eda1`](NixOS/nixpkgs@7673eda) haskell: Add documentationTarball to lib
* [`bc1ffa45`](NixOS/nixpkgs@bc1ffa4) haskellPackages.pandoc: 2.11.1 -> 2.11.1.1
* [`798e23c7`](NixOS/nixpkgs@798e23c) haskellPackages.reflex-dom-core: Remove obsolete patches
* [`becd5f5b`](NixOS/nixpkgs@becd5f5) haskellPackages.matterhorn: Fix eval
* [`bf29c147`](NixOS/nixpkgs@bf29c14) haskellPackages.haskell-language-server: Fix build
* [`13f96d5d`](NixOS/nixpkgs@13f96d5) haskell-language-server: 0.6.0rc -> 0.6.0
* [`425d22e6`](NixOS/nixpkgs@425d22e) haskellPackages: Fix eval errors
* [`ed26917b`](NixOS/nixpkgs@ed26917) haskellPackages: Cleanup unneeded builds
* [`3cbe2b5b`](NixOS/nixpkgs@3cbe2b5) haskell-language-server: Fix hydra config for deps
* [`bacdeffd`](NixOS/nixpkgs@bacdeff) haskellPackages.hls-hlint-plugin: Fix build on hydra
* [`c3b35f21`](NixOS/nixpkgs@c3b35f2) lib: Add composeManyExtensions
* [`07e697d2`](NixOS/nixpkgs@07e697d) haskell: improve documentation on ghcWithHoogle and developPackage
* [`a32c2310`](NixOS/nixpkgs@a32c231) haskell: add withHoogle option to developPackage
* [`49e9758e`](NixOS/nixpkgs@49e9758) haskell: Add cabal2nixOptions to developPackage
* [`0f1709ad`](NixOS/nixpkgs@0f1709a) haskell-language-server: Fix build
* [`bf2b91cf`](NixOS/nixpkgs@bf2b91c) haskellPackages.stack: Fix eval error
* [`9ea5a41d`](NixOS/nixpkgs@9ea5a41) haskell-pantry: update overrides for the new version
* [`986d973f`](NixOS/nixpkgs@986d973) qvge: init at 0.6.1
* [`5a5cb550`](NixOS/nixpkgs@5a5cb55) julia: init at 1.5 (NixOS/nixpkgs#101933)
* [`dd8591d7`](NixOS/nixpkgs@dd8591d) jmol: 14.31.14 -> 14.31.17
* [`c1dfbaa8`](NixOS/nixpkgs@c1dfbaa) mill: removing MILL_VERSION variable (NixOS/nixpkgs#103736)
* [`a698dfa0`](NixOS/nixpkgs@a698dfa) last: 1133 -> 1145
* [`d4a4860e`](NixOS/nixpkgs@d4a4860) kpt: 0.36.1 -> 0.37.0
* [`001a975b`](NixOS/nixpkgs@001a975) python3Packages.dipy: 1.2.0 -> 1.3.0
* [`698c4713`](NixOS/nixpkgs@698c471) PULL_REQUEST_TEMPLATE.md: use rendered docs
* [`c881ca60`](NixOS/nixpkgs@c881ca6) python3Packages.pytorch-metric-learning: 0.9.81 -> 0.9.94
* [`d1a603b5`](NixOS/nixpkgs@d1a603b) kubernetes-helm: 3.4.0 -> 3.4.1
* [`7a5047be`](NixOS/nixpkgs@7a5047b) ubootRockPi4: init
* [`2f4bd223`](NixOS/nixpkgs@2f4bd22) libthreadar: 1.3.0 -> 1.3.1
* [`7225ae36`](NixOS/nixpkgs@7225ae3) haproxy: add passthru.tests
* [`ac676f13`](NixOS/nixpkgs@ac676f1) cloud-nuke: 0.1.18 -> 0.1.23
* [`a398eb85`](NixOS/nixpkgs@a398eb8) lxd: 4.7 -> 4.8
* [`06d328c3`](NixOS/nixpkgs@06d328c) liblinear: 2.41 -> 2.42
* [`df7db2b3`](NixOS/nixpkgs@df7db2b) mavproxy: 1.8.22 -> 1.8.23
* [`5e76b77f`](NixOS/nixpkgs@5e76b77) openocd: unstable-2020-09-02 -> unstable-2020-11-11
* [`1f9b3967`](NixOS/nixpkgs@1f9b396) python37Packages.vowpalwabbit: 8.8.1 -> 8.9.0
* [`0e6f0204`](NixOS/nixpkgs@0e6f020) ocamlPackages.mirage-unix: use Dune 2
* [`7fb0a750`](NixOS/nixpkgs@7fb0a75) ocamlPackages.mirage-runtime: use Dune 2
* [`9ca92f0a`](NixOS/nixpkgs@9ca92f0) ocamlPackages.mirage: init at 3.9.0
* [`302cbf17`](NixOS/nixpkgs@302cbf1) arc_unpacker: init at unstable-2019-01-28
* [`91a41b05`](NixOS/nixpkgs@91a41b0) python37Packages.sshtunnel: 0.2.1 -> 0.2.2
* [`3098d504`](NixOS/nixpkgs@3098d50) python37Packages.gtts: 2.1.1 -> 2.1.2
* [`c07706ef`](NixOS/nixpkgs@c07706e) python37Packages.internetarchive: 1.9.5 -> 1.9.6
* [`e4b6e569`](NixOS/nixpkgs@e4b6e56) python37Packages.sphinxcontrib-katex: 0.6.1 -> 0.7.1
* [`2ac6d50e`](NixOS/nixpkgs@2ac6d50) vte-ng: update patches to apply on vte 0.62
* [`99d3a69d`](NixOS/nixpkgs@99d3a69) musescore: fix unpack on darwin (NixOS/nixpkgs#103651)
* [`f89b4dc4`](NixOS/nixpkgs@f89b4dc) utsushi: 3.59.2 -> unstable-2020-11-10
* [`5d08fb8f`](NixOS/nixpkgs@5d08fb8) python37Packages.hyperopt: 0.1.2 -> 0.2.5
* [`9750813b`](NixOS/nixpkgs@9750813) nixos/telegraf: add support for native ping
* [`157d7354`](NixOS/nixpkgs@157d735) nixos/telegraf: add environmentFile option
* [`8edc4619`](NixOS/nixpkgs@8edc461) nixos/telegraf: switch to setting types
* [`7534d926`](NixOS/nixpkgs@7534d92) nixos/telegraf: allow multiple env files
* [`b696d796`](NixOS/nixpkgs@b696d79) telegraf: 1.15.2 -> 1.16.2
* [`68f44d99`](NixOS/nixpkgs@68f44d9) fahviewer: 7.6.13 -> 7.6.21 (NixOS/nixpkgs#103688)
* [`e3cf6e12`](NixOS/nixpkgs@e3cf6e1) fahcontrol: 7.6.13 -> 7.6.21 (NixOS/nixpkgs#103677)
* [`8578fb31`](NixOS/nixpkgs@8578fb3) phonemizer: init at 2.2.1
* [`00251c06`](NixOS/nixpkgs@00251c0) sacc: 1.01 → 1.02
* [`65bd03c8`](NixOS/nixpkgs@65bd03c) hsetroot: 1.0.2 -> 1.0.5
* [`fb397ae7`](NixOS/nixpkgs@fb397ae) python37Packages.casbin: 0.9.0 -> 0.10.0
* [`6769ad9f`](NixOS/nixpkgs@6769ad9) Revert "Merge NixOS/nixpkgs#102138: thunderbird: set build timeout at eight hours"
* [`0c0b533f`](NixOS/nixpkgs@0c0b533) linux-rt_5_4: 5.4.74-rt42 -> 5.4.77-rt43
* [`a429039a`](NixOS/nixpkgs@a429039) pijul: 1.0.0-alpha -> 1.0.0-alpha.1
* [`c7463be4`](NixOS/nixpkgs@c7463be) simh: init at 3.11-1
* [`6bf02266`](NixOS/nixpkgs@6bf0226) pythonPackages.notmuch2: init at 0.31
* [`0e89c426`](NixOS/nixpkgs@0e89c42) doc/contributing: remove label instructions
* [`2fa89880`](NixOS/nixpkgs@2fa8988) nvidia-x11: 455.28 -> 455.38 (NixOS/nixpkgs#103830)
* [`e542a2d2`](NixOS/nixpkgs@e542a2d) flyctl: 0.0.146 -> 0.0.149
* [`16874792`](NixOS/nixpkgs@1687479) ft2-clone: 1.39 -> 1.40
* [`72c798dd`](NixOS/nixpkgs@72c798d) hugo: 0.78.1 -> 0.78.2
* [`efe6b12a`](NixOS/nixpkgs@efe6b12) python37Packages.pyvips: 2.1.12 -> 2.1.13
* [`e038ae53`](NixOS/nixpkgs@e038ae5) python37Packages.dropbox: 10.8.0 -> 10.10.0
* [`05d4955a`](NixOS/nixpkgs@05d4955) python37Packages.versioneer: 0.18 -> 0.19
* [`a0ea37d2`](NixOS/nixpkgs@a0ea37d) python2Packages.versioneer: disable python2
* [`d2928191`](NixOS/nixpkgs@d292819) python37Packages.cmd2: 1.3.11 -> 1.4.0
* [`7d129704`](NixOS/nixpkgs@7d12970) python37Packages.azure-mgmt-policyinsights: 0.5.0 -> 0.6.0
* [`0e77efac`](NixOS/nixpkgs@0e77efa) python37Packages.bpython: 0.20 -> 0.20.1
* [`fa962c1d`](NixOS/nixpkgs@fa962c1) python37Packages.distributed: 2.30.0 -> 2.30.1
* [`b94a2943`](NixOS/nixpkgs@b94a294) scheherazade-new: init at 3.000
* [`1ff209c9`](NixOS/nixpkgs@1ff209c) lazydocker: 0.9 -> 0.10
* [`dbf134a7`](NixOS/nixpkgs@dbf134a) html-proofer: 3.16.0 -> 3.17.0
* [`2806eb27`](NixOS/nixpkgs@2806eb2) coq_8_12: 8.12.0 → 8.12.1
* [`3e6fdd84`](NixOS/nixpkgs@3e6fdd8) musikcube: 0.94.0 -> 0.95.0
* [`5848e984`](NixOS/nixpkgs@5848e98) mutt: 2.0.0 -> 2.0.1
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants