Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix haskell-lsp and lsp-test references #76087

Closed
wants to merge 20 commits into from

Conversation

@mgttlinger
Copy link
Contributor

@mgttlinger mgttlinger commented Dec 20, 2019

Motivation for this change

Tree did not evaluate otherwise due to broken references

Things done

Tested that tree evaluates

  • Tested using sandboxing (nix.useSandbox on NixOS, or option sandbox in nix.conf on non-NixOS linux)
  • Built on platform(s)
    • NixOS
    • macOS
    • other Linux distributions
  • Tested via one or more NixOS test(s) if existing and applicable for the change (look inside nixos/tests)
  • Tested compilation of all pkgs that depend on this change using nix-shell -p nix-review --run "nix-review wip"
  • Tested execution of all binary files (usually in ./result/bin/)
  • Determined the impact on package closure size (by running nix path-info -S before and after)
  • Ensured that relevant documentation is up to date
  • Fits CONTRIBUTING.md.
cdepillabout and others added 14 commits Dec 16, 2019
This update was generated by hackage2nix v2.15.0-9-g650d530 from Hackage revision
commercialhaskell/all-cabal-hashes@dc5b0e7.
This update was generated by hackage2nix v2.15.0-9-g650d530 from Hackage revision
commercialhaskell/all-cabal-hashes@b2a082b.
haskellPackages.glirc is a "Console IRC Client." I've added a doJailbreak
to fix the build (thanks @Infinisil) and added it to top-level/all-packages.nix
so people can find and install it as they would normally.

Would be nice to make this build in a way that allows the OTR extension to be
enabled. One thing at a time....
glirc: init at 2.33.1
This update was generated by hackage2nix v2.15.0-11-g2fb6f7e from Hackage revision
commercialhaskell/all-cabal-hashes@4fa8739.
haskellPackages.snap-server: patch for network >= 3.0
spago: add update script for automatically updating to new versions
This PR fixes dhall_1_28_0, dhall-bash_1_0_25, and dhall-json_1_6_0 so
they build.

They all require a newer version of prettyprinter than we get from the
LTS package set.

This is from #75931 by @ijaketak.

Co-authored-by: Keito Kajitani <ijaketak@gmail.com>
haskellPackages.dhall_1_28_0: fix overrides so it builds
This adds dhall-1.27.0 to extra-packages in
configuration-hackage2nix.yaml.

dhall-1.27.0 is used by spago, so this package needs to be available.
haskellPackages.dhall_1_27_0: generate this package
@mgttlinger
Copy link
Contributor Author

@mgttlinger mgttlinger commented Dec 20, 2019

@mgttlinger
Copy link
Contributor Author

@mgttlinger mgttlinger commented Dec 20, 2019

I'm not sure what to do here because the source no longer contains any reference to the old version but ofborg still picks it up from somewhere...

@cdepillabout
Copy link
Member

@cdepillabout cdepillabout commented Dec 20, 2019

Unfortunately it looks like ghcide depends on haskell-lsp ==0.18.*, haskell-lsp-types ==0.18.*, so updating them here doesn't work.

@mgttlinger Could you make haskell-lsp_0_18_0_0 and haskell-lsp_types_0_18_0_0 available? You can do this by sending a PR adding the required lines to extra-packages in configuration-hackage2nix.yaml and waiting for hackage-packages.nix to be regenerated.

@mgttlinger mgttlinger mentioned this pull request Dec 20, 2019
1 of 10 tasks complete
@mgttlinger
Copy link
Contributor Author

@mgttlinger mgttlinger commented Dec 20, 2019

@cdepillabout Can you recommend documentation to read to get an idea of what is going on with this yaml file so that I have more of an idea of what to do next time?

haskell-lsp: Added 0.18.* to extra-packages for ghcide
@cdepillabout
Copy link
Member

@cdepillabout cdepillabout commented Dec 20, 2019

@mgttlinger Sorry, I don't actually have a good recommendation for documentation. I've pieced it together by being active here in nixpkgs. Although it is something I would like to help write at some point.


If you watch the weekly twitch streams from peti, you can get an idea of everything that goes into keeping haskell packages updated:

https://www.twitch.tv/peti343

donatello and others added 2 commits Dec 20, 2019
Builds fine now.
haskellPackages.postgresql-simple-url: mark unbroken
@mgttlinger
Copy link
Contributor Author

@mgttlinger mgttlinger commented Dec 20, 2019

@cdepillabout Actually would it be a possibility to update ghcide because the current version is fine with 0.19: https://github.com/digital-asset/ghcide/blob/v0.0.5/ghcide.cabal#L44-L45

mgttlinger added 2 commits Dec 20, 2019
@mgttlinger mgttlinger force-pushed the mgttlinger:haskell-updates branch from f6ad796 to 37f8757 Dec 20, 2019
@mgttlinger
Copy link
Contributor Author

@mgttlinger mgttlinger commented Dec 20, 2019

Oh never mind the stack.yaml of ghcide disallows 0.19

@peti peti force-pushed the NixOS:haskell-updates branch 5 times, most recently from aa46cdd to fdd64fb Dec 20, 2019
@mgttlinger
Copy link
Contributor Author

@mgttlinger mgttlinger commented Jan 3, 2020

I guess this is obsolete by now

@mgttlinger mgttlinger closed this Jan 3, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

6 participants
You can’t perform that action at this time.