Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

NT has trouble with magic #2644

Closed
p5pRT opened this issue Sep 20, 2000 · 3 comments
Closed

NT has trouble with magic #2644

p5pRT opened this issue Sep 20, 2000 · 3 comments

Comments

@p5pRT
Copy link

@p5pRT p5pRT commented Sep 20, 2000

Migrated from rt.perl.org#4336 (status was 'resolved')

Searchable as RT4336$

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Sep 20, 2000

From Carl_B_Howes@res.raytheon.com

Downloaded stable.zip from
http​://www.perl.com/pub/language/info/software.html#stable today and built it
with the following results.

From "nmake test"​:

Failed Test Status Wstat Total Fail Failed List of failed


op/magic.t 35 2 5.71% 23-24
22 tests and 129 subtests skipped.
Failed 1/236 test scripts, 99.58% okay. 2/11176 subtests failed, 99.98% okay.
NMAKE : fatal error U1077​: '..\perl.exe' : return code '0xff'
Stop.

From "perl -V"​:

Missing $ on loop variable at ..\lib/Exporter.pm line 40.
BEGIN failed--compilation aborted at ..\lib/Config.pm line 2.
BEGIN failed--compilation aborted.

From "perl -v"​:

This is perl, version 5.003_07

Copyright 1987-1996, Larry Wall

  + suidperl security patch
  Win32 port Copyright (c) 1995-1996 Microsoft Corporation.
  All rights reserved.
  Developed by ActiveWare Internet Corp., http​://www.ActiveWare.com

Perl for Win32 Build 307 - Built 10​:11​:54 Jul 15 1997

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5.0 source kit.

Is this a known set of bugs?

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Sep 21, 2000

From [Unknown Contact. See original ticket]

An update - rebooting has helped somewhat. "perl -V" now returns​:

Summary of my perl5 (revision 5 version 6 subversion 0) configuration​:
  Platform​:
  osname=MSWin32, osvers=4.0, archname=MSWin32-x86
  uname=''
  config_args='undef'
  hint=recommended, useposix=true, d_sigaction=undef
  usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=unde
f
  useperlio=undef d_sfio=undef uselargefiles=undef
  use64bitint=undef use64bitall=undef uselongdouble=undef usesocks=undef
  Compiler​:
  cc='cl', optimize='-O1 -MD -DNDEBUG', gccversion=
  cppflags='-DWIN32'
  ccflags ='-O1 -MD -DNDEBUG -DWIN32 -D_CONSOLE -DNO_STRICT -DPERL_MSVCRT_RE
ADFIX'
  stdchar='char', d_stdstdio=define, usevfork=false
  intsize=4, longsize=4, ptrsize=4, doublesize=8
  d_longlong=undef, longlongsize=8, d_longdbl=define, longdblsize=10
  ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize
=4
  alignbytes=8, usemymalloc=n, prototype=define
  Linker and Libraries​:
  ld='link', ldflags ='-nologo -nodefaultlib -release -libpath​:"j​:\perl\5.6.0
\lib\MSWin32-x86\CORE" -machine​:x86'
  libpth=E​:\MICROS~1\VC98\lib
  libs= oldnames.lib kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32
.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib netapi32.lib uuid.lib wsoc
k32.lib mpr.lib winmm.lib version.lib odbc32.lib odbccp32.lib msvcrt.lib
  libc=msvcrt.lib, so=dll, useshrplib=yes, libperl=perl56.lib
  Dynamic Linking​:
  dlsrc=dl_win32.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' '
  cccdlflags=' ', lddlflags='-dll -nologo -nodefaultlib -release -libpath​:"j​:
\perl\5.6.0\lib\MSWin32-x86\CORE" -machine​:x86'

Characteristics of this binary (from libperl)​:
  Compile-time options​:
  Built under MSWin32
  Compiled at Sep 20 2000 15​:21​:05
  @​INC​:
  j​:/perl/5.6.0/lib/MSWin32-x86
  j​:/perl/5.6.0/lib
  j​:/perl/site/5.6.0/lib/MSWin32-x86
  j​:/perl/site/5.6.0/lib
  .

Now to try the port that started me down this road...

@p5pRT
Copy link
Author

@p5pRT p5pRT commented Sep 22, 2000

From [Unknown Contact. See original ticket]

Downloaded stable.zip from
http​://www.perl.com/pub/language/info/software.html#stable
today and built it
with the following results.

From "nmake test"​:

Failed Test Status Wstat Total Fail Failed List of failed
--------------------------------------------------------------
----------------
op/magic.t 35 2 5.71% 23-24
22 tests and 129 subtests skipped.
Failed 1/236 test scripts, 99.58% okay. 2/11176 subtests
failed, 99.98% okay.
NMAKE : fatal error U1077​: '..\perl.exe' : return code '0xff'
Stop.

You did not specified exact information about your build environment
settings. Most probably the problem is in your compiler setup (e.g. you
linked executable against wrong library). Consult Readme.WIN32 file from
perl distribution to make/

You use some of MSVC++, so you need to run vcvars32.bat (or better set-up
appropriate env vars), and change Makefile.

<!ENTITY Vadim REALLIFE "Vadim V.Konovalov, St.Petersburg, Russia">
&Vadim;

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant