Nov 16, 2018
Merge remote-tracking branch 'origin/development'
Sep 24, 2018
Fix CommandAlreadyAvailable error for PackageManagement module. (#333)
This is happening as Get-Command returns the local commands from PSModule.psm1 for the Find-Package, Install-Package and Uninstall-Package provider functions. Added check to ignore the commands from PSModule.psm1.

Resolves #329
Sep 13, 2018
Change default scope in Install-Module and Install-Script (#315)
Implements below functionality
PS 3.0/4.0/5.0/5.1 : Default scope is based on the current user privileges.
PS Core 6+: Default scope is always CurrentUser (it includes Windows as well).
Users can still specify the -Scope parameter if they would like to install to the required scope path.
Aug 17, 2018
Resolve Install/Save-Module error in PSCore 6.1.0-preview.4 on WSL-Ub…
…untu 18.04 OS (#313)

* - Resolved Install/Save-Module error in On WSL - Ubuntu 18.04 OS with PSCore 6.1.0-preview.4
  - Removed the usage of ExcludeVersion dynamic option so that NuGet provider always downloads the packages into version appended package folder.
  - This unblocks the customers to use the Install-module and Save-Module cmdlets on Ubuntu 18.04 OS (WSL and Azure) with PSCore 6.1.0 release.
- Updated error message in Save-Module cmdlet when the specified path is not accessible.
- Added few additional verbose messages
Resolves #302 and #309

For additional details: OneGet/oneget#320

* Added changelog for 1.6.7 release
Jun 29, 2018
Fix for NuGet.exe upgrade and no to prompt (#296)
May 16, 2018
Merge remote-tracking branch 'origin/development'
Dec 5, 2017
Merge remote-tracking branch 'origin/development'
Oct 6, 2017
development to master for 1.5.0.0 version (#173)
* Changes to support require license acceptance

* Fixed empty version tag for Nuget bug (#156) (#157)
Updated generate nuget tag code to do not provide version tag for empty or null versioning dependency modules/scripts

* Added version for REQUIREDSCRIPTS (#162)

* Added versioning for REQUIREDSCRIPTS
Enabled following scenarios for REQUIREDSCRIPTS
[1.0] - RequiredVersion
[1.0,2.0] - Min and Max Version
(,1.0] - Max Version
1.0 - Min Version

* Updated ChangeLog.md and ReleaseNotes for 1.5.0.0 version (#172)
Aug 8, 2017
Merge remote-tracking branch 'origin/development'
May 15, 2017
Merge remote-tracking branch 'origin/development'