Skip to content

Arbitrary Code Execution in grunt

high severity Published May 6, 2021

Package

npm grunt (npm)

Affected versions

< 1.3.0

Patched versions

1.3.0

Description

The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.

References

CVE ID

CVE-2020-7729

CVSS Score

7.1 High
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H