Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cups-2.2.2: cupsd won't start when gssapi has been disabled during compilation #4947

Closed
Polynomial-C opened this issue Jan 19, 2017 · 2 comments
Closed
Assignees
Labels

Comments

@Polynomial-C
Copy link

@Polynomial-C Polynomial-C commented Jan 19, 2017

In Gentoo bug #606472 we got a report that cupsd from cups-2.2.2 fails to start with its default cupsd.conf file if cups has been compiled without gssapi support.
We've fixed this by conditionally removing the kerberos policy part from cupsd.conf (see gentoo/gentoo@7ee5737) but perhaps this can be fixed in a more convenient way.

@michaelrsweet

This comment has been minimized.

Copy link
Collaborator

@michaelrsweet michaelrsweet commented Jan 19, 2017

Hmm, OK, we'll look into a better long-term solution.

@michaelrsweet michaelrsweet self-assigned this Jan 19, 2017
michaelrsweet added a commit that referenced this issue Mar 9, 2017
…t don't

have Kerberos support compiled in.  The result will be a run-time access
failure that gets logged instead of stopping cupsd (Issue #4947)
@michaelrsweet

This comment has been minimized.

Copy link
Collaborator

@michaelrsweet michaelrsweet commented Mar 9, 2017

Fixed in TOT.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.