Skip to content

dart-native/codegen

master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
bin
 
 
 
 
lib
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

codegen

NPM Version Build Status

Generate Dart bindings from native code. It's based on dart_native.

You can use codegen to convert native SDK into Flutter SDK. Such as Login SDK:

Codegen is a part of DartNative. It's the cyan part(DartNative Codegen) in the picture below:

It's still under development. Here's how it works:

Installation

$ npm install -g @dartnative/codegen

Requirement

"node": ">=14"

Usage

Usage: codegen [options] <input>

Generate dart code from native API.

Options:
  -V, --version                 output the version number
  -l, --language <language>     [objc, java, auto(default)] (default: "auto")
  -o, --output <output>         Output directory
  -t, --template <template>     Generate a shareable Flutter project containing
                                modular Dart code.
                                Specify the type of project to create:
                                [package, plugin]
  --project-name <projectName>  The project name for this new Flutter project.
                                This must be a valid dart package name.
  -h, --help                    display help for command

License

BSD 3-Clause License.

About

Generator for dart_native bindings. Codegen can transform native SDK to Flutter plugin.

Topics

Resources

License

Stars

Watchers

Forks

Packages

No packages published