Skip to content
This repository

CoffeeScript support for NetBeans IDE

README.markdown

CoffeeScript support for NetBeans IDE

http://netbeans.org/

FEATURES:

  • Just works!

    • (No need for Node.js)
  • Advanced syntax highlighting

  • Error checking by background compilation

    • (Rhino JavaScript engine is used to compile *.coffee files)
  • Autocompiling to a JavaScript file in the same directory

    • (Test it in a web browser right away)
  • Syntax highlighting and error checking in scripts

    • (HTML and PHP files)
  • Indentation & formatting, code folding

  • Option to use Node.js with coffee command for compiling. Supported platforms: Mac, Linux and new experimental support for Windows.

  • Cakefile project support

VERSION HISTORY:

  • 1.4

    • Internal improvements and bugfixes
  • 1.3

    • CoffeeScript updated to v1.6.3

    • Improved *nix command line support

  • 1.2.1

    • Bugfixes
  • 1.2

    • CoffeeScript updated to v1.4.0

    • New option to set autocompile target folder

    • New option to always use UTF8 encoding for CoffeeScript files

    • NetBeans 7.3 support

  • 1.1.1

    • CoffeeScript updated to v1.3.3
  • 1.1.0

    • CoffeeScript updated to v1.3.1

    • Syntax highlight improvements

  • 1.0.2

    • Bugfixes
  • 1.0.1

    • Bugfixes
  • 1.0.0

    • Node.js compiling experimental support for Windows

    • Cakefile project support

    • Default indentation level 2spaces

  • 0.9.6

    • CoffeeScript updated to v1.2.0
  • 0.9.5

    • Code folding

    • Bugfixes

  • 0.9.4

    • Support for Node.js and coffee command compiling (Mac, Linux only)

    • Bugfixes

  • 0.9.3

    • Bugfixes
  • 0.9.2

    • CoffeeScript updated to v1.1.2

    • Rhino updated to 1.7R3

    • Bugfixes

  • 0.9.1

    • Added the support for indentation & formatting
  • 0.9

    • CoffeeScript updated to v1.1.1

    • Added syntax highlighting and error checking in scripts (HTML, PHP)

INSTRUCTIONS:

Download coffeescript-nb.nbm and add it using NetBeans plugin manager

Plugin requires NetBeans 7.0

SCREENSHOT:

screenshot2


screenshot

LICENSE:

Apache License, Version 2.0

COPYRIGHT:

2011-2013 Denis Stepanov

Something went wrong with that request. Please try again.