Latest version (3.14.0) does not work with Python 3.5 #208
As the title says, upgrading to 3.14.0 while using Python 3.5.2 will cause the following error:
It does work with Python 3.6
I have not seen any requirements for Python to be at least at version 3.6
Version 3.13.2 works just fine.
The text was updated successfully, but these errors were encountered:
Hi @JeroenEntjes ,
Thanks a lot for reporting an issue and doing investigation on it. I'm really sorry that this issue went through our testing gates :(
I've reviewed results of testing for
Please, downgrade Dependency Injector to <3.14 or upgrade your Python to >3.5.6 as a temporary solution. I will work on hotfixing it from my side in next few days.
PS: What OS do you use? Is Python 3.5.2 a system Python there? Just looking for a way to get environment with 3.5.2 without compiling it from sources...
Hi, thanks for your replies!
Indeed my temporary solution has been to downgrade Dependency Injector to a lower version. I am using Mac OS Mojave 10.14.
Don't worry about the testing gates, I know all about them. I am currently able to work just fine using a downgraded version of DI and we will soon upgrade to Python 3.6+ I figured I'd report this when it happened anyway, in case anyone else suffers from it.